Windows 7 and Defcon, 1FPS

Technical Support for all Defcon related issues

Moderator: Defcon moderators

hacker999
level0
Posts: 3
Joined: Sat Nov 28, 2009 1:32 am

Windows 7 and Defcon, 1FPS

Postby hacker999 » Sat Nov 28, 2009 1:40 am

Hi, I just got Defcon and Im running Windows 7 Home Premium 32Bit (Retail) But Defcon Runs at 1-2FPS, and Im not sure why.

Specs:

AMD Phenom 2.1GHz Tri-Core
ATI Radon HD4670 1GB
2GB DDR2 Ram

I more that Double the needs for this game and I can run Flight sim and world of Warcraft well over 60FPS on Max settings, but I only get 1-2FPS on Defcon on all low settings.

Can someone please help me.

Thanks , Josh
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Sat Nov 28, 2009 1:20 pm

The difference between those other games and Defcon is that Defcon uses OpenGL. Microsoft hates OpenGL and they do their best to cripple OpenGL support in out-of-the-box installations. Usually, you can fix poor OpenGL performance by going to the original manufacturer of your card and getting the latest stable drivers from there. If that does not work, try beta drivers; failing that, try older drivers.
hacker999
level0
Posts: 3
Joined: Sat Nov 28, 2009 1:32 am

Postby hacker999 » Sun Nov 29, 2009 1:02 am

Thanks, I'll try that.
hacker999
level0
Posts: 3
Joined: Sat Nov 28, 2009 1:32 am

Postby hacker999 » Sun Nov 29, 2009 1:05 am

Ok, I tried updating to new Drivers, and Now get about 300fps!


Works great.

Thanks

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 0 guests