[Bug] Broke vehicle pathing / spawning somehow!

(previously 'DEVELOPER') Private forum for registered community members. To register, please visit www.prison-architect.com/register.

Moderator: NBJeff

thisisgil
level1
level1
Posts: 11
Joined: Wed Sep 26, 2012 7:32 pm

[Bug] Broke vehicle pathing / spawning somehow!

Postby thisisgil » Thu Sep 27, 2012 9:59 am

I am not sure how I came to break all my deliveries but I have a suspicion.

After having a bunch of prisoners break out, I thought it would be a good idea to surround my entire prison with fencing. After doing this, no vehicle would stop at my prison. I removed my fencing, thinking that was preventing access, and currently I have the following situation:

Garbage Trucks: Non existent - the garbage area outside my prison is full of garbage bags with no trucks to pick up
Prisoner Trucks: Never stop at prison - they appear at the top of the screen, drive to the bottom of the screen, and vanish
Supply Trucks: I have a constant stream of supply trucks just driving from top to bottom - there are always between 2 - 3 on the screen at any one time. I tried dismantling them to see if that fixed anything, but they just infinitely spawn.
User avatar
gsuberland
level2
level2
Posts: 161
Joined: Wed Sep 26, 2012 7:29 pm
Location: United Kingdom
Contact:

Postby gsuberland » Thu Sep 27, 2012 10:01 am

Go into Rooms and try building another patch of Delivery and Garbage next to the road. They might just need resetting.
User avatar
weasello
level1
level1
Posts: 17
Joined: Fri Oct 06, 2006 8:30 am
Location: Victoria, BC
Contact:

Postby weasello » Thu Sep 27, 2012 7:03 pm

Yep, you can replicate this really easily and quickly on a new map:

Just build a fence between your deliveries (and/or garbage) and the road.

It appears that at least one delivery tile must touch the road otherwise the vehicles don't stop.
thisisgil
level1
level1
Posts: 11
Joined: Wed Sep 26, 2012 7:32 pm

Postby thisisgil » Thu Sep 27, 2012 7:08 pm

I tried rezoning my old delivery patch and making a new one, but no luck. Once it's broken, it's broken :(

Return to “Community Members”

Who is online

Users browsing this forum: No registered users and 1 guest