How to XFIRE with non-steam Defcon

General discussion about Defcon

Moderator: Defcon moderators

User avatar
HUNdefcon
level1
level1
Posts: 30
Joined: Sat Oct 21, 2006 9:56 pm
Location: Hungary
Contact:

How to XFIRE with non-steam Defcon

Postby HUNdefcon » Sat Oct 21, 2006 10:11 pm

I just realized that non-steam Defcon won't work with Xfire, coz Xfire asks for the steam folders and files... i hope they'l add support for non-steam Defcon too. :roll: :(
Last edited by HUNdefcon on Mon Oct 23, 2006 7:51 am, edited 1 time in total.
User avatar
B3rgil
level1
level1
Posts: 39
Joined: Sat Sep 30, 2006 9:45 am
Location: Nancy, France

Postby B3rgil » Sat Oct 21, 2006 11:29 pm

That's also my case and I hope they'll include the non-Steam version too. I noticed Darwinia (without Steam) is recognized by XFire, so...
User avatar
HUNdefcon
level1
level1
Posts: 30
Joined: Sat Oct 21, 2006 9:56 pm
Location: Hungary
Contact:

Postby HUNdefcon » Sun Oct 22, 2006 10:29 am

B3rgil wrote:That's also my case and I hope they'll include the non-Steam version too. I noticed Darwinia (without Steam) is recognized by XFire, so...


ive already flooded the xfire developer forum askin dem to release a patch...
starscream
level1
level1
Posts: 27
Joined: Fri Mar 25, 2005 11:06 pm
Location: in a sub, just off your undefended coast

Postby starscream » Sun Oct 22, 2006 9:48 pm

just browse to your xfire folder and edit defcons entry in games.ini to look like this it works for me

[4920]
LongName=Defcon
ShortName=defcon
LauncherDirKey=C:\Program Files\Defcon
LauncherExe=defcon.exe
Launch=%UA_LAUNCHER_EXE_PATH% -applaunch 1520 %UA_LAUNCHER_EXTRA_ARGS% %UA_LAUNCHER_NETWORK_ARGS%
InGameRenderer=OGL

taking thanx in easy wins please
User avatar
HUNdefcon
level1
level1
Posts: 30
Joined: Sat Oct 21, 2006 9:56 pm
Location: Hungary
Contact:

Postby HUNdefcon » Mon Oct 23, 2006 7:52 am

thanks. btw my xfire username is: yopp
if some1 want 2 play :)
cleverivan
level1
level1
Posts: 47
Joined: Fri Oct 13, 2006 2:35 am
Location: One Nuke ahead of yours

Postby cleverivan » Mon Oct 23, 2006 7:55 am

What type of program is XFire?
User avatar
GeneticFreak
level3
level3
Posts: 325
Joined: Sat Sep 30, 2006 2:43 pm
Location: Indonesia
Contact:

Postby GeneticFreak » Mon Oct 23, 2006 8:12 am

It's like an instant messenger that automatically displays what game you're currently playing and what games you like to play and allows you to directly launch the game that your contacts are playing and in some cases even connect to the same server they do.
Blessed be the LORD my strength which teacheth my hands to war and my fingers to fight
User avatar
B3rgil
level1
level1
Posts: 39
Joined: Sat Sep 30, 2006 9:45 am
Location: Nancy, France

Postby B3rgil » Mon Oct 23, 2006 8:28 am

starscream wrote:just browse to your xfire folder and edit defcons entry in games.ini to look like this it works for me

[4920]
LongName=Defcon
ShortName=defcon
LauncherDirKey=C:\Program Files\Defcon
LauncherExe=defcon.exe
Launch=%UA_LAUNCHER_EXE_PATH% -applaunch 1520 %UA_LAUNCHER_EXTRA_ARGS% %UA_LAUNCHER_NETWORK_ARGS%
InGameRenderer=OGL

taking thanx in easy wins please

Thanks starscream, but it apparently doesn't work for me... :?
User avatar
HUNdefcon
level1
level1
Posts: 30
Joined: Sat Oct 21, 2006 9:56 pm
Location: Hungary
Contact:

Postby HUNdefcon » Mon Oct 23, 2006 9:05 am

I also had to reinstall xfire, than modify the ini file, write c:\program files\defcon to the path, click "installed" and apply. it has to work, i just managed to do it on the other pc as well
User avatar
Dudeinacrate
level1
level1
Posts: 23
Joined: Mon Oct 09, 2006 8:50 pm
Location: Far as possible from N. Korea

Postby Dudeinacrate » Mon Oct 23, 2006 3:46 pm

starscream wrote:just browse to your xfire folder and edit defcons entry in games.ini to look like this it works for me

[4920]
LongName=Defcon
ShortName=defcon
LauncherDirKey=C:\Program Files\Defcon
LauncherExe=defcon.exe
Launch=%UA_LAUNCHER_EXE_PATH% -applaunch 1520 %UA_LAUNCHER_EXTRA_ARGS% %UA_LAUNCHER_NETWORK_ARGS%
InGameRenderer=OGL

taking thanx in easy wins please


Worked perfectly for me. Thanks mate! :D
User avatar
B3rgil
level1
level1
Posts: 39
Joined: Sat Sep 30, 2006 9:45 am
Location: Nancy, France

Postby B3rgil » Mon Oct 23, 2006 9:42 pm

HUNdefcon wrote:write c:\program files\defcon to the path, click "installed" and apply

Now it works, thank you.
starscream
level1
level1
Posts: 27
Joined: Fri Mar 25, 2005 11:06 pm
Location: in a sub, just off your undefended coast

Postby starscream » Mon Oct 23, 2006 9:48 pm

my bad... forgot to tell you to go to xfire options and tell it its installed after modifying .ini file

sorry guys...

now wanna add me to your xfires will be nice seeing defconners on there

my xfire id is s7ar5cr3am
sapi
level1
level1
Posts: 38
Joined: Mon Oct 02, 2006 1:42 am

Postby sapi » Tue Oct 24, 2006 9:17 am

Nice - i could use some defconners on my xfire...

xfire = sap1
starscream
level1
level1
Posts: 27
Joined: Fri Mar 25, 2005 11:06 pm
Location: in a sub, just off your undefended coast

Postby starscream » Thu Oct 26, 2006 12:52 am

my apologies but *bumps* for those who missed it
User avatar
kikinchaz
level2
level2
Posts: 125
Joined: Thu Sep 14, 2006 9:58 pm
Location: UK
Contact:

Postby kikinchaz » Sun Oct 29, 2006 1:06 am

Whilst were on the topic of xfire usernames add me - lucifon

ChaZ

Return to “General”

Who is online

Users browsing this forum: Google [Bot] and 6 guests