did DEFCON just mess with my sound settings?

Technical support for all issues relating to Defcon Linux

Moderator: Defcon moderators

Posts: 6
Joined: Tue Jul 08, 2008 12:50 pm

did DEFCON just mess with my sound settings?

Postby earthpig » Mon Jun 14, 2010 9:35 pm

hi, ill just copy/paste my thread from ubuntuforums.org, and adjust the formatting appropriately.

skip to SKIP TO HERE to see why this may be a DEFCON-related issue.

copypasta to follow:


problem: starting yesterday, around update time, sound ceased working. after restarting, sound output is still not working. the applet is stuck on 'mute all', and is greyed out.

opening the sound preferences from the applet, and going to the 'output' tab, i see that the only device for sound output available to me is 'dummy output'. screenshot attached, to clarify.

rhythmbox, and other things that play sound, don't object to me hitting the 'play' button... time ticks as if they where playing sound, but it is still muted.

running alsamixer from the command line...

Code: Select all

[chris: ~]$ alsamixer
cannot open mixer: No such file or directory

i am certain alsamixer is installed.

running gnome-alsamixer returns an empty window with the usual menu items at the top. selecting anything, however, returns this:

Code: Select all

[chris: ~]$ gnome-alsamixer

[COLOR="MediumTurquoise"](it opens, then i click on a menu item...)[/COLOR]

(gnome-alsamixer:2353): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed
Segmentation fault

ive clicked through all the obvious tabs and whatnot in the sound preferences.

possible cause:

-update is the most likely one, of course.
-DEFCON, the game.


something else interesting... yesterday, after updating, i kept using my computer even though it told me to restart. i was in the middle of playing [url="http://www.introversion.co.uk/defcon/downloads/"]DEFCON[/url], and kept playing. the defcon sound kept working, but all other sound died. "all well", i figured, "im sure the wonkyness will sort itself out next time i restart".

no dice.

DEFCON isn't 'installed' in the traditional sense, you just extract it and run as user (not root). it was downloaded directly from the vendor's website. i don't see how this could cause breakage.

anyways, advice or ideas?


update - ok, so it definately WAS something DEFCON did while running with normal user privileges. when i logged into another account, sound worked perfectly. logging back into "chris", it no longer works again. anyone know the dotfile or whatever that i can simply delete to restore this username's sound preferences to default?


ok, it's definately something with this specific user. running "sudo alsamixer" works fine, but just "alsamixer" does nada. my intuition tells me it's something i should be able to fix without being root, since all users work except this one.


logging into a different username, i can go to the sound preferences applet -> hardware tab -> see the 'internal audio' device listed, along with several profiles and whatnot. logged in as my main (broken) user, the area below "Choose a device to configure:" is completely blank, and no profiles are listed.
Posts: 6
Joined: Tue Jul 08, 2008 12:50 pm

Postby earthpig » Mon Jun 14, 2010 9:57 pm

solved. it was unrelated to DEFCON, i think. I don't think it had anything to do with DEFCON after all, just odd timing. here is the documentation, if anyone is curious: http://ubuntuforums.org/showthread.php?p=9460933

Return to “Linux Troubleshooting”

Who is online

Users browsing this forum: No registered users and 0 guests