New Administrator Entity not working

Discussion about Mods for Prison Architect

Moderator: NBJeff

Jam_Jam
level0
Posts: 1
Joined: Fri Nov 10, 2017 8:40 am

New Administrator Entity not working

Postby Jam_Jam » Sun Nov 12, 2017 8:12 am

Is there a way to make new administrators work? I have this script but when I try to require the admin it just pops up as Required: none. I can't find any solution online, please help!

Materials.txt:

Code: Select all

BEGIN Object
    Name                 VicePrincipalOB
    Price                -1000 
   Upkeep             -200
    RenderDepth          2 
    ViewRange            3
    Toughness            5
    BlockedBy            Wall
    BlockedBy            StaticObject 
    BlockedBy            UtilityStation 
    Research             VicePrincipalRE
    Sprite               Warden
    Properties           Entity
    Properties           Administrator
    Properties           Staff
    Equipment            Clipboard
END


Research.txt

Code: Select all

BEGIN Research   
    Name                 VicePrincipalRE
    Type                 Entity
    Time                 180
    Cost                 -500
    Admin                Warden
    Requires             Warden   
    Sprite               Warden
    X                    400 
    Y                    390 
    NonWideX             540 
    NonWideY             40 
END

BEGIN Research
    Name                 SharedDorms
    Type                 Ability
    Admin                VicePrincipalOB
    Requires             VicePrincipalRE
    Cost                 -1000
    Time                 360
    X                    400 
    Y                    490 
    NonWideX             920 
    NonWideY             180 
END


baselanguage.txt

Code: Select all

object_viceprincipalob  Vice Principal
research_viceprincipalre  Vice Principal
research_shareddorms    Shared Dormitories

Return to “Modding”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest