Game Crashing when I click Join Game

Technical Support for all Defcon related issues

Moderator: Defcon moderators

PharaohsVizier
level0
Posts: 5
Joined: Wed Jun 30, 2010 8:40 pm

Game Crashing when I click Join Game

Postby PharaohsVizier » Wed Jun 30, 2010 8:49 pm

I just bought this game off steam, and basically I was enjoying it just fine on my netbook, but on my desktop computer (running Vista), it crashes the moment I try to join any game. Anyone know what's going on?
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Thu Jul 01, 2010 9:10 am

When Defcon crashes, it leaves a blackbox.txt file behind in the installation folder. Could you post that, and debug.txt from the same folder? Clear out your authentication key first. Also, your system specs would probably help.

Blind guess: crashes when joining a game have been network activity related in the past. For example, what the BigFoot network adapters do to your system has been found harmful at times, and Norton Internet Security was responsible for a fair share of problems itself.
User avatar
Ace Rimmer
level5
level5
Posts: 10803
Joined: Thu Dec 07, 2006 9:46 pm
Location: The Multiverse

Postby Ace Rimmer » Thu Jul 01, 2010 3:16 pm

We need two things here:

1. A stick for all the new people that bought Defcon from the Steam sale summarizing all of bert's solutions to the various problems.

2. A stipend for bert for all his solutions to the various problems.
Smoke me a kipper, I'll be back for breakfast...
PharaohsVizier
level0
Posts: 5
Joined: Wed Jun 30, 2010 8:40 pm

Postby PharaohsVizier » Thu Jul 01, 2010 7:30 pm

First off, thanks bert for replying in such a timely fashion. I appreciate it. And at Ace Rimmer, there's really no need to bash people posting on the forums is there? You go to the support site for Defcon, and they tell you to post your problems on the forum. You aren't very considerate if you think most people buy a game just so that they can read through an entire forums worth of solutions.

To be fair, I did read most of his older posts, so I can tell you that I've gone through the trouble of turning off firewalls, port forwarding, etc so far. I also cleared my authentication key, trying to join games as a demo user as well as tried to repaste my key. Needless to say, neither things worked out well.

I didn't get any forum of a blackbox.txt file, I'm not sure if that is a clue or anything, the game does crash, but doesn't generate a blackbox.txt. The debug.txt is:

Code: Select all

Defcon 1.6 STEAM built Jun 23 2010
Parsing archive main.dat...DONE
Found language 'english' with caption 'English' in 'data/language/english.txt'
Found language 'french' with caption 'Français' in 'data/language/french.txt'
Found language 'german' with caption 'Deutsch' in 'data/language/german.txt'
Found language 'italian' with caption 'Italiano' in 'data/language/italian.txt'
Found language 'spanish' with caption 'Español' in 'data/language/spanish.txt'
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 60ms
Parsing International data (2753 islands) : 12ms
Parsing City data (2745 cities) : 19ms
Parsing archive sounds.dat...DONE
Authentication key set : 'STEAMC-NDWYYY-LDHDSH-TMZEUK-TPY'
WinSock started
Connection established to MetaServer on port 5008. Listening on Port 5009
SteamAPI_Init SUCESS
Steam Authentication Initiated
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = 76561197963673373
Steam Authentication : Getting Steam3 Auth
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Requesting Authentication
Steam Authentication Accepted : FULL GAME USER
Authentication key set : 'STEAMC-NDWYYY-LDHDSH-TMZEUK-TPY'
Received Authentication : STEAMC-NDWYYY-LDHDSH-TMZEUK-TPY : (keyID 1305741) : Accepted
Authentication HashToken set to -1868016690
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
CLIENT : Disconnected
EclRemoveWindow failed on window LOBBY
Local IP address is: 192.168.1.112
WinSock started
Server started on port 5010
CLIENT : Attempting connection to Server at 192.168.1.112:5010...
Int Data not found : dr
SERVER: New Client connected from 192.168.1.112:5011 (version 1.6 STEAM)
SERVER: Client at 192.168.1.112:5011 requested ID.  Sent ID 0.
Largest server letter sent : 81 bytes
Started requesting public IP:port for socket 1156
MetaServer enabling UDP broadcast for LAN discovery...SUCCESS
MetaServer : WAN registration enabled
CLIENT : Received ClientID of 0
CLIENT : Server version is 1.6 STEAM
MetaServer : LAN registration enabled
Server has set the MOD path: ''
CLIENT : Received HelloClient from Server
Socket 1156 identified as public IP 207.6.228.105:51835
SERVER: New team request from 192.168.1.112:5011
Largest server letter sent : 83 bytes
Requesting data from MetaServer : DemoLimits
Received data from MetaServer : DemoLimits
Largest server letter sent : 95 bytes
SERVER: New team request from 192.168.1.112:5011
SERVER: New team request from 192.168.1.112:5011
SERVER: New team request from 192.168.1.112:5011
SERVER: New team request from 192.168.1.112:5011
SERVER: New team request from 192.168.1.112:5011
Largest server letter sent : 191 bytes
App RandSeed = 1371
Parsing City data (2745 cities) : 22ms
Num nukes given to each team on start : 232
Population of Team #0 : 100.0 Million spread over 25 cities
Population of Team #1 : 100.0 Million spread over 25 cities
Population of Team #2 : 100.0 Million spread over 25 cities
Population of Team #3 : 100.0 Million spread over 25 cities
Population of Team #4 : 100.0 Million spread over 25 cities
Population of Team #5 : 100.0 Million spread over 25 cities
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Largest server letter sent : 365 bytes
EclRemoveWindow failed on window Side Panel
EclRemoveWindow failed on window Placement
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
Requesting data from MetaServer : ServerTTL
Received data from MetaServer : ServerTTL
CLIENT : Sending disconnect...
CLIENT : Disconnected
SERVER : Shutting down...
SERVER : Sent Disconnect to client 0
SERVER : Shut down complete
Disconnected from MetaServer


Lastly, my system specs are:
HP m8200n
AMD Athlon(tm) 64 X2 Dual Core Processor 6000+, 3.00GHz
3.00GB RAM
Microsoft Vista Service Pack 1, 32bit
ATI Radeon 4650

Not sure what else you might need. Again, thanks for the help!
User avatar
Ace Rimmer
level5
level5
Posts: 10803
Joined: Thu Dec 07, 2006 9:46 pm
Location: The Multiverse

Postby Ace Rimmer » Thu Jul 01, 2010 7:55 pm

PharaohsVizier wrote:First off, thanks bert for replying in such a timely fashion. I appreciate it. And at Ace Rimmer, there's really no need to bash people posting on the forums is there? You go to the support site for Defcon, and they tell you to post your problems on the forum. You aren't very considerate if you think most people buy a game just so that they can read through an entire forums worth of solutions.

To be fair, I did read most of his older posts, so I can tell you that I've gone through the trouble of turning off firewalls, port forwarding, etc so far. I also cleared my authentication key, trying to join games as a demo user as well as tried to repaste my key. Needless to say, neither things worked out well.
Not sure what else you might need. Again, thanks for the help!

I'm going to guess it's related to your sound driver? (from a quick google search of this forum)

Also, I wasn't bashing anybody, I was simply saying we need a *Sticky (thread) to "help" all the new people so you *don't* have to rummage through the forum to find what you need. I was actually trying to be helpful by proxy. Sorry if you misunderstood.
Smoke me a kipper, I'll be back for breakfast...
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Thu Jul 01, 2010 11:20 pm

That debug.txt is from a (successful, it seems, all the TTL lines hint at a reasonably long runtime) local game. Sorry, I forgot to mention that the file is cleared every time the program is run, so you'll need to do whatever it takes to crash it and salvage debug.txt immediately afterwards.
PharaohsVizier
level0
Posts: 5
Joined: Wed Jun 30, 2010 8:40 pm

Postby PharaohsVizier » Thu Jul 01, 2010 11:57 pm

@Ace Rimmer - I guess I jumped the gun on that one. Sorry. As for the sound card, I'm not entirely sure what I can do about that. The drivers are the latest version already, it's a Creative Audigy.

@bert the turtle - should have figured that one out :P The debug.txt is now:

Code: Select all

Defcon 1.6 STEAM built Jun 23 2010
Parsing archive main.dat...DONE
Found language 'english' with caption 'English' in 'data/language/english.txt'
Found language 'french' with caption 'Français' in 'data/language/french.txt'
Found language 'german' with caption 'Deutsch' in 'data/language/german.txt'
Found language 'italian' with caption 'Italiano' in 'data/language/italian.txt'
Found language 'spanish' with caption 'Español' in 'data/language/spanish.txt'
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 56ms
Parsing International data (2753 islands) : 12ms
Parsing City data (2745 cities) : 17ms
Parsing archive sounds.dat...DONE
Authentication key set : 'DEMOHN-ETJTQT-GZYBWS-QYEXFH-QJZ'
WinSock started
Connection established to MetaServer on port 5008. Listening on Port 5009
SteamAPI_Init SUCESS
Steam Authentication Initiated
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = 76561197963673373
Steam Authentication : Getting Steam3 Auth
Steam Authentication : Requesting Authentication
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Requesting data from MetaServer : DemoLimits
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Received data from MetaServer : DemoLimits
Received Authentication : DEMOHN-ETJTQT-GZYBWS-QYEXFH-QJZ : (keyID -1) : Accepted
Auth Key accepted as DEMOKEY : DEMOHN-ETJTQT-GZYBWS-QYEXFH-QJZ
Steam Authentication Accepted : FULL GAME USER
Authentication key set : 'STEAMD-DGQJZH-AWGNIF-RTCRUV-JLE'
Received Authentication : STEAMD-DGQJZH-AWGNIF-RTCRUV-JLE : (keyID 1307769) : Accepted
Authentication HashToken set to 1292662328
Requesting data from MetaServer : UpdateURL
Started requesting public IP:port for socket 440
Received data from MetaServer : UpdateURL
Socket 440 identified as public IP 207.6.228.105:53792
Local IP address is: 192.168.1.112
Char Data not found : dv
Char Data not found : dm
Char Data not found : dn
Char Data not found : dv
CLIENT : Disconnected
EclRemoveWindow failed on window LOBBY
Stopped requesting public IP:port for socket 440
EclRemoveWindow failed on window Enter IP Manually
CLIENT : Attempting connection to Server at 71.178.199.225:5010...
Requesting connection to 71.178.199.225:5010 via matchmaker


Still no blackbox though.
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Fri Jul 02, 2010 9:23 am

That looks like it's crashing on network action all right. Hmm, but no blackbox. Is there perhaps a Windows crash report? If there is any prompt ("Application XXX needed to close..." popup), you should be able to generate a report from that; memory is a bit hazy, but I think there's an option to send an error report to Microsoft along with a 'show what is sent' button.
PharaohsVizier
level0
Posts: 5
Joined: Wed Jun 30, 2010 8:40 pm

Postby PharaohsVizier » Fri Jul 02, 2010 9:13 pm

Alrighty:

Code: Select all

Product
Defcon

Problem
Stopped working

Date
29/06/2010 6:03 PM

Status
Not Reported

Problem signature
Problem Event Name:   APPCRASH
Application Name:   Defcon.exe
Application Version:   1.0.0.1
Application Timestamp:   4c223555
Fault Module Name:   AVLibrary.dll
Fault Module Version:   0.0.0.0
Fault Module Timestamp:   4b0de69a
Exception Code:   c0000005
Exception Offset:   0000e376
OS Version:   6.0.6001.2.1.0.768.3
Locale ID:   4105
Additional Information 1:   fd00
Additional Information 2:   ea6f5fe8924aaa756324d57f87834160
Additional Information 3:   fd00
Additional Information 4:   ea6f5fe8924aaa756324d57f87834160
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Sat Jul 03, 2010 12:46 am

Aha. AVLibrary.dll is not something that is supposed to be there, and it's the origin of the crash (not necessarily the cause). Can you find out which software package it belongs to and whether its removal fixes the problem?
A quick google search turned up this as a likely candidate: Hide-The-IP, an anonymization service? That shouldn't require to register a DLL to be called on network activity. Standard VPN techniques work just as well, I'd give HotSpot Shield a try.

Edit: yep, I went ahead and installed hide-the-ip here, and sure enough, joining internet games crashed. Uninstalling fixed that. I realize it's a paid service, so you may not want to uninstall it (even temporarily while you want to nuke the world); maybe twiddling with some options will make you find a workaround.
PharaohsVizier
level0
Posts: 5
Joined: Wed Jun 30, 2010 8:40 pm

Postby PharaohsVizier » Sat Jul 03, 2010 1:22 am

*clap clap*

Thank you so much, I am genuinely impressed that you isolated the problem to a specific program, and was dead on. Uninstalled Hide-my-IP, everything started working. Interestingly enough, I have hotspot shield installed in my netbook, both were used to watch Hulu :P
Infernokoi
level0
Posts: 2
Joined: Wed Jul 07, 2010 3:25 am

Postby Infernokoi » Wed Jul 07, 2010 3:28 am

Sorry to intrude here but I'm also having a similar problem, when I try to join a game Defcon will just crash out. However I can host games perfectly ok, UNLESS I have been onto the join game screen prior, at which point it will also crash :P I got the debug.txt after I loaded the game and immediately went to join one and this is what I got:

Defcon 1.6 STEAM built Jun 23 2010
Parsing archive main.dat...DONE
Found language 'english' with caption 'English' in 'data/language/english.txt'
Found language 'french' with caption 'Français' in 'data/language/french.txt'
Found language 'german' with caption 'Deutsch' in 'data/language/german.txt'
Found language 'italian' with caption 'Italiano' in 'data/language/italian.txt'
Found language 'spanish' with caption 'Español' in 'data/language/spanish.txt'
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 21ms
Parsing International data (2753 islands) : 9ms
Parsing City data (2745 cities) : 14ms
Parsing archive sounds.dat...DONE
Authentication key set : 'STEAMJ-FOOJYZ-EFJLYO-ZJSFPG-BEP'
WinSock started
Connection established to MetaServer on port 5008. Listening on Port 5009
SteamAPI_Init SUCESS
Steam Authentication Initiated
Steam Authentication : Logging On To Steam
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = 76561197995257009
Steam Authentication : Getting Steam3 Auth
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Requesting Authentication
Requesting authentication of key STEAMJ-FOOJYZ-EFJLYO-ZJSFPG-BEP
Steam Authentication Accepted : FULL GAME USER
Authentication key set : 'STEAMJ-FOOJYZ-EFJLYO-ZJSFPG-BEP'
Received Authentication : STEAMJ-FOOJYZ-EFJLYO-ZJSFPG-BEP : (keyID 1318399) : Accepted
Authentication HashToken set to 591798288
Started requesting public IP:port for socket 3760
Requesting data from MetaServer : UpdateURL
Socket 3760 identified as public IP 94.0.71.210:5011
Local IP address is: 192.168.0.88
Received data from MetaServer : UpdateURL
CLIENT : Disconnected
EclRemoveWindow failed on window LOBBY
Stopped requesting public IP:port for socket 3760
EclRemoveWindow failed on window Enter IP Manually
CLIENT : Attempting connection to Server at 69.224.37.234:5010...
Requesting connection to 69.224.37.234:5010 via matchmaker
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Wed Jul 07, 2010 10:12 am

Just like for the previous poster, you should use the windows crash report dialog thing to extract details of the crash, or post the blackbox.txt file if it's there.
Infernokoi
level0
Posts: 2
Joined: Wed Jul 07, 2010 3:25 am

Postby Infernokoi » Thu Jul 08, 2010 4:20 am

When I get one of those prompts and go to see the details of the crash I get a hugeeeeee list of stuff that isn't in the same format as the previous poster's and I can't copy it, there appears to be a list of 'modules' with various information underneath then a HUGE wall of what appears to be random numbers/letters :S and there is no such thing as a blackbox.txt in my folder :(
User avatar
bert_the_turtle
level5
level5
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Thu Jul 08, 2010 9:59 am

Then just look for the "Fault Module Name: " line and copy it by hand.
(The way to get the full info is to note where the information is saved. It's stored in some .txt file. You can open that in an editor.)

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest