Weird lag problem - heartbeat like lag

Technical Support for all Defcon related issues

Moderator: Defcon moderators

--gabe
level0
Posts: 4
Joined: Sat Feb 16, 2008 12:42 am

Weird lag problem - heartbeat like lag

Postby --gabe » Sat Feb 16, 2008 12:50 am

Hey guys, hope you can help me with the following problem. I recently bought Defcon and when I'm ingame there are short lags about 1-2 times a second.
My system:
GeForce 8800GT (FW169.21)
AMD Athlon 64 X2 5000+
2 GB of Corsair DDR2 RAM
ECS 6100SM-M Mainboard
DX 9.0c
Win XP Pro SP2
This might help:
Image

If there is anything else you need, just tell me!

Thank you,
--gabe
User avatar
Pox
level5
level5
Posts: 1786
Joined: Sat Mar 03, 2007 11:23 am
Location: Melbourne

Postby Pox » Sat Feb 16, 2008 1:01 am

What graphics drivers are you running?
Do you have the latest patch for defcon?
--gabe
level0
Posts: 4
Joined: Sat Feb 16, 2008 12:42 am

Postby --gabe » Sat Feb 16, 2008 3:39 pm

as i said, forceware 169.21

and im playin the game over steam, doesnt that mean it updates automatically?
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sat Feb 16, 2008 4:57 pm

Did you try changing the affinity of the process in Task Manager to 0?
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
--gabe
level0
Posts: 4
Joined: Sat Feb 16, 2008 12:42 am

Postby --gabe » Sat Feb 16, 2008 6:14 pm

is that the priority? and if it is, which level would that be, the highest or the lowest?
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Sat Feb 16, 2008 6:46 pm

No, the affinity, like he said. You have a dual core processor, right? Well Defcon sometimes has trouble with dual core processors. So set the affinity to 0 - meaning it will run on a single core only (I believe). This may help you. :)
Here is my signature. Make of it what you will.
Image
--gabe
level0
Posts: 4
Joined: Sat Feb 16, 2008 12:42 am

Postby --gabe » Sat Feb 16, 2008 8:54 pm

unfortunatly that didnt help. by the way, when assigned to both cores, the cpu usage of defcon is at approx 80-100%, when assigned to one of the two cores its just 40-60% on one core (not the total system)

EDIT: k, well it seems to have to do something with other programs which interrupt defcon. setting the priority on "real time" reduces the lag well
User avatar
Azati Prime
level1
level1
Posts: 56
Joined: Sat May 20, 2006 4:45 am
Location: California
Contact:

Postby Azati Prime » Mon Mar 17, 2008 7:39 am

I get that problem in some other games occasionally. Sometimes it's not a problem at all while other times my frame rate bobs up and down making it unplayable. Not sure what causes it.
Image
The enemy's gate is down.

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest