Auth problems? Hosting issues? no servers listed? *ReadMe*!!

Technical Support for all Defcon related issues

Moderator: Defcon moderators

stevie_vee
level0
Posts: 6
Joined: Thu Oct 05, 2006 9:22 pm

Auth problems? Hosting issues? no servers listed? *ReadMe*!!

Postby stevie_vee » Thu Oct 05, 2006 9:45 pm

Alright guys (and girls)

Seems to be a lot of problems with everyone connecting.

I had similar issues, but i hate to be defeated so had a play and have found what seems to be a possible solution.

I have a system which worked fine when i first installed Defcon. It authenticated and i could see other people playing. i just couldnt seem to get anoyone to connect to me.

I had a play and suddenly my system did all the stuff you guys are having.......authentication status on "checking" and no servers listed for me to join.....

In the end I have found the following works for me:

Set ports 5008-5011 to allow send/recieve UDP in your SOFTWARE firewall. This has already been done by most of you (if not, get on with it)

If you have a router you obviously need to mess with port forwarding. This seems to be the bit thats causing the issue!

I found forwarding ports 5008-5011 (all of which defcon uses) allowed people to connect to me, but i couldnt authenticate or connect to others.
Disabling the forwarding let me join to other peoples games and authenticate, but they couldnt join to me???

Upshot of this is....ONLY FORWARD PORT 5010. DO NOT set port forwarding on ports 5008-5009 and port 5011. these will stop you authenticating!

Wierd Eh?
Note: also set 'port forwarding' in DEFCON network setttings to 'Enabled'

These are based on default PORTS as instaled by DEFCON.

I've done a fair bit of testing and this seems to fix all problems. I have tried this on 3 of the 5 terminals on my network, using WIN XP and win 2k. Zonealarm and norton firewall. This fixes every one I have done the tests on so far.

Hope this helps some of you guys.
User avatar
Mighty Santa
level2
level2
Posts: 150
Joined: Tue Sep 19, 2006 5:10 pm
Location: London, UK
Contact:

Postby Mighty Santa » Fri Oct 06, 2006 6:05 pm

thanks for all that.

I'm something of a tech, but frankly, the more I try to see all this up, the more confused I get.
--

Is it something about the game that makes all this networking a mess for seemingly most players, or is typical for most new games these days?
4, 8, 15, 16, 23, 42
davejk
level1
level1
Posts: 36
Joined: Mon Sep 18, 2006 11:47 pm

Postby davejk » Fri Oct 06, 2006 6:30 pm

Networking has been fine for me and a few others on site, and I'm going through about six internal routers and a Squid proxy...
User avatar
MrBunsy
level5
level5
Posts: 1081
Joined: Mon Apr 24, 2006 4:40 pm
Location: Southampton
Contact:

Postby MrBunsy » Fri Oct 06, 2006 10:08 pm

Bizzare solution indeed, but if it works..! Out of interest, which ISP do you use? There might be a link.

Mighty Santa wrote:or is typical for most new games these days?
Typical unfortunatly, what with most people owning a router and a decent firewall now.
cornix
level0
Posts: 3
Joined: Sat Oct 07, 2006 10:14 am
Contact:

Postby cornix » Sat Oct 07, 2006 10:28 am

Another important thing (I just found out after painful hours of wondering why my DefCon won't auth)

I didn't try this with a direct version from IV yet, but it solved all my problems with my Steam version.

DefCon(Steam) does send a DNS request everytime it starts, trying to find metaserver.introversion.co.uk. Now, in my home/company network, we got 2 DNS servers. One for Internet stuff and one for Intranet. Now, if you only got the Intranet-DNS set in your connection settings (this was the case for the auto-configuration I received from our DHCP), you'll have a hard time getting a reply for a DNS-request about an Internet server.

Solution: Set the Internet-DNS as the primary DNS server in your connection settings and the Intranet one as the alternative (may also work vice versa)

IF THIS DOESN'T HELP: I found this out by simply using a packet sniffer on my PC: Wireshark. It showed me that my PC sent an UDP-packet with a DNS request for metaserver.introversion.co.uk and as an answer got an ICMP-packet that it can't find the server because the port is unreachable. This way it lead me to my solution. What I want to say with this is: IF my solution didn't help you, and you're somewhat computer savvy and/or got enough patience to look through the logs any try to find out what's happening: Download Wireshark and find out!
graduateduser
level1
level1
Posts: 55
Joined: Mon Aug 20, 2018 10:29 am

Re: Auth problems? Hosting issues? no servers listed? *ReadMe*!!

Postby graduateduser » Fri Oct 26, 2018 12:38 pm

stevie_vee wrote:Alright guys (and girls)
Seems to be a lot of problems with everyone connecting.
I had similar issues, but i hate to be defeated so had a play and have found what seems to be a possible solution.
I have a system which worked fine when i first installed Defcon. It authenticated and i could see other people playing. i just couldnt seem to get anoyone to connect to me.
I had a play and suddenly my system did all the stuff you guys are having.......authentication status on "checking" and no servers listed for me to join....
In the end I have found the following works for me:
Set ports 5008-5011 to allow send/recieve UDP in your SOFTWARE firewall. This has already been done by most of you (if not, get on with it)
If you have a router you obviously need to mess with port forwarding. This seems to be the bit thats causing the issue!
I found forwarding ports 5008-5011 (all of which defcon uses) allowed people to connect to me, but i couldnt authenticate or connect to others.
Disabling the forwarding let me join to other peoples games and authenticate, but they couldnt join to me???
Upshot of this is....ONLY FORWARD PORT 5010. DO NOT set port forwarding on ports 5008-5009 and port 5011. these will stop you authenticating!

Wierd Eh?
Note: also set 'port forwarding' in DEFCON network setttings to 'Enabled'

These are based on default PORTS as instaled by DEFCON.
I've done a fair bit of testing and this seems to fix all problems. I have tried this on 3 of the 5 terminals on my network, using WIN XP and win 2k. Zonealarm and norton firewall. This fixes every one I have done the tests on so far.
Hope this helps some of you guys.



Our hosting marketplace offers various hosting services, allowing to fulfill the most complex tasks. The main goal is to provide the level of service, allowing you to concentrate on business development and not on IT infrastructure. Our project always goes in time with IT progress, we follow all technologies and know-how, increasing our knowledge to create products that can meet the requirements of all customers tomorrow and today. If you want to more details please visit here. https://inxy.hosting/

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest