Page 3 of 9

Posted: Wed May 02, 2007 8:59 pm
by frenchfrog
Really depends on Ambrosia software.

Posted: Thu May 03, 2007 9:55 am
by KingAl
Indeed. if you want updates, pester them about it.

Posted: Tue May 08, 2007 4:16 pm
by brunnenguk
This patch seems to have a curious bug. There are files encrypted at level 8. Decrypter only goes to level 7.

Help! :(

Posted: Tue May 08, 2007 4:49 pm
by frenchfrog
I think it always been like this. I don't remember touching file encryption levels.

Posted: Wed May 09, 2007 3:07 am
by KingAl
Indeed, this has happened before. It's simply a complication to your missions though - i.e. you won't get paid in full - rather than a game breaker, and I've never really considered it a bug.

Posted: Tue May 29, 2007 10:30 am
by MarianG
Is this a bug?.
I read that you can hack into dead agests PC's.
I've complete Mole Mission. The dead of several agents appeared in the news.
And now I'm trying to hack into them but no result. I wan not easy to get the IP for the PC but I did it, still nothing. The same message appears. Something like "No external log ... , Please leave now."
I have a question, can you put the IP for each agent in the "Uplink_Agents_list". Hacking into all targets on screen, and following the links, takes 2 or 3 days.

Posted: Tue May 29, 2007 10:34 am
by KingAl
There is only 1 personal computer in the entire game that you can hack. If take a look at the logs in the ARC central mainframe when the dead agent e-mail arrives, you might be able to find it.

Posted: Tue May 29, 2007 7:42 pm
by Mr.Me
Ok, so i've been reading the forum, i checked the faq's, but i'm not able to find an answer to my question. Why can't i install the latest patch?
Oh, and i'm running an online, english, pc version.
The problem is this, i can't click on ok, to install the patch in the folder.(to replace the first exe file.).
The path and drive are correct, but still the ok button won't work.

Anybody have an idea on how this can be solved?
Let me know, ok?
Thx in advance!!

Greetz!!

Posted: Tue May 29, 2007 9:50 pm
by frenchfrog
Mr.Me wrote:i'm running an online, english, pc version.


If that 'online' version is not directly from Introversion you are out of luck. If it's Steam it will update itself automatically (you may try the Steam beta to try the latest patches). Other then that, be sure to select the right directory, worse case, try redownloading and reinstalling Uplink.

Posted: Wed May 30, 2007 12:08 pm
by Mr.Me
Thx for the quick reply!!

The online version i bought, was directly from Introversion. (Bought it online in 2005). Last week, after buying a new pc, i installed it again. (with the downloadlink wich was provided upon purchase). Registered the product again, and started playing. Untill the fatal error occured...... :cry: Then i started to look up some info, and came here.
How do i tell if it's Steam? :?:
In the other case, i will try downloading and reactivation again.

Greetz!!!

Posted: Wed May 30, 2007 12:13 pm
by KingAl
Steam is an online content delivery service - if you don't know what it is, you don't have the Steam version ;)
Check in your Uplink directory to see if there's a text file called something like errorlog.txt - it might give shed light on what the fatal error was caused by.

Posted: Thu May 31, 2007 4:37 pm
by Mr.Me
Ok, in the debug log i found this.

An Uplink Assertion Failure has occured
=======================================
Condition : *(condition [i]-1) == ' '
Location : C:\Development\Uplink\source\World\Computer\recordbank.cpp, line 136
============== B E G I N C O R E D U M P =================
retAddress = 004CCCD3
============== E N D C O R E D U M P =====================

I think that it went wrong here.....(i think...... :? ). Maybe i should send this to the support section and see what they come up with??
Or should i send the complete debug log?

Greetz!!

Posted: Thu May 31, 2007 6:35 pm
by frenchfrog
You should post in the Bug Reports section in the future.

Was this report done in Uplink 1.55 with an agent created in 1.55?

Posted: Sat Jun 02, 2007 5:41 am
by Parafox
I thought I'd give Uplink a try in linux, so I installed version 1.31 from my cd, which ran fine (after I deleted the libgcc file) , but whenever I patch it to 1.55 it wont load.

Here's the relevent part of my debug.log:

===============================================
NEW GAME 18:4, 31/5/2007
===============================================
Version : 1.55
RELEASE
Linux Build
Version 1.55 (RELEASE)
Compiled on Mar 19 2007 at 13:34:53
(code-C)(code-M)(code-T)
Loading uplink options from /home/parafox/.uplink/options...success


An error occured in Uplink
Files integrity is not verified

An Uplink Error has occured
Files integrity is not verified
Saving uplink options to /home/parafox/.uplink/options...success

Posted: Sat Jun 02, 2007 5:54 am
by KingAl
It won't 'load' as in it won't start? Try deleting your existing options file - since it gets buggered up there and I believe it creates options if there are none present (though this may not be true of the linux version).
Make sure you start a new agent file when you get the new patch to avoid future problems, also.