Uplink 1.55 Patch/Demo (Windows/Linux)

Discussion about the latest patch

Moderators: bert_the_turtle, jelco, Rkiver, frenchfrog, JamesL

User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Uplink 1.55 Patch/Demo (Windows/Linux)

Postby frenchfrog » Mon Mar 19, 2007 5:08 pm

As usual, download the windows patch, linux patch or linux patch with installer.
View the full changelog here.
The windows demo, linux demo.


On linux, if you hit a crash, please report the relevant part of the ~/.uplink/debug.log file, please also report the distro you are using. All testing was done on Ubuntu 6.06 .




There was some major changes in this patch, please test.




VERSION 1.55

- Fixed : Crashes with invalid floating point operations.
- Fixed : Problem on Linux with .dat files directly in Uplink directory and not in the lib/ sub directory. (Happen when upgrading from some older version of Uplink to a newer version)
- Fixed : A crash with LANs having invalid location. (check the debug.log to see the warnings)
- Fixed : A crash with LANs having invalid links. (check the debug.log to see the warnings)
- Fixed : A crash with LANs having modems without phone number.
- Fixed : Crashes with PasswordBreaker/DictionaryHacker if their target screen isn't there anymore.
- Fixed : Crashes with tasks if their interface isn't there anymore.

- Added : A code card (codecard.txt) to the online download version of Uplink.
- Added : Software rendering option to the Windows version of Uplink. Also change to software rendering if the game crash during OpenGL initialization.
- Added : Show Bank IP on the Finance interface.

- Changed : Steam Authentication is now done with the help of a external DLL, this should permit new MODs to work with Steam.
- Changed : Much better error handling on Linux and some minor tweaks to error handling on Windows.
- Changed : Loading a corrupted saved game (agent) should now show a message box instead of crashing.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Fri Mar 23, 2007 2:21 pm

Ok, the files should now be accessible.
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
viciarg
level1
level1
Posts: 10
Joined: Fri Oct 13, 2006 8:17 am

Postby viciarg » Sun Mar 25, 2007 9:15 am

Code: Select all

user@host:~$ uplink
/usr/local/games/uplink
/usr/local/games/uplink/lib/uplink.bin.x86: /usr/local/games/uplink/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
user@host:~$ gcc -dumpversion
4.2.0
user@host:~$ cat /proc/version
Linux version 2.6.19 (root@host) (gcc version 4.1.2 20061028 (prerelease) (Debian 4.1.1-19)) #7 SMP Sun Jan 21 18:00:48 CET 2007


Uplink full download v1.31 purchased several months ago and played extensively on win xp, installed on Debian, patched to v1.55, got "GCC_4.2.0 not found" first time, downloaded GCC 4.2.0 tarball, ./configure && make && make install w/o problems, did the whole Uplink install'n'patching again, same thing - that was my night. Let's see, what the day brings. Has anyone an idea?

Thank you.
Humanas actiones non ridere, non lugere, neque detestari; sed intellegere curavi.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sun Mar 25, 2007 5:33 pm

Try deleting /usr/local/games/uplink/lib/libgcc_s.so.1

Only necessary .so files should be :
lib/libfreetype.so.6
lib/libftgl.so.0
lib/libSDL-1.2.so.0
lib/libSDL_mixer-1.2.so.0
viciarg
level1
level1
Posts: 10
Joined: Fri Oct 13, 2006 8:17 am

Postby viciarg » Sun Mar 25, 2007 6:23 pm

Thank you, this brought something new:

Code: Select all

/usr/local/games/uplink
=============================
=                           =
=        U P L I N K        =
=                           =
=        Version 1.55       =
=     - R E L E A S E -     =
=                           =
=============================

Version 1.55 (RELEASE)
Compiled on Mar 19 2007 at 13:34:53
(code-C)(code-M)(code-T)

An Uplink Internal Error has occured: segmentation violation (SIGSEGV)

An Uplink Internal Error has occured during graphics initialization

An (unrecognised) Uplink Internal Error has occured
===================================================
See the /home/viciarg/.uplink/debug.log file for more informations on the error


The referred debug.log:

Code: Select all

===============================================
NEW GAME     19:20, 25/3/2007
===============================================
Version : 1.55
RELEASE
Linux Build
Version 1.55 (RELEASE)
Compiled on Mar 19 2007 at 13:34:53
(code-C)(code-M)(code-T)
Loading uplink options from /home/viciarg/.uplink/options...failed

=====DEBUGGING INFORMATION ENABLED=====
Loading application data
Successfully loaded data archive data.dat
Successfully loaded data archive graphics.dat
Successfully loaded data archive loading.dat
Successfully loaded data archive sounds.dat
Successfully loaded data archive music.dat
Successfully loaded data archive fonts.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat
Successfully loaded data archive patch3.dat
Finished loading application data
Init_Game called...creating game object
Finished with Init_Game
Saving uplink options to /home/viciarg/.uplink/options...success
Initialising SDL...
Uplink has been forced to Abort
===============================
 Message   : Could not initialize SDL: No available video device.
 Location  : app/opengl.cpp, line 94

An Uplink Internal Error has occured: segmentation violation (SIGSEGV)

An Uplink Internal Error has occured during graphics initialization

An (unrecognised) Uplink Internal Error has occured
===================================================
============== B E G I N  C O R E  D U M P =================
retAddress = 0x804f43b
retAddress = 0x80f9b76
retAddress = 0xb7fd0420
retAddress = 0x80faffa
retAddress = 0x80fb2e8
retAddress = 0x80fb3be
retAddress = 0xb7b64ea8
retAddress = 0x804d5b1
============== E N D  C O R E  D U M P =====================


Edit:
okay, i started it from Debian|Games menu and it worked. Now it wanted to have a verification code from a black card in the cd tray, which i don't have since i only ordered the download version.

My Paypal payment information etc. still available, if needed for verification needs.
Humanas actiones non ridere, non lugere, neque detestari; sed intellegere curavi.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sun Mar 25, 2007 6:59 pm

Redownload from the store and reapply the 1.55 patch, it then shouldn't ask for a code.
viciarg
level1
level1
Posts: 10
Joined: Fri Oct 13, 2006 8:17 am

Postby viciarg » Sun Mar 25, 2007 10:22 pm

Thank you, now it works.
Humanas actiones non ridere, non lugere, neque detestari; sed intellegere curavi.
lassombra
level1
level1
Posts: 18
Joined: Wed Mar 28, 2007 12:26 am

Postby lassombra » Wed Mar 28, 2007 1:21 am

I just purchased from the store a few hours ago. I had played it on a friends computer, who had the FBI mod installed, and decided to buy it.

The download version works great, but when I try to run the FBI mod on it, it keeps asking for the code.

When I read that the code card was included in the patch I decided to download and install the patch. It did not seem to create a codecard.txt file anywhere. I would really like to be able to play the FBI mod, but can't.

How can I get this file? Will I have to wait till the online store download version is updated? Or can I get it some other way. I am a legitimate customer, and my uplink version is working fine, just want to be able to play the FBI mod.
Last edited by lassombra on Wed Mar 28, 2007 10:04 pm, edited 1 time in total.
You wake up to see a shadow receding.

You sit up to find a cold sweat revealing:

Lassombra was here.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Wed Mar 28, 2007 2:39 pm

lassombra wrote:Will I have to wait till the online store download version is updated?


Officially, yes.

But you should be able to get a code card in the meantime if you contact the support with your store account info.
lassombra
level1
level1
Posts: 18
Joined: Wed Mar 28, 2007 12:26 am

Postby lassombra » Wed Mar 28, 2007 9:06 pm

Thanks, I decided it wasn't necessary, I'll just wait till the box shows up, or it is updated. Wonderful game btw, I really enjoy it. Now if I can just figure out how to play it and get my necessary sleep at the same time...
You wake up to see a shadow receding.



You sit up to find a cold sweat revealing:



Lassombra was here.
joda
level0
Posts: 3
Joined: Fri Apr 13, 2007 10:34 am

can't install the patch

Postby joda » Fri Apr 13, 2007 10:40 am

hello,

first: sorry for my english :?

i have the german retail-version of uplink.

my problem: i can't patch uplink to 1.55

uplink is installed on drive g:

i start the patch - i choose the correct drive and folder - but i can't push the ok-button (button is grey)
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Fri Apr 13, 2007 2:58 pm

This patch is for the Introversion PC english version only.
joda
level0
Posts: 3
Joined: Fri Apr 13, 2007 10:34 am

Postby joda » Fri Apr 13, 2007 8:50 pm

This patch is for the Introversion PC english version only.


??? that's the first game with patches for just one language-version :shock:

what's the problem to patch the other versions? the fixes has no relation to the language...
User avatar
Montyphy
level5
level5
Posts: 6745
Joined: Tue Apr 19, 2005 2:28 pm
Location: London, England

Postby Montyphy » Fri Apr 13, 2007 9:04 pm

joda wrote:
This patch is for the Introversion PC english version only.


??? that's the first game with patches for just one language-version :shock:


No, it's not. In fact, some games have different patches for US and UK that may not match.

joda wrote:what's the problem to patch the other versions? the fixes has no relation to the language...


Depends on how it was coded and who did the translation. ;)
Uplink help: Check out the Guide or FAQ.
Latest Uplink patch is v1.55.
joda
level0
Posts: 3
Joined: Fri Apr 13, 2007 10:34 am

Postby joda » Fri Apr 13, 2007 9:27 pm

No, it's not. In fact, some games have different patches for US and UK.


i meant: the first game with patches for just one language - and no patch for the other versions...

Depends on how it was coded.


you're right.

let me say so: i have payed the same price for my german version like other people for their english version - can't i expect the same support?

Return to “Latest Patch”

Who is online

Users browsing this forum: No registered users and 2 guests