Page 2 of 2

Posted: Sun Oct 15, 2006 9:24 pm
by frenchfrog
Known problem, font rendering is partly broken on linux, probably because of some changes in the inner working of some libraries (perhaps X server when the switch was made between Xfree and Xorg), who knows. The exact same code (and libraries) works well on windows.

Posted: Mon Oct 16, 2006 3:07 am
by offsides
Well, it's unfortunate and frustrating... What library is it? I'm more than happy to try and test/investigate, and I'm not afraid to dig code/straces (though I don't have the DevCD, and I can't really justify spending $53 for it). I'd also love it if you could fix the problem that causes Uplink to max out the CPU on Linux - it seem like a display rendering issue, as when the window is open X uses most of the CPU, but when the window is minimized (and thus not visible) uplink.bin.x86 is using most of the CPU.

As a full-time Linux user (my primary workstations at both home and work are Linux, as is my job focus), it's nice to find games that I like to play that don't require windows. I'ts unfortunate that they tend to get the short end of the support (which is understandable given the smaller userbase, but still...)

Thanks for putting the effort to make Uplink even better!

Posted: Mon Oct 16, 2006 3:07 pm
by frenchfrog
The libraries in question are FTGL and GLTT (Uplink can work with either of these).

GLTT use freetype1 and FTGL use freetype2. Perhaps there something on my build system that screw up those libraries, but like I said earlier, who knows.

Posted: Mon Oct 16, 2006 11:46 pm
by D-Struct
Did you already updated the DevCD?

I would grab one next month and then updating the linux binaries for various distributions, if possible.

Badly I can not afford one this month, but in november I will order one. ;-)



Posted: Tue Oct 17, 2006 2:47 am
by offsides
Are you statically linking against the font libraries? If so, can you release a patch that dynamically links against them? I just installed the latest FTGL ebuild and can test that version (2.1.2) for you. GLTT is deprecated (hasn't been updated since 2001) and is slated for removal from the gentoo tree...

Posted: Tue Oct 17, 2006 3:14 am
by frenchfrog
In the coming days I'll try to provide a dynamicly linked version of Uplink. (for the font library)

Posted: Tue Oct 17, 2006 3:26 pm
by D-Struct
frenchfrog wrote:In the coming days I'll try to provide a dynamicly linked version of Uplink. (for the font library)

Hopefully this will help, thanks for your continuing support. ;-)

Posted: Wed Oct 18, 2006 5:36 am
by erpfoo
Never saw a reply regarding the running on linux x86_64. So far nothing has worked that I have tried. Did I miss a link/recommend someplace?

strace dumps on:
$here/lib/uplink.bin.x86 "$@"

Which seems indicative of an SDL issue. I have not done any more r&d. See below.

Using both provided gcc and SDL
./lib/uplink.bin.x86: ./lib/ version `GCC_4.2.0' not found (required by /usr/lib/

Using provided libSDL
Version 1.50 (RELEASE)
Compiled on Oct 9 2006 at 23:57:43
./uplink: line 44: 19224 Segmentation fault $here/lib/uplink.bin.x86 "$@"

Using niether
Version 1.50 (RELEASE)
Compiled on Oct 9 2006 at 23:57:43

Posted: Wed Oct 18, 2006 2:40 pm
by frenchfrog
I cannot help, I don't have a x86_64 box .

Perhaps post the relevant part ~/.uplink/delog.txt

Posted: Thu Oct 19, 2006 2:21 am
by erpfoo
I was not sure if I should continue this post here since I just tried 1.51 and I get the same results between 1.50 and 1.51. Below is the output of 1.51.

I find it odd its complaining about the iniability to initialize SDL video when 1.3 works fine and other games work fine. ie: Neverwinter Nights (uses SDL), UT2K, Q4 etc. Not sure how to persue this and if its x86_64 related or system specific.

Maybe its the recent (but seriously OLD) bug/exploit in nvidia drivers. LOL

NEW GAME 20:40, 18/10/2006
Version : 1.51
Linux Build
Version 1.51 (RELEASE)
Compiled on Oct 16 2006 at 20:26:49
Loading uplink options from /home/daeamarth/.uplink/options...success

Successfully loaded data archive data.dat
Successfully loaded data archive graphics.dat
Successfully loaded data archive loading.dat
Successfully loaded data archive sounds.dat
Successfully loaded data archive music.dat
Successfully loaded data archive fonts.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat
Successfully loaded data archive patch3.dat
Warning, difference in depth between the video mode requested 16 and the closest available 32 for width: 1024, height:768, flags:2

Uplink has been forced to Abort
Message : Could not initialize SDL Video: Couldn't find matching GLX visual.
Location : app/opengl.cpp, line 111
============== B E G I N C O R E D U M P =================
retAddress = 0x804dc2f
retAddress = 0x805298d
retAddress = 0x811004a
retAddress = 0x8110102
retAddress = 0x48a714e4
retAddress = 0x804d841
============== E N D C O R E D U M P =====================
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Posted: Thu Oct 19, 2006 3:59 pm
by frenchfrog
Try starting Uplink with the '!graphics_screendepth 32' on the command line. See the readme.txt for more informations.