Page 4 of 4

Posted: Tue Oct 03, 2006 8:33 pm
by Kinping
frenchfrog: Awesome man! You did it. TRYC worked for me and in the log I do not have anything that could not be accessed. Everything workes flawless!!!

Thank you!

Posted: Wed Oct 04, 2006 12:08 am
by jokeyrhyme
I can report success with 1.49TRYC as well. Yay!

And I had no problems with 1.49 on Windows either.

Is there any word on when these patches will become official? What exactly are you aiming for? When you fix the font thing in Linux, I'd say these babies are good to go.

Posted: Wed Oct 04, 2006 6:34 am
by le_jawa
I just tried running with a clean install and patched straight to 1.49TRYC. The screen blanks and changes resolution, then the game just quits and leaves my resolution all goofed up (I still get my 1600x1200, but it's with a vritual desktop running with a 1024x768 screen view).

My OS is Ubuntu Linux 6.06 IA32. Here's the debug.log:

Code: Select all

NEW GAME     1:22, 4/10/2006
Version : 1.49TRYC
Linux Build
Version 1.49TRYC (RELEASE)
Compiled on Oct  3 2006 at 01:02:26
Loading uplink options from /home/jason/.uplink/options...failed

Loading application data
Successfully loaded data archive sounds.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat
Finished loading application data
Init_Game called...creating game object
Finished with Init_Game
Initialising SDL...done
 SDL is now opening a 1024x768 window in 32 depth ...done
 SDL is now changing the window caption and diverse settings ...done
 Initialising OpenGL...
Finished initialising OpenGL.
Now registering callback functions...done
 Init_Fonts called...setting up system fonts
REDSHIRT : Failed to load file : /home/jason/bin/uplink/lib/fonts/dungeon.ttf
Unable to open font : fonts/dungeon.ttf
True type font support is DISABLED
Finished with Init_Fonts
 Init_Sound called...setting up sound system
Compiled with SDL_mixer version: 1.2.7
Running with SDL_mixer version: 1.2.7
Finished with Init_Sound
Init_Music called...loading modules
Finished with Init_Music
Creating main menu.
REDSHIRT : Failed to load file : /home/jason/bin/uplink/lib/music/bluevalley.uni

I presume this is the aforementioned ttf bug. I don't know if the music error at the end is critical or not. I should add that I moved my options and .usr files for testing, but that did no good.

I hope all this helps.

Posted: Wed Oct 04, 2006 2:43 pm
by frenchfrog
SysRq wrote:You might want to make a note on the patch that it requires all the .dat files to be in lib/ *maybe this was required with 1.3x and I just wasn't paying attention, I did a clean install to test this). It would also be nice if uplink would output a error message that says something along those lines if it can't find them. Currently it just says "====== END OF DEBUGGING INFORMATION ====
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/music/bluevalley.uni" etc so someone who doesn't know what's going on wouldn't think they didn't have that file period not knowing the .dat files are just containers with the content within them

I guess I'll put a note on first post.

Ah, gotcha

Posted: Wed Oct 04, 2006 9:06 pm
by le_jawa
I guess I should've read back a bit further. Thanks for the tip.

patch 1.49 question

Posted: Sat Oct 07, 2006 7:25 pm
by lexus
Dos the patch 1.49 is inly for Linux or i can intall it with in windows xp?

Posted: Sat Oct 07, 2006 11:41 pm
by jokeyrhyme
lexus: If you go to the beta patch site you will find patches for Windows and Linux. The Windows ones end in ".exe" and the Linux ones end in ".tar.gz".

The increased amount of Linux-related chatter here is only a result of the 1.49 patch being released for Linux. Until now, only the Windows version was being updated.

If they release a new patch, it is almost always going to have a Windows version. Sometimes the Linux version lags behind.

Posted: Mon Oct 09, 2006 7:47 pm
by idle
i've updated my uplink and it works... (i havn't test it complete).
i'm using gentoo 1.12.5 (gcc-4.1.1).

BUT i think the font is crap :D

Posted: Tue Oct 10, 2006 6:19 am
by Kakalto
Idle, it does mention the font issue in the top post :wink:

Posted: Sun Aug 26, 2012 5:24 am
by V10lator
Could anybody with deep insights please jump into this:

Thanks. :)