Uplink Quits Unexpectedly on Start

Discussions on the Mac release

Moderators: bert_the_turtle, jelco, Chris, Icepick, Rkiver, Punisher Bass

Posts: 1
Joined: Thu Aug 16, 2012 4:05 am
Location: Canada

Uplink Quits Unexpectedly on Start

Postby shadexx6 » Thu Aug 16, 2012 4:25 am

I just bought Uplink from the most recent Humble Bundle (for Android 3, I think?) I got a Steam key for it and downloaded it through Steam. However, as soon as I click "play" the application will pop up in my hot bar, immediately disappear and say "Uplink quit unexpectedly". I've tried redownloading the game and verifying the cache. Both didn't help. Any help would be greatly appreciated.

I've also tried to download the application itself from Humble Bundle. Ran into problems here in that part of the text, mostly the first letter or two, has disappeared. Every time I try, I've gotten stuck on the local waypoint screen (the map with the six or seven cities on it). No matter what I do on that screen, be it click any where or hit any button, I can not move past this screen. There are no buttons visible anywhere.

Any help would be appreciated. Thank you!
Posts: 1
Joined: Sat Aug 18, 2012 1:16 am

I am fine without the mods

Postby ranmocy » Sat Aug 18, 2012 2:07 am

What is your version of MacOS and your macbook? Something about the video card?

I am using Mountain Lion with my Macbook Air 4,2. I download it directly from Humble Bundle.
Everything is fine here except mods. I add a gateway mod to ~/Library/Application Support/Uplink/mods/.
It can be started, but crashed as soon as I load my profile. The same when I try to create a new profile.

It seems that it is also a Steam version. I search the Ambrosiasw forum, but there is a topic said the Steam version is not maintained by them.
I tried Ambrosiasw trial version. It didn't crashed but didn't load the mods any way.

Can't I use mods under Mac OSX? All I wish is to add a gateway!

The debug.log as following:

Code: Select all

NEW GAME     8:53, 18/8/2012
Version : 1.6.2
Mac OS X Build
Version 1.6.2 (RELEASE)
Compiled on Aug  7 2011 at 20:51:02

Loading uplink options from /Users/ranmocy/Library/Application Support/Uplink/options...success

Successfully loaded data archive data.dat
Successfully loaded data archive graphics.dat
Successfully loaded data archive loading.dat
Successfully loaded data archive sounds.dat
Successfully loaded data archive music.dat
Successfully loaded data archive fonts.dat
Compiled with SDL_mixer version: 1.2.7
Running with SDL_mixer version: 1.2.11
Loading profile from /Users/ranmocy/Library/Application Support/Uplink/Ranmocy.usr...REDSHIRT : Failed to load file : /Applications/Uplink_1.6.2.app/Contents/MacOS/../Resources/data/gateways/NanosTECH2.txt

An Uplink Assertion Failure has occurred
 Condition : rsFilename
 Location  : /Users/chrisdelay/Development/UplinkMac/trunk/sources/3rdparty/uplink/source/uplink/src/world/generator/worldgenerator.cpp, line 488
============== B E G I N  C O R E  D U M P =================
============== E N D  C O R E  D U M P =====================
Posts: 4
Joined: Wed Jan 09, 2013 12:27 am

Postby TurbulentEddie » Wed Jan 09, 2013 1:05 am

For custom gateway on OS X Steam, see: http://forums.introversion.co.uk/uplink ... 902#435902

Return to “Mac Uplink”

Who is online

Users browsing this forum: No registered users and 1 guest