Gateway Images Not Showing Up

Moderated discussion about Uplink

Moderators: bert_the_turtle, jelco, Chris, Icepick, Rkiver, Punisher Bass

Posts: 10
Joined: Fri Jan 27, 2012 4:12 pm
Location: PA

Gateway Images Not Showing Up

Postby Kitkun » Sat Jul 27, 2013 5:04 pm

Let me explain...

I have downloaded and played this a few times before, and I have modded the game most of those times, usually just Skins and Gateways. I've never had any issues before.

Since then, like years since then, I have finally gotten around to replaying the game, and I have decided to use Steam to play it. Installation went smooth, game works fine as-is.

Then, I went to ModLink, and downloaded my usual Skins and Gateways, I like, and installed them, as I usually do, "data" to the "data\gateways" folder, and "graphics" to the "graphics\gateway" folder.

Now then, when I open, whether I start a new character or just use an existing one, the Gateways show up in the list, at least, their info does. You can buy them as well; however, there is no picture, small or big, of the game. It just shows an "X" in the top left corner of the map, and I do not understand why.

Any help would be greatly appreciated!

Thanks in advance!
Posts: 6
Joined: Fri Aug 31, 2012 8:59 am

Postby JAFO » Wed Aug 07, 2013 9:30 am

Recently I purchased Uplink again (the old 1.31 version on my CD wouldn't install on Linux Mint) and ran into a similar problem.

On checking, it turned out that the folder and file permissions for the various gateways I tried to install weren't set correctly. I had to open a root-mode file browser and change the 'group' and 'others' permissions to 'access files'.

After that, everything works properly.. are you using Linux or a Mac? If so, permissions might be your problem.

Edit to add:
Further to the above, I found one gateway that still wouldn't display, and just had an 'X' in the corner, like you mentioned. It turned out that the file extension for the pic was in uppercase (.TIF) instead of lowercase (.tif). Since the game expects to see ".tif", on a case-sensitive OS such as Linux, this means the game doesn't recognise it.

Renaming the extension to lowercase solved the problem.
Posts: 1
Joined: Sat Aug 10, 2013 9:29 am

Postby jamaika » Sat Aug 10, 2013 3:14 pm

Thanks JAFO i had the same problem and with your suggestions i fixed it :D

Return to “Uplink in Moderation”

Who is online

Users browsing this forum: No registered users and 1 guest