Page 1 of 1

Custom Gateways (and Other Mods?) in OS X Steam (v. 1.6.6)

Posted: Wed Jan 09, 2013 12:51 am
by TurbulentEddie
I am running the latest version of Uplink available (1.6.6) for OS X on Steam. I have attempted to install the NeoTrinity gateway modfrom the (unofficial) Modlink site.

It seems that the correct place to put the files is under:

Code: Select all

/Users/<username>/Library/Application Support/Uplink/mods

Under this location, here is what my tree looks like with the mod installed:

Code: Select all


Starting Uplink and attempting to log in then leads to "An Uplink Assertion Failure." Here is the relevant entry in the debug.log (caching Steam ID, username removed):

Code: Select all

NEW GAME     17:38, 8/1/2013
Version : 1.6.6
Mac OS X Build
Version 1.6.6 (RELEASE)
Compiled on Aug 28 2012 at 17:49:44

Loading uplink options from /Users/<username>/Library/Application Support/Uplink/options...success

Successfully loaded data archive data.dat
Successfully loaded data archive graphics.dat
Successfully loaded data archive loading.dat
Successfully loaded data archive sounds.dat
Successfully loaded data archive music.dat
Successfully loaded data archive fonts.dat
Compiled with SDL_mixer version: 1.2.12
Running with SDL_mixer version: 1.2.12
Loading profile from /Users/<username>/Library/Application Support/Uplink/A.usr...REDSHIRT : Failed to load file : /Users/<username>/Library/Application Support/Steam/SteamApps/common/Uplink/

An Uplink Assertion Failure has occurred
 Condition : rsFilename
 Location  : /Users/Andrew/Documents/UplinkMac/sources/3rdparty/uplink/source/uplink/src/world/generator/worldgenerator.cpp, line 488
============== B E G I N  C O R E  D U M P =================
============== E N D  C O R E  D U M P =====================
Setting breakpad minidump AppID = 1510
Steam_SetMinidumpSteamID:  Caching Steam ID:  XXXXXXXXXXXXXXXXX [API loaded no]

I have tried just about every file permission combo on the NeoTrinity files (.txt and .tif) in case that was causing them not to be read, but to no avail. Nothing about the mod-created directories' properties seem different than usual, either.

This is not a new bug by any means; there are two other reports of this happening in the Mac Uplink support forum: ... 484#435484 ... 445#435445

Neither thread has a resolution posted, so I thought I would bring it to attention here. Let me know if I can provide any more info. I have not tested if other types of mods work.

Posted: Wed Jan 09, 2013 1:04 am
by TurbulentEddie
And as quickly as I posted that, I think I have figured a workaround, though it isn't pretty. Notice the location that the mod is being loaded from:

Failed to load file : /Users/<username>/Library/Application Support/Steam/SteamApps/common/Uplink/

Perhaps this is where files should actually be installed, but I found symlinks work just as well:

Code: Select all

cd /Users/<username>/Library/Application\ Support/Steam/SteamApps/common/Uplink/
ln -s /Users/<username>/Library/Application\ Support/Uplink/mods/* .
ls -l | grep "@"
lrwxr-xr-x  1 <username>  staff       59 Jan  8 17:56 data@ -> /Users/<username>/Library/Application Support/Uplink/mods/data
lrwxr-xr-x  1 <username>  staff       63 Jan  8 17:56 graphics@ -> /Users/<username>/Library/Application Support/Uplink/mods/graphics
lrwxr-xr-x  1 <username>  staff       60 Jan  8 17:56 music@ -> /Users/<username>/Library/Application Support/Uplink/mods/music
lrwxr-xr-x  1 <username>  staff       61 Jan  8 17:56 sounds@ -> /Users/<username>/Library/Application Support/Uplink/mods/sounds

Now the custom gateway install works (bought, 24h+logout+login, looked at hardware, success!).

Upon some more careful searching of the forum, that this is the location to install mods is hinted at in the Steam user's thread, but anything you all can do to make this clearer? [/quote]

Re: Custom Gateways (and Other Mods?) in OS X Steam (v. 1.6.

Posted: Sat Jan 03, 2015 2:18 am
by CivilizationLord
First off, thank you so much for the troubleshooting. I was one of the people with the exact same problem. It seems that the modding documentation for Uplink is scattered. There is a mods folder in the Uplink Folder, even though the release notes say that it should be in Application Support. On top of that, it won't even run the mods when you figure it out!

I tried running your code through terminal, but when I got to the permissions part (lrwxr-xr-x) it responded with "command not found." I'm running the newest OS X, Yosemite. Any help would be appreciated. Thank you!