Linux twinview problem

For problems with the game

Moderators: bert_the_turtle, jelco, Chris, Icepick, Rkiver, Punisher Bass

Absum
level0
Posts: 3
Joined: Wed Apr 02, 2008 3:41 am

Linux twinview problem

Postby Absum » Wed Apr 02, 2008 11:03 am

Hi, i'm running Ubuntu 7.10 and Uplink 1.55 the problem is that Uplink, no matter what settings, always goes fullscreen but only draws halfscreen. My current setup is with two screens on a nvidia 6800 GPU and when i start Uplink it creates a 2720x1024 window but only draws on one of the screens (which is 1024x768)

Anyway, end of rambling, hope i made some sense. I love this game but don't want to run it in wine just to play it.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Thu Apr 03, 2008 12:26 am

Normally Uplink enumerate available screen resolutions and pick the closest to 1024x768. If Uplink picks 2720x1024 it means Uplink don't see any lower resolution.
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
Absum
level0
Posts: 3
Joined: Wed Apr 02, 2008 3:41 am

Postby Absum » Thu Apr 03, 2008 2:43 am

But running uplink in a user set resolution or in windowed mode is out of the question?
orillian
level4
level4
Posts: 585
Joined: Fri Nov 16, 2007 8:41 pm

Postby orillian » Thu Apr 10, 2008 9:32 pm

look in the options, there is a setting to choose the resolutions just about every thing from 6x8 to 12x7 and more
Absum
level0
Posts: 3
Joined: Wed Apr 02, 2008 3:41 am

Postby Absum » Fri Apr 11, 2008 12:21 am

Well, one problem would be me not being able to see the options since the buttons are drawn offscreen.
idle
level0
Posts: 6
Joined: Fri Sep 15, 2006 7:49 pm

Postby idle » Wed Sep 03, 2008 5:46 pm

try to add this:
Option "MetaModes" "1680x1050,1680x1050; 1680x1050"
now you should see both modes in xrandr:
Screen 0: minimum 1680 x 1050, current 3360 x 1050, maximum 3360 x 1050
default connected 3360x1050+0+0 0mm x 0mm
3360x1050 50.0*
1680x1050 51.0
Gentoo
Amd 64 3700+

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest