Linux (poss. n00b) help...

For problems with the game

Moderators: bert_the_turtle, jelco, Chris, Icepick, Rkiver, Punisher Bass

shearn89
level0
Posts: 6
Joined: Mon Sep 06, 2004 4:37 pm

Linux (poss. n00b) help...

Postby shearn89 » Tue May 15, 2007 5:24 pm

Hi, I'm running Ubuntu 6.06, with Uplink 1.55. (I think) I have installed uplink correctly - i copied the zip file off the cd, unzipped it into a folder called "uplink" in my home directory, then got the patch and extracted all those files into the same folder. I then start a terminal and run the uplink script, and it spits out this... I had a look around but I only came across one similar problem, and the answer there didn' t help...
Here the console output:

alex@alexlaptop:~$ cd uplink
alex@alexlaptop:~/uplink$ ./uplink
=============================
= =
= U P L I N K =
= =
= Version 1.55 =
= - R E L E A S E - =
= =
=============================
Version 1.55 (RELEASE)
Compiled on Mar 19 2007 at 13:34:53
(code-C)(code-M)(code-T)
alex@alexlaptop:~/uplink$


No log file is created, so i can't post that. Any help would be greatly appreciated....
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Wed May 16, 2007 10:47 pm

Dunno, no ~/.uplink/ directory?

Try running Uplink under strace?
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
shearn89
level0
Posts: 6
Joined: Mon Sep 06, 2004 4:37 pm

Postby shearn89 » Thu May 17, 2007 9:12 am

===============================================
aah! that helps - here is the debug.log for the latest attempt (the others are all the same, varying slightly depending on what i tried to run)...


NEW GAME 9:4, 17/5/2007
===============================================
Version : 1.55
RELEASE
Linux Build
Version 1.55 (RELEASE)
Compiled on Mar 19 2007 at 13:34:53
(code-C)(code-M)(code-T)
Loading uplink options from /home/alex/.uplink/options...success
=====DEBUGGING INFORMATION ENABLED=====
An error occured in Uplink
Files integrity is not verified
An Uplink Error has occured
Files integrity is not verified
Saving uplink options to /home/alex/.uplink/options...success
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Thu May 17, 2007 4:18 pm

shearn89 wrote:Files integrity is not verified


You are probably missing some .dat files or less possibly some .dat files are corrupted.

Put all .dat files in the lib/ uplink subdirectory.

data.dat
fonts.dat
graphics.dat
loading.dat
music.dat
patch3.dat
patch2.dat
patch.dat
sounds.dat
world.dat
GusMan
level0
Posts: 4
Joined: Fri Nov 30, 2007 8:48 pm

Postby GusMan » Fri Nov 30, 2007 9:38 pm

I had a similar problem with Uplink, I tried running under strace, but i still did not get a debug.log created, and still no Uplink.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Fri Nov 30, 2007 10:39 pm

Do you run the latest patch? (Currently 1.55)

Is there anything printed on the console?
Roujin
level0
Posts: 1
Joined: Sat Mar 01, 2008 11:00 pm

Postby Roujin » Sun Mar 02, 2008 12:54 am

How did you get it to even run?
I am also using Ubunto 6 and i cant even get the main file to start
Ive set the permissions to exxecute but nothing
Ive got all the data files and they are all ok
NO RUN NO LOG NO Nothing
Please tell me how u got it running this far
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sun Mar 02, 2008 3:36 pm

frenchfrog wrote:Do you run the latest patch? (Currently 1.55)

Is there anything printed on the console?

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest