Page 1 of 2

blue screen / memory dump upon running uplink

Posted: Tue Jun 20, 2006 2:14 am
by taltamir
On one of my computers I experience a windows fatal error (either a blue screen or a memory dump) between 10 seconds and 2 minutes after starting the game. It happens with the version 1.31c beta patch full version AND with the version 1.31 demo and happens every time (so its with AND without glut). It happened 5 times before I stopped trying. I don't remember this machine ever crashing before, the game is the ONLY thing that was running on it, and it stopped happenening as soon as I stopped trying to run the game (the computer is always on...)

It does have a rage128 pro video card though... so that might be the problem.

All it takes is running the game. I can just leave it in the main agent login screen for a few moments and then windows crashes.

I got a SiSoft Sandra report of the machine that is affected. I would like to post it however its a text file that is 4.59MB big uncompressed raw text so I cant just copy paste the data in here. So I have to actually upload it (its only 164kb once compressed with rar).

Posted: Tue Jun 20, 2006 11:26 pm
by taltamir
I found an old Radeon 9000 (pro i think) laying around and used it to replace the Rage 128 pro in the machine that crashes, and it STILL crashes... (it performed a memory dump within 10 seconds of running the game).

I really have no idea why it would do that. This isn't some super ancient machine (I have five of those laying around), this is my secondary machine and it is relative modern and well beyond the minimum requirements.
It has an athlon 2500+ barton core CPU with 512MB of DDR ram and now a Radeon 9000 (Pro?) with catalyst 6.5 installed on windows XP SP2. There is no reason it should memory dump or blue screen when running the game.
The fact it does BOTH instead of just one of those is the oddest part, sometimes I get a blue screen, sometimes it just resets the ram and the computer boots up again and windows gives me a notice of a fatal exception forcing it to memory dump next time it boots.

Posted: Wed Jun 21, 2006 4:32 am
by frenchfrog
Windows should _never_ blue screen because of a particuliar program.

The problem is probably with some hardware or drivers or windows.

Things to check:
-Windows Event log (accessible from computer management)
-Windows updates
-Motherboard drivers (for the agp port)
-Updates to .NET framework (since ATI drivers use .NET)
-Perhaps Directx (you never know ;) )

Also, most probably not the source of your problem but you could rename or remove opengl32.dll if it's present in Uplink directory (cause graphical glitch or slowness for any recent cards/drivers).

Posted: Thu Jun 22, 2006 1:19 am
by taltamir
windows should not... but it DOES!
I have tested it 6 times now. It takes less then a minute from when I start uplink to blue screen OR memory dump (memory dump is more common, of the 6 times only 1 was blue screen, all the rest memory dumps). The machine in question did not crash in YEARS, runs 24/7, and is used daily by me without any issues!
Also, I replaced its video card from a rage128 pro to a radeon9000 after the 5th crash and tested it again and it still crashed (within 10 seconds). And before you condensendently ask: I had the windows default drivers for the rage card (for some reason the ATI ones didn't recognize it) and I installed .NET2 and catalist 6.5 immidiatly after installing the video card. So everything was in order with the drivers.

Everything is the latest version :roll:
I'll get the dump if I knew where to find it and where to upload it to, I already have a detailed system analasys from SiSoft Sandra.. Just give me an option to upload it!

Posted: Thu Jun 22, 2006 1:55 am
by frenchfrog
Did you check if there was some logs in Windows Event log (under System or Application category)?

Else, sometimes it create a memory dump, check in C:\WINDOWS\MiniDump


** google is your friend

Posted: Thu Jun 22, 2006 9:45 am
by taltamir
where is the windows event log?

There are 4 dumps in the minidump, so appearantly it was 4 dumps and 2 blue screens and not 5 and 1 (I thought I remembered two blue screens.. meh).

I'd upload the dumps as i said before, I have nowhere to upload them to.

Posted: Thu Jun 22, 2006 6:57 pm
by frenchfrog
First, for memory dump and event log settings: Control Panel->System->'Advanced' tab->'Startup and Recovery' panel, 'Settings' button. A small memory dump should be enough.

For the Windows Event log: 'My computer'->right click context menu, 'Manage'->in the tree view 'System Tools'->'Event Viewer'

google the errors it gives you for further answers.

Posted: Fri Jun 30, 2006 6:38 am
by taltamir
so... anyone from introversion gonna provide a location to which I should send the dumps?

Posted: Fri Jun 30, 2006 1:34 pm
by Stewsburntmonkey
taltamir wrote:so... anyone from introversion gonna provide a location to which I should send the dumps?

No, they will not. It is not IV's job to deal with your computer problems. Uplink is almost certainly not the cause of the problem, just the trigger.

You have been focusing on the video card, but other drivers could be the source of the problem. The most probable suspect is the audio driver. I would update the audio drivers and if that doesn't work, I would look at some of the hardware settings (like audio acceleration, turn it down, AGP apperture size, etc).

Posted: Sat Jul 01, 2006 9:45 pm
by taltamir
Firstly whats with all the hostility? I am trying to help hunt down a major bug in the game, so get your heads out of your arses!

1. I do not need tech support. I already finished the game on my main gaming machine! I am just trying to find and fix the bug.

2. The machine worked for years, and I play many games on it. It has never crashed before or AFTER. It does however crash with 100% reproduceability when I try to run uplink.

3. In trying to find the exact incompatibility I have replaced the video card, this did not help, so I disabled the onboard sound card and put in a PCI soundcard. This solved the problem, so I now know that it is an incompatibility with the onboard sound. The onboard sound however works FINE with any other game I tried running on the same machine. So it is some sort of incompatibility with the audio on that machine. (so the detailed system specs would come in handy after all!)

Posted: Sun Jul 02, 2006 8:53 pm
by prophile
Maybe it's just that Windows sucks and you should use linux instead?

Posted: Tue Jul 04, 2006 11:16 am
by taltamir
maybe its a bug in the program... and for those who tell me that its impossible:

Spellforce: The order of Dawn tends to blue screen every now and then on intense battles after many hours of play. I have observed that on many computers. The blue screen message mentions an unreachable memory address. This is solveable by increasing the pagefile to 2GB when playing this game. People who had that problem before pointed out that my solution worked and once they allocated the extra space it solved their problem.

So here you have another example where a program causes windows to blue screen. It is possible, it happens, and it is solveable.
As far as I know spellforce was never patched for this issue, and the workaround is still used by some. Well, as far as we can see, uplink will probably not be patched with this issue aswell...

Mmmm... maybe my mistake is bringing this up in the forums... I'll look up contant info on the uplink website and just email this to them...

Posted: Tue Jul 04, 2006 11:59 pm
by frenchfrog
First, _all_ softwares have bugs, some of those bugs are known and will never get patched. (This is _not_ a good reason for not patching them).

Last Uplink patch is like 4 years old, and there is at least 50 bugs in 1.31 (the latest patch). See the following post for some of them: ... hp?t=30284

Now for your problem, your motherboard sound drivers is buggy, no surprise here, I often saw motherboard sound drivers stay at version 1.0 (even if there is full of bugs in them). Your problem is also the result of the bad driver architecture in Windows, a driver can crash Windows as a whole. (This is _suppose_ to be solved in Vista by running drivers in user land instead of kernel land). And then Uplnik trigger the bug in your driver.

Now for 'Spellforce: The order of Dawn', here again, there is multiple problems: it seems Spellforce leak memory and use tons of it, thus using all available memory and then crashing windows, which is a Windows bug (I guess windows should kill the process and regain the used memory), either way the result for the user would be the same, he would lose his game.

The major difference between Uplink and Spellforce, in this case, is that Uplink hold a minor part of the responsibility contrary were Spellforce hold the majority of it.

EDIT: memory leaks are bitch to track down, this is probably the reason the devs haven't patched them or perhaps they simply evaluated that not enough users are affected by it.

Posted: Sun Jul 09, 2006 8:37 am
by ChasM
I'm pretty sure Windows sucks,
and there are still lots of AC'97 sound equipped mobos that don't fully function.
But since Windows sucks, your sound/audio drivers may not yet be WHQL approved.
Uplink was built with Microsoft tools (except the Linux version), and
since Windows sucks, WE all get to help debug your new hardware.
Stew is correct, IV won't care (last patch four years ago).
This forum FLAMES pretty easily. Prolly because Windows sucks.
Your Athlon 2500+ is pretty quick so, what brand of mobo was that?
I'm guessing it's Asian with about 400Mhz FSB.

Posted: Tue Jul 11, 2006 11:22 pm
by taltamir
WHQL doesn't even mean anything, it was a scheme by MS to squize money from companies by requiring them to pay money to get "approved" by windows. Non WHQL approved drivers would not autoinstall (requiring manual install) and give scary warnings to users. On the other hand there are many cases where WHQL drivers don't even work properly.
EX: ... V3cywsLDE=

And in spellforce total RAM usage never went above 50% on my computer, for some reason it just tries to access a VERY VERY high ram address every once in a while.