Unity on Linux: Release Notes and Known Issues

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

dixita
level0
Posts: 9
Joined: Fri Mar 24, 2017 9:40 am
Contact:

Unity on Linux: Release Notes and Known Issues

Postby dixita » Tue Apr 11, 2017 11:29 am

Hi! This thread will be used to post new builds of Unity for Linux, including release notes and known issues.

THE LATEST AVAILABLE BUILD WILL BE IN THE LAST POST ON THIS THREAD.

Today, we're releasing the first public build, so this post contains extra information about system requirements and what you can expect. Future releases will also be posted in this thread.

Installer Types and Supported Systems

The Unity Editor for Linux is packaged into two types of installers:
A .deb package, which can be installed via the Ubuntu Software Center and is expected to work on installations of Ubuntu 12.04 or newer.
A platform-agnostic self-extracting shell script, which is designed for other distributions.
Unity Technologies is providing official support for Ubuntu 12.04 or newer. People are welcome to use other distributions with the understanding that we do not guarantee support.

Machines also need a modern graphics card with vendor-supported graphics drivers (provided by NVIDIA, AMD, or Intel).

We do not explicitly support running the Linux editor inside a virtual machine due to limitations related to GPU virtualization (although it does usually work).

Supported Target Platforms
The Unity Editor for Linux supports export to the following platforms:
Linux / Windows / Mac Standalone
Android (additional dependencies needed, see below)
WebGL (additional dependencies needed, see below)
Tizen (additional dependencies needed, see below)
SamsungTV
Legacy WebPlayer
iOS project deployment (experimental in 5.5 builds)
Dependencies and Recommended Packages
The dependencies for Unity itself are:
gconf-service
lib32gcc1 (>= 1:4.1.1)
lib32stdc++6 (>= 4.6)
libasound2 (>= 1.0.23)
libc6 (>> 2.15)
libc6-i386 (>= 2.15)
libcairo2 (>= 1.6.0)
libcap2 (>= 2.10)
libcups2 (>= 1.4.0)
libdbus-1-3 (>= 1.2.14)
libexpat1 (>= 1.95.8)
libfontconfig1 (>= 2.8.0)
libfreetype6 (>= 2.3.9)
libgcc1 (>= 1:4.1.1)
libgconf-2-4 (>= 2.31.1)
libgdk-pixbuf2.0-0 (>= 2.22.0)
libgl1-mesa-glx | libgl1
libglib2.0-0 (>= 2.31.8)
libglu1-mesa | libglu1
libgtk2.0-0 (>= 2.24.0)
libnspr4 (>= 1.8.0.10)
libnss3 (>= 3.14.3)
libpango1.0-0 (>= 1.22.0)
libstdc++6 (>= 4.6)
libx11-6 (>= 2:1.4.99.1)
libxcomposite1 (>= 1:0.3-1)
libxcursor1 (>> 1.1.2)
libxdamage1 (>= 1:1.1)
libxext6
libxfixes3
libxi6 (>= 2:1.2.99.4)
libxrandr2 (>= 2:1.2.99.2)
libxrender1
libxtst6
zlib1g (>= 1:1.1.4)
debconf (>= 0.5) | debconf-2.0
npm
The Ubuntu Software Center will install these automatically if using the .deb package. If using the self-extracting shell script (or another distribution), you're on your own.

To export players to certain targets, there are other dependencies:

For WebGL:
ffmpeg | libav-tools
nodejs
java6-runtime
gzip
For Android and Tizen:
java7-jdk
These recommended packages are included in the Recommends section of the .deb package.

We're also not currently bundling the dependencies for MonoDevelop (and doing so is a bit complicated), so the easiest way to ensure you can run the bundled MonoDevelop is to first install the upstream MonoDevelop from the Ubuntu Software Center.

Reporting Bugs

The 'Report a Bug' link currently directs users to this area of the forum, which is dedicated to feedback and issues with the Linux Editor. This is the primary location for providing feedback and reporting issues with the Linux Editor.

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest