can't change screen resolution in windowed mode

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

Tatsukishi
level0
Posts: 2
Joined: Fri Nov 25, 2011 1:47 pm

can't change screen resolution in windowed mode

Postby Tatsukishi » Fri Nov 25, 2011 2:21 pm

hey guys,
I got dar- and multiwinia with the humble bundle but I can't really play because the games lay even in windowed mode over both of my screens (laptop + external). It doesn't offer me another resolution than 3360x1200 and when i tried setting it in the preferences.txt it just rewrote the values back to that (tried 800x600 and 1024x768).
So, is there a way to force a specific resolution or am I screwed/forced to deactivate one of the screens to play?

Btw: I have Ubuntu 11.04 x64 on a Lenovo T410 with a nVidia videocard and darwinia ver. 1.43-2 and multiwinia ver. 1.3.1-1, both installed via the x64-humble-.deb.

greetings
tatsukishi
User avatar
bert_the_turtle
level5
level5
Posts: 4796
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Fri Nov 25, 2011 4:23 pm

The games only offer window sizes that match possible screen resolutions. Two ways to solve your problem:
1. Add more screen resolutions to your configuration. This may require xorg.conf editing. No need for new modelines, usually, just add a good MetaModes line.
2. Edit preferences.txt... oh, you tried already. Odd, it works for Defcon.
Tatsukishi
level0
Posts: 2
Joined: Fri Nov 25, 2011 1:47 pm

Postby Tatsukishi » Fri Nov 25, 2011 4:58 pm

It worked now with the preferences.txt, I just copied the screen-arguments form Defcon, which automatically chose 1024x768 as window size. (before that I just changed ScreenWidth and -High)
Thanks for mentioning Defcon, I didn't really realise that they use the same schema for the preferences before you mentioned Defcon, thanks for that :)

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest