What now?

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

twistx
level0
Posts: 2
Joined: Tue Oct 03, 2006 7:06 pm

What now?

Postby twistx » Thu Jan 28, 2010 6:30 am

So... installation on 64b systems is an obvious problem, and I guess the developers are off rolling around in some fat piles of cash; far to busy to support this ancient game. You'd think after 3 years of the problem being a glaring issue someone could get around making a compatible binary for customers that paid good money for the game. Maybe? Hello? I guess not.
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Thu Jan 28, 2010 8:28 am

It's the job of the 64 bit system to provide a 32 bit compatibility layer AND support for applications linked against older versions of system libraries. If you can't get it to work no matter what you do, it is, above all, a failure of your Linux distribution. (And FYI, the developers have no piles of cash to roll around in.)

Instead of complaining in a general direction, why don't you state your concrete problem? Many people have gotten it to run on various 64 bit systems, I bet one of them would be willing to help.
User avatar
dimension128
level0
Posts: 5
Joined: Mon Jan 25, 2010 10:02 am

Postby dimension128 » Fri Jan 29, 2010 3:20 pm

While I don't agree with the overall tone of the original poster. The truth is, that the ideal solution would be for IV to compile the game against the newest libraries and on a 64bit system. That way we can have an updated blob for each arch that will "just work". Not to mention, maybe the game would work better with the latest SDL system? I don't know if there would be a difference. But I do know that when I try to make the game use my systems SDL sound stops working. All distros will be dropping these older libraries soon. Ubuntu already has. libstdc++ 5 has been considered deprecated for years now. And the loki installer is very old. Honestly I would be happy with a simple script based installer. But if a gui is needed, MojoSetup would be a good way to go.

And while you are correct in saying that the various distros should support backward compatibility, they have, for quite a long time.

And twist, if your having trouble getting the game to work on 64bit, see my post here. If you cant find anything on the forum that is helpfull, post your problem (error messages etc.) and what your system specs are.

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 6 guests