Installing Darwinia and Uplink on Ubuntu 9.10 libgtk-1.2

Problems with the Linux version of Darwinia

Moderators: jelco, bert_the_turtle, Chris, andy, John

Posts: 2
Joined: Mon Nov 16, 2009 1:31 am

Installing Darwinia and Uplink on Ubuntu 9.10 libgtk-1.2

Postby Darling1985 » Mon Nov 16, 2009 1:41 am

Hi all,

I'm trying to install Darwinia on Ubuntu 9.10 and I get the following message when trying to install the 1.4b and 1.3. I'm a bit new to linux and I am struggling with this problem.

I've read that this problem is also an issue with Uplink.

paul@paul-quad:~/Downloads$ sh
Verifying archive integrity... All good.
Uncompressing Darwinia full 1.4.0b9......................................................................
/home/paul/.setup3522: error while loading shared libraries: cannot open shared object file: No such file or directory


User avatar
Posts: 4795
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne

Postby bert_the_turtle » Mon Nov 16, 2009 10:22 am

Apparently, the installer requires libgtk version 1.2. You probably have a later version only. You'll find tons of other threads if you search for 'libgtk-1.2', most of them with stuff people have tried which may work for you. If you're running the 32 bit edition, try

Code: Select all

sudo aptitude install libgtk1.2
Posts: 2
Joined: Mon Nov 16, 2009 1:31 am

Postby Darling1985 » Fri Nov 20, 2009 1:03 am

Thanks for your help but that has not worked. It appears to be missing from the ubuntu repositories I'm searching. From a little bit of googling this seems to be a common problem as many games depend on it. Any more ideas?

Posts: 1
Joined: Wed Dec 02, 2009 1:52 am

Loki, dated but still loved

Postby pl3w5y » Wed Dec 02, 2009 2:08 am

Ubuntu have removed the files you need in 9.10 but you can install ones from 9.04, I would not expect this to break your system, I just did it on my Mythbuntu box and it's ok but your mileage may vary.

you could do this manually but just open a terminal and paste these commands in one shot:

wget ... 2_i386.deb
wget ... 1_i386.deb
wget ... d2_all.deb
sudo dpkg -i *.deb

if your using 64 bit change the 'i386' to 'amd64' on the first 2 lines
Posts: 6
Joined: Wed Jan 20, 2010 5:45 am

Installing w/o GTK libs

Postby bmr5770 » Fri Jan 22, 2010 1:12 am

See my post on the uplink forums for installing without using GTK. I know it works for Uplink, I'm not sure if it will for Darwinia.

User avatar
Posts: 5
Joined: Mon Jan 25, 2010 10:02 am

I have it working. On Ubuntu 9.10 64bit

Postby dimension128 » Wed Jan 27, 2010 4:13 am

Well I was a little scared to buy the game, because I couldn't get the demo to work properly. But I went ahead and bought it, and I had to go through a fair amount of troubleshooting/google-foo, but I have the game working!

Ill do the best I can to list the steps I took to make it work. Unfortunately I didn't really keep track, so this is all from my fragile memory.

First of all, the installer wants an old version of libgtk. In Ubuntu 9.10 this version is depreciated.
You need this even with the patches, as they also utilise the loki installer.

Part 1.
Now, if your running 32bit, your all good. Just install the following packages, then skip down to part 2. - This one is for all arch's. -- This one may or may not be needed, I'm not sure.

If your on 64bit, you need to install those packages for your arch, and then also download the 32bit versions of them.
Now extract the files from the 32bit packages to some place. On Ubuntu you can just right click on the files and use whatever 'extractor' program you have at your disposal. For me, I right click -> Open with -> Archive Manager. You want to get the "data.tar.gz" file. And then extract the contents of this file.
Once you have the files extracted from one of these packages, go into its lib folder.
All of the files inside the lib folder need to be copied to your /usr/lib32 folder. And of course this requires root.

Here are the steps to take via the command line.
(Just replace the filename with whatever package you are working with)

Code: Select all

sudo dpkg-deb -x libgtk1.2_1.2.10-18.1build2_i386.deb ./tmp #this is the command to extract the files from the .deb

Code: Select all

sudo cp ./tmp/usr/lib/* /usr/lib32/ #copying the lib files to your lib23

Code: Select all

sudo rm -R ./tmp #removing the newly created tmp folder in the current directory.

Part 2.
Now you also need to install the libstdc5 stuff.
I followed the instructions located here.

In short, its the same process, Install the package for your arch.
If your running 64bit, you also need to download the 32bit package, extract it, and put its lib files into your lib32.

Part 3.
Now, one more thing needs to happen.
Wherever you installed darwinia "/usr/local/games/darwinia" by default...
You need to go into the lib folder there, and silence the evil file.
As I understand it, Removing or renaming this file causes darwinia to look for libgcc on your system instead of using its own pre-packaged version. And doing this works for me.

Heres the command line version.

Code: Select all

sudo mv /usr/local/games/darwinia/lib/ /usr/local/games/darwinia/lib/

One last thing.
Whenever you run an update, the loki installer says "This will overwrite the game" or whatever. Just go ahead and do it. But you need to re-run the above command to kill the file again. Because running the update will put it back.

Let me know how this works for you. If you run into an error, maybe it will jog my memory and Ill be able to remember any other things I did to get this working. But I'm pretty sure this is everything that's needed.
Posts: 1
Joined: Thu Aug 19, 2010 10:16 pm

Postby Matt3223 » Sat Aug 21, 2010 12:25 am

thanks for these tips dimension128, they worked like a champ getting Darwinia to run on my Ubuntu Lucid box. :)

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest