Darwinia can't install on Fedora 9

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

yeoheric
level0
Posts: 1
Joined: Sat Aug 09, 2008 8:12 pm

Darwinia can't install on Fedora 9

Postby yeoheric » Sat Aug 09, 2008 8:22 pm

Hi,

I bought my copy of Darwinia via the Net and downloaded darwinia-complete-1.2.1b.sh about 3 weeks back. I was trying to install on my Fedora 9 machine a moment ago when I got this message:

/home/eyeoh/.setup5216: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory

I do have gtk2 stuff installed :

[eyeoh@primus Download]$ rpm -qa | grep gtk2
gtk2-devel-2.12.11-1.fc9.i386
gtk2-engines-2.14.3-1.fc9.i386
pygtk2-libglade-2.12.1-6.fc9.i386
pygtk2-2.12.1-6.fc9.i386
gtk2-2.12.11-1.fc9.i386

What did I miss? I am running the Gnome desktop with kernel 2.6.25.11-97.fc9.i686, Pentium D 3.02GHz, 2 GB RAM and an Nvidia 7600.

Please help.

Thanks.

Eric
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Sat Aug 09, 2008 10:25 pm

"libgtk-1.2"... the Loki installer is old and may not gracefully find libgtk2. You could try two things depending on your comfort level with linux.

1) just install the old libgtk1.2 file from a repository. This shouldn't cause any probs with gtk2 already installed, but I can't promise it won't cause some probs somewhere.

2) just create a symlink from a dummy libgtk-1.2 (with the correct .so filename which you can get from the error message) and point the symlink to the newer gtk2 .so file. This may or may not work depending on how much backwards compatibility there is between 1.2 and 2.x. You should be able to delete the symlink after installation. Note: this will require root priviledges.

3) search the forums about the "loki" installer -- I seem to remember there is a command line switch that bypasses the gui and just extracts everything directly. Search the web too, since loki is used by others.

Note: you will want to immediately install the 1.4.0b9 patch from the sticky thread in this forum. It is a shar script, so has no gui and no need for gtk.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sat Aug 09, 2008 10:38 pm

You need gtk1 stuff,

You may also want to try the Linux beta patch (1.4.0b9).

You may to check for further problem solving: Darwinia 1.2.1b not starting (corrected: v1.40b9).
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Sun Aug 10, 2008 12:11 am

... Darwinia doesn't need gtk at all -- it's not linked in the executable. Only the old loki installer for the original darwinia needs gtk for the installer gui. After you install the base game, gtk is never needed again, not even to install the patches, which are all command line shars.

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 7 guests