Page 1 of 1

Mouse/Camera Problem - crazy movement

Posted: Wed Feb 06, 2008 1:19 am
by The_Xperience
Hello, I bought the game darwinia yesterday, as well as the other two games. I tried only Uplink and I thought the other games must be great as well.
That's the reason why I didn't try the demo of darwinia first.

So, now here is the problem:
When I lunch darwinia, everythings seems to be normal, but as soon as the planet appeares, the mouse cursor (those 4 white triangles with the red circle around it) starts to move down a bit. Then the camera follows it, slowly... and this doesn't stop. At the end, the cursor is at the bottom of the screen and the camera is rotating around it's own axis as fast as possible, while looking up to the fireball in the center of the planet.

When I hit the Escape Button, everything stops... I can now move the camera, when I click the right mouse button. But only as far as the screen allows me. When the cursor hits the edge of the screen, the camera stops as well.

I figured out that, to start a level, I have to move the normal cursor (those 4 triangles) to the "Garden"... I figured also out that that cursor should not move out of the center of the screen. And I really guess that my problem has something to do with the software which controles the cursor on the X-Window-System.

My system is btw. an AMD 64-bit processor, running Debian (testing) with Gnome.

I would be glad about any ideas what i can try.... and sorry for the not-so-good english. I'm german, not a native english speaker. ;)

Posted: Wed Feb 06, 2008 5:25 am
by Shwart!!
Don't worry about the language. It's better than many English-natives online. :wink:

Theoretically, you can move the map with the WASD keys when the menu is open.
How does the map react to you moving the mouse?


Posted: Wed Feb 06, 2008 8:41 am
by The_Xperience
Oh yeah, i forgot...
When the menu is open, i can move forward and sideward through ther WASD keys, move up and down through Q and E, and so on.
But as soon as i leave the menu, i can't move anymore through the keys. Except one thing: When I found a "stable point" (through moving while the menu is open), a point at which the camera isn't moving by itself, then I can move a bit up and/or down using q and e.. but in most cases the camera is going to become crazy again. In that "stable point" i can even move the mouse without much reaction... and even if i found a stable point which points to Garden, I can't click on it... err I can, but nothing happens. ;)

Sometimes it feels like.... yeah how do i describe it...? When you play an usual 3D-Game. Ego-Shooters, Jump'n Runs, whatever! And you jump or fall inside an solid object, through a bug. There are usually 2 things that would happen. 1st nothing happens at all. You move around inside the object, and as soon you leave it, you can't go back in. 2nd you get slowly pushed out through the physic engine. Like levitating... smooth and slow.
The 2nd thing is like what happens to the camera in darwina. It moves slowly to the ground, like it's about to get pushed out of the planet. While its moving, it going up and down a bit, but really fast... like headbanging. ;) When it reaches to bottom, the camera looks upwards and begins to spin. That is what mostly happens.

When I move outside the planet, through moving with the menu open, the camera gets sucked into the planet again, and then inside it's the same as ever... spinning, moving, headbanging.

And maybe I wasn't clear enough about the moving through the mouse. The map doesn't react at all. One exception: When the game startes and the camera is still at the starting point, the crazy movement starts slow, but i can speed it up when i move the mouse, becaus then the cursor will move fast to the bottom of the screen and the camera moves faster to the bottom of the planet.
While beeing in the menu i can steer through the mouse, but only as far as the screen allows me. For example: If i want to make a 360° turn to the right. Then i have to move the mouse to the left corner on the screen, click the right button, move it right until i reach the other end of the screen (mouse is invisible while clicking), release the mousebutton and start from the left again if i didn't already make a whole 360. That's unusual for mouse-controling, but maybe completely casual for this game.


Another idea:
When i play an usual 3D-Game and through some sort of bug, i can see a mouse pointer. Then i usually see the following: The pointer sticks to the middle of the screen, no matter what. If you move it away from it, the camera turns, and the mousepointer always returns to the center again... few times a second. You see flickering the cursor, but it always goes back to the center.
Somebody will now say "sure it does" and yeah, that's what i also think, as far as i understand mouse steering. But whatever i look at in darwinia, it doesn't show this behavior.
I know, there is a second possible steering, when the cursor is moved freely around the screen and the camera starts to move if the cursor reaches the edge of the screen. But darwinia doesn't seem to have a steering like this. It rather seems to have the first one i was talking about.

Posted: Thu Feb 07, 2008 3:28 pm
by Shwart!!
Well, moving while the menu is open is a bug itself, and is not implemented properly.
Therefore, clicking multiple times to move a full 360* is not something you should run into during gameplay; the screen is supposed to simply follow the cursor.

I'm not entirely sure how to fix your problem... but try adding the line 'StartMap = Garden' (without the quotes) to your Preferences.txt file, which is in the main Darwinia directory.
It should make the game bypass the map, and go right into the first level.
It may not work as intended, but theres a chance. (<SHOUT> If anyone knows the proper syntax of the command, and if I messed it up, please correct me. </SHOUT>)


Posted: Thu Feb 07, 2008 7:18 pm
by The_Xperience
Nice idea, so far... but still the same problem. As i can say for now: It's maybe not a mouse problem at all. Or it's a mixed problem. As I enter the map, it's starts to... yeah... "vibrate". When I use the menu to move around, then there happened 2 things. First I get pushed back to my original position and nothing changed at all. Then, after the second try, I got in a stable position. Then i could move around with WASD without problem. But as soon as I got to low, so i collided with the islands on the ground, the "vibrating" starts again. But i could move at least.
The only thing i still ask myself was: Why the hell did I get pushed back at first? It was like I was pushed out of an solid object which i wasn't supposed to be in and I was brought back to the outside of the map...

Any ideas from the orignal programmers? Maybe any way to contact them? I at least paid for the game, so...

Maybe I should install a Windows system again... i was planed that for a couple of weeks now, but never needed it -really-. But if I get it working within the Windows system, I get a clue how the game is supposed to react on mouse movement, and then i can maybe give some more info.
But thanks for the help so far, anyway. :)

Posted: Fri Feb 08, 2008 9:36 pm
by Shwart!!
Getting ruturned to your original point, after moving in the menu, is common. It is a bug, but don't worry too much about it.
I'm sure the programmers moniter the forums, but you can contact them here.
You could try setting ControlMouseButtons in your preferences.txt to 2, or if it is at 2, try it at 3. Probably won't change it, but it's worth a shot.


Posted: Tue Feb 12, 2008 6:06 pm
by Jotti
Just when I thought I was the only one with this problem ;)

It happens to me on both my workstation and my laptop, both running Debian testing AMD64. It used to run fine on this machine until a while ago, but that was before I switched to AMD64 (not sure if that's relevant though). Tried different SDL versions, to no avail. Tried the latest beta patch too, it didn't solve anything...

Posted: Thu Feb 14, 2008 10:26 pm
by Shwart!!
Hmm. There seems to be a pattern there with the AMD-64 processors. Is there anyone else here with a *nix box running such a processor?
Jotti, try the suggestions I've mentioned here. They likely will not work, but there is a possibility that they will...


Posted: Thu Feb 14, 2008 11:08 pm
by Jotti
Tried those before I posted, I'm afraid they didn't work...

Posted: Fri Feb 15, 2008 6:26 am
by Shwart!!
Ah. Unfortunate, though not terribly surprising. :(

I wish there was something more I could do to help, but other than buying a similar box, installing Darwinia, and trying to replicate the problem, there is nothing I can do.


Posted: Thu Feb 28, 2008 1:11 pm
by The_Xperience
That's unexpected(!):
I tried running the windows version through a wine, and... (suprise) exactly the same problem!
But yeah... i really didn't expect this.
I know, i said I'm about to install windows within the next days... buuuuut.... i don't want to. ;)
Maybe there will be the day when I'll say "uh yeah, i need a windows system right now....!!" but i don't think so at the moment
So I should write a mail to someone of the programmer crew and tell them, right? *sigh* Well, not today... :lol:

Posted: Thu Feb 28, 2008 10:14 pm
by Shwart!!
Huh. That is indeed unusual.
I think some of my friends run AMD-64 processors on their Windows machines... I'll see if I can test Darwinia on their computers.


Posted: Fri Feb 29, 2008 4:54 am
by KingAl
Darwinia is fine in Windows XP with an AMD-64 X2, at least with the AMD-provided 'drivers' and 'dual core optimiser' - which may well make a difference given that, according to the Windows troubleshooting guide, AMD dual cores normally need single core affinity set. However, that's not much help in a Linux context, and there don't appear to be equivalents for Linux. Still, if they're dual core processors, setting affinity to single core probably couldn't hurt.

Anyway, why do you think it's the processor? I can't imagine how that could affect mouse control in the manner described; the OP's guess regarding the windowing system strikes me as closer to the mark, were it not for the fact that the same issue appears in Wine. But, I don't use Linux, so what the hell would I know.
EDIT: Ah, righteo, the Common bugs thread describes Darwinia 'juddering and shuddering' with dual core AMDs, so setting single core affinity may well be a solution.

Posted: Sun Jun 08, 2008 3:15 pm
by Jotti
*bump* :)

After a couple of months I tried the game again on the same system. It seems that some Debian update fixed whatever was wrong sometime in the past 3 months... Darwinia works like a charm again! No idea what caused it though...