Page 1 of 1

Darwinia demo, Ubuntu edgy eft x64, libgtk

Posted: Tue Apr 10, 2007 12:55 am
by Capslock118
I purchased defcon awhile back and it was a wonderful game. Thank you. Now I have went to try darwinia. I run Ubuntu edgy eft x64 edition and have tried to install the demo but get this error:

Code: Select all

joel@joel-desktop:/media/games/Darwinia-Linux$ sudo sh darwinia-demo2-1.3.0.shVerifying archive integrity... All good.
Uncompressing Darwinia demo2 1.3.0.......................................................................
/home/joel/.setup29116: error while loading shared libraries: cannot open shared object file: No such file or directory

I searched this entire forum and beyond and have found others with similar problems but all I have found was people saying install libgtk-1.2 or others just plain quit trying


Code: Select all

joel@joel-desktop:/media/games/Darwinia-Linux$ sudo apt-get install libgtk1.2Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk1.2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

so what is my solution? I cant seem to find an answer....

I did find someone suggestion moving a libgtk file to lib32 folder but I am unsure where i would start with that.

Thanks for any help guys

Posted: Tue May 01, 2007 3:13 pm
by Admiral Frosty
Yeah, I have the same thing. It drives me nuts.

Posted: Thu Feb 21, 2008 11:44 pm
by aegnor
me2 ... has nobody a good hint?

Posted: Sat Feb 23, 2008 12:58 am
by frenchfrog
Don't have a 64 bits Linux install here, but perhaps you need to 32 bits version of GTK 1.

Worse case simply extract the files from the installer? --noexec --nox11 --target darwinia

Please post back if it works.

Posted: Sun Jul 20, 2008 11:02 am
by zach
Apparently, Hemebond has had trouble registering here, so I am (fittingly) relaying some internet relay chat messages that should help solve the problem;
Hemebond, on #darwinia wrote:I got the demo running on Ubuntu 8.04 AMD64.
sudo aptitude install ia32-libs
Then go to and download and install the getlibs package.
getlibs -p libglib1.2ldbl
Then, since I'd already extracted the installer with "--noexec --nox11 --target darwinia" switches
I ran ~/darwinia/
And it installed.
ln -s /usr/lib32/ ./
er, that's in the ~/darwinia/demo2/lib/ directory
Ah, turns out you can just delete from the ./darwinia/lib/ directory.