Linux FAQ

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

User avatar
John
Introversion Staff
Introversion Staff
Posts: 476
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Linux FAQ

Postby John » Thu Jun 29, 2006 6:15 pm

  1. Q. I have an amd64 and am getting really low FPS
    A. Try this before running the game:

    Code: Select all

    export LIBGL_DRIVERS_PATH=/usr/lib32/modules/dri
    Thanks to demon_bot for this one.
  2. Q. I'm getting `GCC_4.2.0' not found on Fedora Core 5
    A. Try removing the file darwinia/lib/libgcc_s.so.1 (make a backup somewhere) .
  3. Q. Game crashes when I enter a level.
    A. Try editing the preferences.txt file so that it contains this line:

    Code: Select all

    RenderLandscapeMode = 1
    (remove any other lines beginning with RenderLandscapeMode).
Last edited by John on Fri Jun 30, 2006 11:31 am, edited 1 time in total.
User avatar
trickfred
level5
level5
Posts: 1691
Joined: Sat Jul 24, 2004 5:01 am
Location: The Great White North, Eh?
Contact:

Postby trickfred » Thu Jun 29, 2006 7:35 pm

You mean RenderLandscapeMode, right? Not LandscapeRenderMode?

Edit: feel free to delete this comment.
Last edited by trickfred on Fri Jun 30, 2006 12:29 pm, edited 1 time in total.
User avatar
John
Introversion Staff
Introversion Staff
Posts: 476
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Fri Jun 30, 2006 11:32 am

Yes, thanks Trickfred.
john-whitlock
level0
Posts: 3
Joined: Thu Aug 03, 2006 10:29 pm

Don't always set LIBGL_DRIVERS_PATH...

Postby john-whitlock » Thu Aug 03, 2006 10:41 pm

I am running amd64 under Gentoo, and my LIBGL_DRIVERS_PATH is set correctly:

Code: Select all

echo $LIBGL_DRIVERS_PATH
:/usr/lib/dri:/usr/lib64/dri:/usr/lib32/xorg/modules/dri/:/usr/lib64/xorg/modules/dri


Setting this manually actually caused me to slow WAY down to software rendering. Leaving it unset (system default) works, except that the screen is cutoff at the middle. Maybe a reboot...
flib
level0
Posts: 6
Joined: Mon Feb 27, 2006 7:34 am

Re: Linux FAQ

Postby flib » Sun Aug 13, 2006 8:03 am

John wrote:
  1. Q. I have an amd64 and am getting really low FPS
    A. Try this before running the game:

    Code: Select all

    export LIBGL_DRIVERS_PATH=/usr/lib32/modules/dri
    Thanks to demon_bot for this one.
  2. Q. I'm getting `GCC_4.2.0' not found on Fedora Core 5
    A. Try removing the file darwinia/lib/libgcc_s.so.1 (make a backup somewhere) .
  3. Q. Game crashes when I enter a level.
    A. Try editing the preferences.txt file so that it contains this line:

    Code: Select all

    RenderLandscapeMode = 1
    (remove any other lines beginning with RenderLandscapeMode).
  • Q. I bought Darwinia with Steam while using Windows, I am no longer using Windows and no longer have the data from when I was using it. How do I get the data that I need to run it in Linux?
    A. Subscribe (as in pay) for Cedega and install Steam with it, then install Darwinia with it (which will not run in Cedega). If it finishes installing, take the files you need.
User avatar
xander
level5
level5
Posts: 16867
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Re: Linux FAQ

Postby xander » Sun Aug 13, 2006 2:52 pm

flib wrote:
  • Q. I bought Darwinia with Steam while using Windows, I am no longer using Windows and no longer have the data from when I was using it. How do I get the data that I need to run it in Linux?
    A. Subscribe (as in pay) for Cedega and install Steam with it, then install Darwinia with it (which will not run in Cedega). If it finishes installing, take the files you need.

Just remember, playing the Steam version of Darwinia on Linux is not officially supported. You can do it, but don't expect a huge amount of help from IV or Valve (especially Valve).

xander
funkyade
level0
Posts: 3
Joined: Thu Oct 19, 2006 8:46 am

Postby funkyade » Thu Oct 19, 2006 9:09 am

Q. I'm getting `GCC_4.2.0' not found on Fedora Core 5
A. Try removing the file darwinia/lib/libgcc_s.so.1 (make a backup somewhere) .


This is the case also with Ubuntu (6.10 Edgy)...

This :

Code: Select all

~/darwinia> mv -p lib/libgcc_s.so.1 libbak/libgcc_s.so.1


works...
le-sid
level0
Posts: 1
Joined: Sun Feb 21, 2010 3:03 am

crash on first level

Postby le-sid » Sun Feb 21, 2010 3:53 am

Trying to run on ubuntu 9.10. started the game normally, framerate normal, sound too, when I enter the garden level (don't have much choice, need to start somewhere) cpu get satured, getting some laggy sound, no graphics, no loading, nothing, I can't even kill the app to return to desktop. I've searched for the preferences.txt file, can't find it anywhere. got more ideas?
User avatar
ghostDancer
level2
level2
Posts: 90
Joined: Tue Jul 12, 2005 4:50 am
Location: Land of Confusion
Contact:

Postby ghostDancer » Sun Feb 21, 2010 3:53 pm

hi,
preferences.txt should be in /home/USERNAME/.darwinia/full/ , otherwise make a search from the shell,

Code: Select all

cd ; find . -name preferences.txt -print;


but i would recommend you to lower the sound settings in the menu (you can try first to disable it just to see if it's the problem) .As you would find in other parts of the forum , it's usually the main problen being really cpu hungry in darwinia.
-------------------------------------------------------------------------
Here is a test to find whether your mission on earth is finished:

if you're alive, it isn't.
------------------------------------------------------------------------

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 2 guests