Page 1 of 1

Generator issue

Posted: Tue Sep 25, 2007 5:25 am
by Nermal
It's probley just my bad playing but I can't seem to get the Generator level to finish. I have cleared all of the islands of Virii and sent all the Darwinians to the solar panels and have turned the machine in the middle island on. Nothing happens. I can see the electricity going to the gate but the generator still has "0". I've tried the level 3 times and ended up with the same result.


Posted: Fri May 01, 2009 9:48 pm
by Sebastian1213
same here!!!!! plzzzz help!!!

Posted: Fri May 01, 2009 10:10 pm
by NeatNit
Are you 100% sure you have all the control towers on the generator's island on??

Posted: Fri May 01, 2009 10:44 pm
by Sebastian1213
@NeatNit: yes, the lights are yellow. there is only 2 right???

Posted: Sat May 02, 2009 11:33 am
by NeatNit
Then I can't help, I'm sure more guys who know a lot more than me will come, though

Posted: Sat Aug 22, 2009 3:00 pm
by Waldorf
Same issue. I've tripple checked, and reseted the map twice. though if it's related to the bug in the betas, that won't help since the switches aren't reset.

version 1.4.2

I'd love to have this cleared up so I can continue the game!


Posted: Sun Nov 22, 2009 1:33 am
by goldenbloo
Having exactly the same problem.

Can anyone help?

Posted: Sun Dec 13, 2009 1:25 am
by Awoogamuffin
Yeah, I've just bought this game and I'm getting the same issue - the generator simply doesn't seem to register the energy from the solar panels. Is there anything else I should be doing?

It's a pity, cause I'd like to play the rest of it, it's fun so far.

Has anybody heard of / found a solution to this yet?

Posted: Wed Dec 30, 2009 5:51 am
by Sebastian1213
NeatNit wrote:Yes.
Then I can't help, I'm sure more guys who know a lot more than me will come, though

:wink: none yet.... hopefully someone will find a fix... :roll:

Posted: Wed Dec 30, 2009 9:37 am
by Shwart!!
I do not own DW on Mac, but I have some experience with bug-hunting. So I can't actually check anything myself. That said...

Assuming all of these reports are from Mac users, is there some possibility that Ambrosia somehow broke the generators or the level in porting DW over? (I would think not, or it would be affecting everybody...)
How many methods of acquiring Mac-Darwinia are there? There might be one specific download that is broken.

Can someone check to make sure the nearby controltower's dish actually points at the generator? It might not have a target set.
Along the same vein, are there actually power lines leading into the generator? It might not be linked right.
And is there a power line leading out? It might not be linked right. You can get your camera into the generator itself, to look at the exact point the links hit. The line leading out should be slightly away from the 3 leading in.

Is this possibly an anti-piracy measure gone awry? It seems an easy point to stick a lock for non-registered users, just in case they somehow reach this level. Try re-running the registration utility, if there is one. (I remember there being one.)

And... just in case... send another engineer to that control tower. Make sure it's fully captured.


Posted: Wed Dec 30, 2009 6:13 pm
by Sebastian1213
cool, thanks! will try that!

Generator bug not fixed

Posted: Wed Apr 21, 2010 9:46 am
by ionicbox
This is still an issue. I'm on the Generator Level
MAC v 1.42 and the generator isn't reporting electricity. They had the same issue on the windows version awhile back. Any fixes?


Posted: Sun Apr 25, 2010 8:01 pm
by ionicbox
I found this ... .php?t=762

Basically this takes a few minutes and it fixes it.

USE Redshirt from

Open up the file found via Library/Application Support/Darwinia/full/users/NewUser/game.txt,

and search for a line that looks like this:
76 2 4 6 0 0

Mine was 76 2 4 5 -1 0 but it is the only line thats close. Using Redshirt - Replace the 2 with a 1 and then save the crypted file game.txt and replace it with the game.txt thats on your HD. The Control Tower thats next to the Generator will now be uncaptured at the start of the level allowing your engineers to reprogram it so it will register the energy generated from the solar panels.

Posted: Sat Jul 24, 2010 5:17 pm
by alex elmo
I did that, and i managed to re-capture it, but it still remains at 0 :(

Posted: Sat May 12, 2012 11:58 am
by crusaderace
[quote="alex elmo"]I did that, and i managed to re-capture it, but it still remains at 0 :([/quote]

Hey guys, it's May 2012, anyone has a fix on this? It's driving me nuts and I still do want to actually complete this game.

1. I have cleared the Generator map of all viruses and have made sure there all Darwinians powering the solar cells.
2. I have also gone to ( to decrpt the game.txt file and changed the 76 2 4 5 -1 0 to 76 1 4 5 -1 0 so that I can recapture the control point but nothing works!

Generator power is still at 0. Anyone can help?

Running Mac version 1.4.2.