Page 1 of 1

Invisible Landscape!!!

Posted: Tue Aug 22, 2006 7:00 pm
by Bug_Hate
When I began playing Darwinia, I just played for fun, 'cause i thought the graphics where really bad, as there was no landscape visible. When i found some screenshots on the internet, i was amazed: the texture was great!
Look at this image now: ... dscape.jpg

This is what i see all the time!
I searched in the forum of Mac issues, but no one seems to have this problem.
I have a G4 Mac 700mhz, 256 mb ram and a Geforce2 32 mb.
I used the "medium" and the "high" configuration of graphical settings, but i couldn't fix it.
As for other bugs, I can't aim a radar dish without the camera going crazy, but i see that many other people had this problem....I just want the landscape back :( ... eagain.jpg

Posted: Tue Aug 22, 2006 7:57 pm
by trickfred
Now, I don't have a Mac, and my apologies if this is useless to you, but did you try this?

Oh good god Darwinia just crashes!

This is an odd bug at first look, you'll have this bug if when you start darwinia, the menu loads fine, but the levels die on you rather quickly (some people don't make it as far as the menu though).

The solution is simple.

Open your prefrences.txt file, and add this line:

RenderLandscapeMode = 1

The reason you are doing this is simple:

In Darwinia, there's three ways it renders the terrain. The setting of RenderLandscapeMode allows you to switch between the three. The outline of the effects is this:

* 0 - uses Vertex Arrays. This was found to be slightly faster on some ATi hardware, and thus should be considered when testing out which setting to use
* 1 - uses Display Lists. This setting emulates the way Darwinia rendered in 1.0
* 2 - uses Vertex Buffer Objects. This is the default setting that Darwinia uses in v1.2 onward.

Basically it appears that Intel cards (that are not Extreme Grahpics) have a problem with VBO's, which is the default mode in 1.2 onwards (thus including the steam version). Setting it to use 1 emulates the original behaviour, and setting it to 0 is an alternative mode using Vertex Arrays.

This can also apply to other cards than just Intel cards. Some laptop computers use ATi's IGP or S3, SiS, or other graphics cards which just can't cope with VBO's. If you have this card type, you'll want to fix it ASAP by using the above line Smile

I realize the trick is meant to fix a different problem, but it does change the way the landscape is rendered, and I thought it might be worth it for you to try.

Posted: Tue Aug 22, 2006 8:08 pm
by NeoThermic
Hmm. On windows, in the beta's, one could invoke this bug by changing the Z-Buffer and slapping apply. I wonder if we can use it the other way around. Change your Z-Buffer to one of the other options and see if the landscape comes back. Then tell us the result.


Posted: Tue Aug 22, 2006 9:06 pm
by ShepFan
As NeoThermic mentioned, I have also had success with landscape issues by changing the Z-buffer setting. Another technique that helped was playing in windowed mode, as opposed to full-screen.


The Landscape's Back!

Posted: Wed Aug 23, 2006 12:49 pm
by Bug_Hate
Thank you trickfred! I changed the RenderLandscapeMode as u suggested, and now i can understand why my squads always got stuck: there are mountains!!! :):):)

I also changed the Z-buffer before I modified the Preferences.txt, but it was useless....

Posted: Wed Aug 23, 2006 1:15 pm
by trickfred

Go trickfred, it's your birthday...

Posted: Wed Nov 08, 2006 12:29 pm
by watsst
I recently downloaded the new 1.4.2 version and began to play but its also having the invisible land. and I cant find the preferences.txt file anywhere. is this only downloadable with the old version? cause there dosent seem to be any other way to change the renderingsoftware stuff

Posted: Wed Nov 08, 2006 12:31 pm
by watsst
nevermind, Im good. figures I find it 5 secs after posting