Problems with Darwinia on iMac G5s?

Problems with the Mac version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

User avatar
xander
level5
level5
Posts: 16868
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Problems with Darwinia on iMac G5s?

Postby xander » Wed Jul 27, 2005 3:18 am

M'kay, someone using the handle buster_ was on IRC this evening, complaining about poor performance on his iMac G5. He seems to have been getting very low framerates, even with the fully patched game. He did not give us much information to go on and left the channel in a rather snarky mood, so I have a question to any one out there with an iMac G5: how is performance? are you suffering from low framerates?

If there is a problem with Darwinia on the G5 iMacs, it would probably be really useful for the folk at IV to know about it, so don't be shy.

xander
nfreader
level1
level1
Posts: 47
Joined: Thu Oct 21, 2004 11:39 pm
Contact:

Postby nfreader » Wed Jul 27, 2005 2:49 pm

First off, I referred Buster to you in the first place, so the blame partly falls on me.

Second: I have a lower end model iMac than our freind here has, but after I turned down my graphics and sound settings, it runs just fine (albeit a little uglier, but hey, who's counting?). This leads me to believe that his computer might be a lemon, but idle conjecture is not nice.
Andcarne
level4
level4
Posts: 675
Joined: Mon May 26, 2003 1:44 am

Postby Andcarne » Thu Jul 28, 2005 11:28 pm

What sort of framerates are we talking here?

I get usually between 6-10fps on my dual 867 G4. That's with settings all the way up. If people with iMac G5's are getting worse then that, then there may be something to do with how the hardware and darwinia are interacting.
User avatar
xander
level5
level5
Posts: 16868
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Postby xander » Fri Jul 29, 2005 12:48 am

As far as I can tell, he was talking less than 5 FPS in Garden. With the settings turned down. On IRC, we concluded that it must be a hardware issue, and tried to get him to post details to the forums, at which point he got rather angry, claiming that software should work, and that he shouldn't have to give up his privacy to post a bug. He seemed to be trolling, but I was hoping that by posting this, we could (1) find out if this problem is occuring on other Macs and maybe track it down a bit, and (2) show that the folk at IV are not deleting reports of major problems (which was one of the accuasations he made).

xander
User avatar
John
Introversion Staff
Introversion Staff
Posts: 476
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Fri Jul 29, 2005 6:37 pm

I've played Darwinia on a G5 before and have always obtained very good frame rates (usually > 40). I haven't tested on G5/tiger yet, but I expect things to improve since the Tiger graphics drivers seem to be even faster for Darwinia.
User avatar
xander
level5
level5
Posts: 16868
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Postby xander » Fri Jul 29, 2005 10:43 pm

John wrote:I've played Darwinia on a G5 before and have always obtained very good frame rates (usually > 40). I haven't tested on G5/tiger yet, but I expect things to improve since the Tiger graphics drivers seem to be even faster for Darwinia.


Have you tried it on an iMac G5? However, I am inclined to agree. I generally get 25-40 FPS on my PowerBook G4, though I have yet to get better than 15 FPS in either Bioshpere or Temple, and Reciever is a dog (the falling souls really slow things down). As I said, I think buster_ was trolling, but I wanted to make sure that there really was no cause for worry. :)

And Tiger improved things greatly. Before Tiger, I was getting less than 1 FPS in Reciever, Biosphere, and Temple. When I installed Tiger, I started getting framerates around 5 FPS in those levels, and the patch further boosted things. Now, I rarely see framerates of less than 8 FPS. Still not perfect, but much more playable.

xander
chakko
level0
Posts: 1
Joined: Thu Oct 13, 2005 11:46 pm
Location: Maastricht, Netherlands

Postby chakko » Fri Oct 14, 2005 1:32 am

yO - I have an original iMac G5 17" with 1Gb ram running Tiger 10.4.2 (with the original GeForce 5200 series.

Seems to run fine for me! I'm getting an average of 50FPS with all settings set to max.

There's noticable slow down when things get busy on-screen, but by no means is gameplay hindered.

Return to “Mac Issues”

Who is online

Users browsing this forum: No registered users and 1 guest