Black Screen in the Mine Level

Problems with the Mac version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

AndyHolyer
level0
Posts: 2
Joined: Fri Jul 22, 2005 10:30 am
Contact:

Black Screen in the Mine Level

Postby AndyHolyer » Fri Jul 22, 2005 10:35 am

I've worked as far as the Mine Level, and today when I go into the level I get a black screen. There's a bit of background noise, but I don't see anything at all, and most keys seem unresponsive.

Other levels (Generator, Escort) display fine.

Running on an iBook with Panther.

Any diagnostics? Things I could try?

Thanks for any help you can provide.
User avatar
John
Introversion Staff
Introversion Staff
Posts: 476
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Mon Jul 25, 2005 6:22 pm

Sounds very odd indeed. Have you tried resetting the level (Press escape to bring up the menu and then select 'reset level').
User avatar
xander
level5
level5
Posts: 16867
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Tue Jul 26, 2005 4:44 am

John wrote:Sounds very odd indeed. Have you tried resetting the level (Press escape to bring up the menu and then select 'reset level').


If you can't reset the level from in the game (which might happen if the screen goes black), you could try deleting the map an mission files from the preferences directory (~/Library/Application Support/Darwinia/full). Delete only the map and mission for Mine.

You could also try playing with the quality settings. In 'preferences.txt' (which is located in the same directory listed above), try playing a bit with these lines:

Code: Select all

RenderLandscapeDetail = 1
RenderWaterDetail = 1
RenderBuildingDetail = 1
RenderEntityDetail = 1
RenderCloudDetail = 1
RenderPixelShader = 1

Higher numbers are lower quality, except for RenderPixelShader, which it either 0 or 1. 1 causes the pixel effect, 0 disables it.

I honestly have little hope that any of these will work, but it is worth a shot, I suppose.

xander

Return to “Mac Issues”

Who is online

Users browsing this forum: No registered users and 1 guest