Fatal Signal (11) received on attempted start

Problems with the Mac version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

dirdled
level0
Posts: 3
Joined: Thu Oct 21, 2004 4:34 pm
Location: West Jordan, UT

Fatal Signal (11) received on attempted start

Postby dirdled » Thu Dec 30, 2004 8:36 am

I tried to find a similar problem to this one in the forums, and wasn't able to locate one, I'm trying to start Darwinia beta4d. The screen goes dark, blinks once, goes dark again and then I get the Fatal signal (11) recieved error dialog. I had a similar problem in beta 3, it acted the same but I never got the dialog or the blackbox file. (I was able to get beta 3 to start once, and was able to play the game quite a while, but was never abelt to get it started again)


Here's the Contents of the blackbox.txt

=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : macosx-demo-beta4d
ERROR : 'Fatal Signal (11) Received
'

=========================
===== SYSTEM REPORT =====
=========================

SysInfoGenVersion: 2
CpuVendor: PowerPC 7450
CpuModel: ppc7450
Num Processors: 2
Country: Any
Language: en_GB
Num sound devices: 3
Primary sound device: Built-in audio controller
Graphics Card: GeForce4 Ti 4600
Operating System: Darwin 6.8
Computer Name: Dan’s G4



=========================
====== USER DATA ========
=========================

USERNAME : dirdled

EMAIL : dirdled@xmission.com


=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.00
BypassNetwork = 1
SinglePlayer = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = software
SoundMixFreq = 22050
SoundMasterVolume = 255
SoundChannels = 16
SoundHW3D = 0
SoundSwapStereo = 0
SoundBufferSize = 2048
ScreenWidth = 1024
ScreenHeight = 768
ScreenWindowed = 0
ScreenZDepth = 24
ScreenColourDepth = 32
ScreenRefresh = 60
RenderLandscapeDetail = 1
RenderWaterDetail = 1
RenderBuildingDetail = 1
RenderEntityDetail = 1
RenderCloudDetail = 1
RenderPixelShader = 1
ControlMouseButtons = 1
RenderLandscapeUsingDisplayLists = 0
ManuallyScaleTextures = 0
StartMap = mine
UserProfile = none
**********

Date/Time: 2004-12-30 00:28:58 -0700
OS Version: 10.2.8 (Build 6R73)
Host: Dans-G4.local.

Command: Darwinia
PID: 10467

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x04bc3000

Thread 0 Crashed:
#0 0x909a3448 in _glTessErrorString(int)
#1 0x04baf000 in 0x4baf000
#2 0x909aa244 in gluBuild2DMipmapsCTXCore(_CGLContextObject*, unsigned long, long, long, long, long, long, unsigned long, unsigned long, long, long, long, void const*)
#3 0x909aaef4 in gluBuild2DMipmapsCTX
#4 0x0004b4f8 in 0x4b4f8
#5 0x00057718 in 0x57718
#6 0x00073e1c in 0x73e1c
#7 0x000743a0 in 0x743a0
#8 0x0006f2c0 in 0x6f2c0
#9 0x0006efd8 in 0x6efd8
#10 0x000694c4 in 0x694c4
#11 0x00069e60 in 0x69e60
#12 0x00061630 in 0x61630
#13 0x00005ef8 in 0x5ef8
#14 0x97dfab40 in _nsNotificationCenterCallBack
#15 0x9016847c in _postNotification
#16 0x90165b90 in _CFNotificationCenterPostLocalNotification
#17 0x9318b16c in -[NSApplication _sendFinishLaunchingNotification]
#18 0x93161f98 in _requiredAEEventHandler
#19 0x91b56570 in aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*)
#20 0x91b590cc in dispatchEventAndSendReply(AEDesc const*, AEDesc*)
#21 0x91b56478 in aeProcessAppleEvent
#22 0x96a83778 in AEProcessAppleEvent
#23 0x9308e698 in _DPSNextEvent
#24 0x930a0824 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
#25 0x930b23f4 in -[NSApplication run]
#26 0x00005ea4 in 0x5ea4
#27 0x0000610c in 0x610c
#28 0x0000315c in 0x315c
#29 0x8fe190f4 in _dyld_start

Thread 1:
#0 0x90073ba8 in mach_msg_trap
#1 0x90005ed0 in mach_msg
#2 0x90148938 in __CFRunLoopRun
#3 0x90180f04 in CFRunLoopRunSpecific
#4 0x94652f80 in HALRunLoop::OwnThread(void*)
#5 0x946591e0 in CAPThread::Entry(CAPThread*)
#6 0x90020c28 in _pthread_body

Thread 2:
#0 0x90042588 in semaphore_timedwait_signal_trap
#1 0x9003e7b4 in _pthread_cond_wait
#2 0x946444fc in CAGuard::WaitFor(unsigned long long)
#3 0x94644130 in CAGuard::WaitUntil(unsigned long long)
#4 0x94642b20 in HPIOThread::WorkLoop()
#5 0x9465919c in HPIOThread::ThreadEntry(HPIOThread*)
#6 0x946591e0 in CAPThread::Entry(CAPThread*)
#7 0x90020c28 in _pthread_body

PPC Thread State:
srr0: 0x909a3448 srr1: 0x0000f930 vrsave: 0x00000000
xer: 0x20000000 lr: 0xbfffe1b0 ctr: 0x00000004 mq: 0x00000000
r0: 0xbfffe1b0 r1: 0xbfffe170 r2: 0x04baf1fc r3: 0x00000080
r4: 0x04baf1fc r5: 0x04bc2dfc r6: 0x04bc2ffc r7: 0x43300000
r8: 0x04bc2e00 r9: 0x90a03010 r10: 0x00000000 r11: 0x04bc3000
r12: 0x0000009f r13: 0x00013c00 r14: 0x00003f80 r15: 0x00000000
r16: 0x00000001 r17: 0x00000001 r18: 0x0000007f r19: 0x0000007f
r20: 0x04b8b000 r21: 0x00000080 r22: 0x00000080 r23: 0x04baf000
r24: 0x0000009f r25: 0x0000007f r26: 0x00000200 r27: 0x00000004
r28: 0x00000004 r29: 0x00000080 r30: 0x00000001 r31: 0x909a3010


=========================
====== STACKTRACE =======
=========================

retAddress = 0x4cd14
retAddress = 0x4c950
retAddress = 0x9000f96c
retAddress = 0xbfffe1b0
User avatar
John
Introversion Staff
Introversion Staff
Posts: 477
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Thu Dec 30, 2004 2:33 pm

Please could you give me some information about what operating system version and which model of Macintosh you are using.

Also, please could you try editing ~/Library/Application Support/Darwinia/demo/preferences.txt and set ManuallyScaleTextures = 1 and tell me if that helps or not.
dirdled
level0
Posts: 3
Joined: Thu Oct 21, 2004 4:34 pm
Location: West Jordan, UT

Postby dirdled » Sun Jan 02, 2005 8:34 am

I'm running OS 10.2.8 on a dual 1GHz MDD Mac
Changing the ManuallyScaleTextures to 1 did allow the program to run although it seems kinda slow

one other quick thing I noticed is that in the help it says the center button on the mouse is Zoom, that doesn't seem to work on my Logitech Cordless optical mouse (Logitech® Cordless Navigator Duo™ Keyboard and mouse) running Logitech Control Center for Macintosh® OS X    Version: 1.4.1 for a driver
User avatar
John
Introversion Staff
Introversion Staff
Posts: 477
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Mon Jan 03, 2005 12:36 am

Thanks. Out of interest what frame rate do you get with this configuration? (Press F5).

Pressing Z should (also) work for zoom. Hopefully we can investigate the mouse problem soon.

Please could you test whether the mouse-wheel changes the height of the camera at all?
dirdled
level0
Posts: 3
Joined: Thu Oct 21, 2004 4:34 pm
Location: West Jordan, UT

Postby dirdled » Mon Jan 03, 2005 1:28 am

Z does work for the Zoom, and using the wheel does change the camera height as far as a frame rate for some reason, right after starting the game the frame rate is as low as 17 fps but after a couple of seconds I am able to get from 30 in a relatively busy area to over 85 in light areas

Return to “Mac Issues”

Who is online

Users browsing this forum: No registered users and 1 guest