SDL Framework Missing? [FullBeta4]

Problems with the Mac version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

User avatar
Monkeyfood
level1
level1
Posts: 59
Joined: Tue Oct 05, 2004 3:31 pm
Location: London
Contact:

SDL Framework Missing? [FullBeta4]

Postby Monkeyfood » Mon Dec 20, 2004 12:51 am

I cannot launch the new FullBeta4 at all.

I get the following logged to the console:

dyld: /Users/diggory/Applications/Games/Darwinia.app/Contents/MacOS/Darwinia can't open library: @executable_path/../Frameworks/SDL.framework/Versions/A/SDL (No such file or directory, errno = 2)


After inspecting the package bundle I noticed than the Frameworks directory has an SDL.framework directory, but it is empty.
User avatar
Monkeyfood
level1
level1
Posts: 59
Joined: Tue Oct 05, 2004 3:31 pm
Location: London
Contact:

Postby Monkeyfood » Mon Dec 20, 2004 12:55 am

I happened to keep the old DemoBeta3 and copied the framework from that.

It appears to launch OK.
UliB
level0
Posts: 3
Joined: Thu Oct 21, 2004 9:46 pm

Postby UliB » Mon Dec 20, 2004 12:58 am

Monkeyfood wrote:I happened to keep the old DemoBeta3 and copied the framework from that.

It appears to launch OK.


Is it available somewhere for download? I just joined this forum after invitation, so I have no Beta3 installed.
Andcarne
level4
level4
Posts: 675
Joined: Mon May 26, 2003 1:44 am

Postby Andcarne » Mon Dec 20, 2004 1:02 am

Strangely enough, I'm using 10.3.5 and the framework folder is blank here, but it works for me. :?
User avatar
Monkeyfood
level1
level1
Posts: 59
Joined: Tue Oct 05, 2004 3:31 pm
Location: London
Contact:

Postby Monkeyfood » Mon Dec 20, 2004 1:31 am


Return to “Mac Issues”

Who is online

Users browsing this forum: No registered users and 1 guest