Fatal error encountered on startup with iMac

Problems with the Mac version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

etherealhedgehog
level0
Posts: 8
Joined: Sat Oct 23, 2004 3:34 am
Location: Davis, California USA

Fatal error encountered on startup with iMac

Postby etherealhedgehog » Thu Oct 28, 2004 2:04 am

Hi,

Happy to be picked as beta tester. Just downloaded the game. Launched from desktop and got fatal error.

Blackbox message follows:
=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : macosx-demo-beta1
ERROR : 'SDL failed to set video mode 1024 x 768'

=========================
===== SYSTEM REPORT =====
=========================

SysInfoGenVersion: 2
CpuVendor: PowerPC 750
CpuModel: ppc750
Num Processors: 1
Country: Any
Language: en_US
Num sound devices: 1
Primary sound device: Built-in Audio
Graphics Card: ATY,GT-C
Operating System: Darwin 7.5.0
Computer Name: . ’s Computer



=========================
====== USER DATA ========
=========================

USERNAME : etherealhedgehog

EMAIL : ray@dcn.davis.ca.us


=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
SinglePlayer = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundDriver = -1
SoundMixFreq = 44100
SoundMasterVolume = 255
SoundChannels = 16
SoundHW3D = 0
SoundSwapStereo = 1
SoundBufferSize = 2000
ScreenWidth = 1024
ScreenHeight = 768
Windowed = 0
RenderLandscapeDetail = 1
RenderWater = 1
RenderWaterDetail = 1
RenderClouds = 1
RenderNegative = 0
RenderPixelShader = 1
RenderSmoothLines = 0
RenderHighDetailVirii = 0
RenderPosterResolution = 1
RenderPixelShaderRange = 800
RenderHighDetailDarwiniansRange = 800
RenderHighDetailViriiRange = 800
RenderLandscapeUsingDisplayLists = 0
StartMap = mine
ControlMouseButtons = 1

=========================
====== STACKTRACE =======
=========================

retAddress = 0x422e4
retAddress = 0x41efc
retAddress = 0x5ee8c
retAddress = 0x22a24
retAddress = 0x5a5ec
retAddress = 0x5a770
retAddress = 0x5aa20
retAddress = 0x52f9c
retAddress = 0x3210
retAddress = 0x909f7184
retAddress = 0x901aa5c8
retAddress = 0x901aefd8
retAddress = 0x909f4fd0
retAddress = 0x92ee30c4
retAddress = 0x92ee2fb0
retAddress = 0x92ee31e0
retAddress = 0x90a4a544
retAddress = 0x90a50c6c
retAddress = 0x91674a10
retAddress = 0x91677858
retAddress = 0x91674c50
retAddress = 0x928c4360
retAddress = 0x92dd2454
retAddress = 0x92de8c24
retAddress = 0x92dfcf8c
retAddress = 0x31bc
retAddress = 0x3424
retAddress = 0x28a4
retAddress = 0x8fe1a558
retAddress = 0x0


I reset my screen to 1024 by 760, restarted the machine and relaunched....same error

Let me know,

Chris
User avatar
John
Introversion Staff
Introversion Staff
Posts: 477
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Sun Oct 31, 2004 2:28 am

Bug well spotted. As a workaround, try setting the screen resolution manually in preferences.txt (inside Darwinia.app):

ScreenWidth = 1024
ScreenHeight = 760

Also, make sure to download beta3 as it is more reliable. Please can you post a report here to let me know whether the workaround worked for you.

Thanks

John
etherealhedgehog
level0
Posts: 8
Joined: Sat Oct 23, 2004 3:34 am
Location: Davis, California USA

Workaround doesn't..... work around

Postby etherealhedgehog » Sun Oct 31, 2004 11:40 pm

John,

Set the screen size in the system prefs. to 1024 X 768. The screen adjusts to the new size.

Redownloaded Darwina making sure it was the beta 3 date.

Still get fatal error message and no launch of game.

Did a search for Darwinia files and only found 2 files they are: Darwinia (the application) and darwinia.plist (in preferences). Opened darwinia.plist but was not able to change anything in that file.

New blackbox error date follows:
=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : macosx-demo-beta3
ERROR : 'SDL failed to set video mode 1024 x 768'

=========================
===== SYSTEM REPORT =====
=========================

SysInfoGenVersion: 2
CpuVendor: PowerPC 750
CpuModel: ppc750
Num Processors: 1
Country: Any
Language: en_GB
Num sound devices: 1
Primary sound device: Built-in Audio
Graphics Card: ATY,GT-C
Operating System: Darwin 7.5.0
Computer Name: . ’s Computer



=========================
====== USER DATA ========
=========================

USERNAME : etherealhedgehog

EMAIL : ray@dcn.davis.ca.us


=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
SinglePlayer = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundDriver = -1
SoundMixFreq = 44100
SoundMasterVolume = 255
SoundChannels = 16
SoundHW3D = 0
SoundSwapStereo = 1
SoundBufferSize = 2000
ScreenWidth = 1024
ScreenHeight = 768
Windowed = 0
RenderLandscapeDetail = 1
RenderWater = 1
RenderWaterDetail = 1
RenderClouds = 1
RenderNegative = 0
RenderPixelShader = 1
RenderSmoothLines = 0
RenderHighDetailVirii = 0
RenderPosterResolution = 1
RenderPixelShaderRange = 800
RenderHighDetailDarwiniansRange = 800
RenderHighDetailViriiRange = 800
RenderLandscapeUsingDisplayLists = 0
StartMap = mine
ControlMouseButtons = 1

=========================
====== STACKTRACE =======
=========================

retAddress = 0x42184
retAddress = 0x41d9c
retAddress = 0x5ee7c
retAddress = 0x228dc
retAddress = 0x5a5dc
retAddress = 0x5a760
retAddress = 0x5aa10
retAddress = 0x52f8c
retAddress = 0x30c8
retAddress = 0x909f7184
retAddress = 0x901aa5c8
retAddress = 0x901aefd8
retAddress = 0x909f4fd0
retAddress = 0x92ee30c4
retAddress = 0x92ee2fb0
retAddress = 0x92ee31e0
retAddress = 0x90a4a544
retAddress = 0x90a50c6c
retAddress = 0x91674a10
retAddress = 0x91677858
retAddress = 0x91674c50
retAddress = 0x928c4360
retAddress = 0x92dd2454
retAddress = 0x92de8c24
retAddress = 0x92dfcf8c
retAddress = 0x3074
retAddress = 0x32dc
retAddress = 0x289c
retAddress = 0x8fe1a558
retAddress = 0x0

Let us know what else we can do

Chris
User avatar
John
Introversion Staff
Introversion Staff
Posts: 477
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Wed Nov 03, 2004 11:42 pm

If you ctrl-click on the Darwinia application and select "Explore Package Contents" then you should be able to access the preferences.txt file.

Try setting the screen width and height options, and experimenting with windowed mode as well.

(Moved this to Mac Specific Bugs)
etherealhedgehog
level0
Posts: 8
Joined: Sat Oct 23, 2004 3:34 am
Location: Davis, California USA

One Step Closer

Postby etherealhedgehog » Thu Nov 04, 2004 7:07 am

Successfully got Darwinia to start. To do so I set the window size at 720 by 540 so it would fit in the screen and set window to 1. It comes up in one correctly sized window. However, it simply shows what I assume is the the startup screen of the game. A series of graphical landscapes with music/sound in the background. It will not accept any imput except for the "h" key for help. After a few moments it brings up a bit of text explaining what keys to use to move the camera around: q,w,e,a,s,d. None respond. The mouse also dissapears and reappears elseware seemingly at random. The only way for me to get out of the game at this point is to force quit. Any suggestions on what to do?
Thanks for your time.
User avatar
John
Introversion Staff
Introversion Staff
Posts: 477
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Postby John » Thu Nov 04, 2004 10:25 am

Hmm.. Interesting. What specification of machine do you have?

Also can you try with smaller window sizes to see if that makes any difference?
etherealhedgehog
level0
Posts: 8
Joined: Sat Oct 23, 2004 3:34 am
Location: Davis, California USA

Still not working

Postby etherealhedgehog » Fri Nov 05, 2004 3:02 am

Hardware Overview:

Machine Model: iMac
CPU Type: PowerPC 750 (2.2)
Number Of CPUs: 1
CPU Speed: 333 MHz
L2 Cache (per CPU): 512 KB
Memory: 320 MB
Bus Speed: 67 MHz


I tinkered with the window until it was as small as 400 by 300. It seems to work slightly more smoothly there, but the only new thing I was able to control was to push alt to get a command menu of some sort. The mouse for the menu appeared but suffered from EXTREME lag and was almost impossible to control. Clicking did not seem to do anything.
Im starting to think my poor old iMac just can't quite keep up with this game. Any other ideas?
etherealhedgehog
level0
Posts: 8
Joined: Sat Oct 23, 2004 3:34 am
Location: Davis, California USA

Problem solved

Postby etherealhedgehog » Sun Nov 07, 2004 9:41 am

Well, I read over other forum conversations, and discovered how to fix the camera problem. I needed to hit F2. Now I can actually control the camera...however, the game is unplayably laggy. It takes about 5 seconds for each frame of camera movement. Is my computer just inadequate for playing this game?
epocs
level0
Posts: 3
Joined: Thu Oct 21, 2004 2:34 pm

Postby epocs » Sun Dec 19, 2004 11:25 pm

I double click on the freshly downloaded file, the icon pops up for a second, and then it dies. Several of these in the log:

**********

Host Name: Adam-Frankes-Laptop.local
Date/Time: 2004-12-19 17:23:31 -0500
OS Version: 10.3.7 (Build 7S215)
Report Version: 2

Command: Darwinia
Path: /Users/afranke/Desktop/Darwinia.app/Contents/MacOS/Darwinia
Version: ??? (???)
PID: 19242
Thread: Unknown

Link (dyld) error:

dyld: /Users/afranke/Desktop/Darwinia.app/Contents/MacOS/Darwinia can't open library: @executable_path/../Frameworks/SDL.framework/Versions/A/SDL (No such file or directory, errno = 2)

**********

SysInfoGenVersion: 2
CpuVendor: PowerPC 7450
CpuModel: ppc7450
Num Processors: 1
Country: Any
Language: en_GB
Num sound devices: 1
Primary sound device: Built-in Audio
Graphics Card: ATY,RV360M11
Operating System: Darwin 7.7.0
Computer Name: Adam Frankes Laptop
gino
level0
Posts: 2
Joined: Fri Oct 22, 2004 10:52 am
Location: Goteborg/Sweden
Contact:

Startup...

Postby gino » Sun Dec 19, 2004 11:32 pm

I can't get Darwinia to start:

Host Name: radar.local
Date/Time: 2004-12-19 23:14:47 +0100
OS Version: 10.3.7 (Build 7S215)
Report Version: 2

Command: Darwinia
Path: /Users/ginopapa/Desktop/Download/Darwinia.app/Contents/MacOS/Darwinia
Version: ??? (???)
PID: 3009
Thread: Unknown

Link (dyld) error:

dyld: /Users/ginopapa/Desktop/Download/Darwinia.app/Contents/MacOS/Darwinia can't open library: @executable_path/../Frameworks/SDL.framework/Versions/A/SDL (No such file or directory, errno = 2)




SysInfoGenVersion: 2
CpuVendor: PowerPC 970
CpuModel: ppc970
Num Processors: 2
Country: Any
Language: en_GB
Num sound devices: 2
Primary sound device: iSight
Graphics Card: ATY,R350
Operating System: Darwin 7.7.0
Computer Name: Radar

Return to “Mac Issues”

Who is online

Users browsing this forum: No registered users and 1 guest