Installation and crash issue

Problems with the Windows version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

CarthAnne
level0
Posts: 6
Joined: Mon Jun 15, 2009 2:56 pm

Installation and crash issue

Postby CarthAnne » Mon Jun 15, 2009 3:07 pm

I installed Darwinia started to play it and crashed when I hit the garden I tryed to install the patch but said I had an incomplete version of Darwinia I reinstall and have the same problem how do I make sure Darwinia installs properly Oh and when first attmepted to play it said {error data transfer 00004} or something like that

Specs:
AMD Athlon 64 X@ Dual Processor 4000+
2.00 GB Ram
32 bit operating system

Anything else you need to know?
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Mon Jun 15, 2009 3:26 pm

I'm not an expert here, but know what the experts need as additional information:
- the contents of the files blackbox.txt and preferences.txt from your profile directoy (just do a file search for them)
- which version of Darwinia you installed
- what graphics card you are using
- which operating system you have. Since you're on the Windows Troubleshooting forum, that means XP or Vista.

oh and please use some punctuation the lack of it makes it hard to read what you write it essentially is just a string of words that go on and on punctuation is your friend it will make you look that much smarter
CarthAnne
level0
Posts: 6
Joined: Mon Jun 15, 2009 2:56 pm

Postby CarthAnne » Mon Jun 15, 2009 4:20 pm

Darwinia version is 1.42, operating system is Windows 7 beta.

And I don`t know how to check what graphics card I`m using and don`t know where blackbox.txt or preferences.txt
User avatar
xander
level5
level5
Posts: 16866
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Mon Jun 15, 2009 4:57 pm

At the top of this forum, there is a stickied post. Did you read that?

xander
CarthAnne
level0
Posts: 6
Joined: Mon Jun 15, 2009 2:56 pm

Postby CarthAnne » Tue Jun 16, 2009 12:30 am

Yes I did and I didnt find the answer to my problem there
User avatar
xander
level5
level5
Posts: 16866
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Tue Jun 16, 2009 2:49 am

Well, perhaps you could tell us what you have tried. Because the very first thing that I would tell you to do would be to change your RenderLandscapeMode (instructions are in that topic). Since you have given me nothing to go on, that is still the advice that I am going to give you. Find your preferences file, and add the line

Code: Select all

RenderLandscapeMode = [n]

where [n] is any number from 0 to 2, inclusive. Try all three numbers, and see if any of them work.

xander
CarthAnne
level0
Posts: 6
Joined: Mon Jun 15, 2009 2:56 pm

Postby CarthAnne » Wed Jun 17, 2009 6:17 pm

Where can I find Preferences txt.
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Wed Jun 17, 2009 7:09 pm

Would it be possible for you to give 1.5.11 a whirl and see if you suffer similar issues with that?

It sounds like it may be crashing before the game is able to create the appropriate files, and if you are indeed using 1.4.2, this could be a permissions related problem, which 1.5.11 is designed to cope with (a problem which became introduced with vista)

edit - in case it wasn't immidietly apparent, there's a very basic support page on the darwinia webpage with a link for the 1.5.11 patch, which the stickied help topic in this forum doesn't seem to mention. I tried it here and it seems to (as usual) require some ridiculous directx 9 dll that it doesn't even use before it will run, so you may need to pop by the MS webpage to get the latest end user runtime download - I'm going to have to and I'm using the windows 7 RC myself...
User avatar
xander
level5
level5
Posts: 16866
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Wed Jun 17, 2009 9:14 pm

From another stickied topic, mods are kept in one of the following places (where "Insurrection" is the name of a mod):
Using the Steam version: \Valve\Steam\SteamApps\[user]\darwinia\mods\Insurrection\
For Windows: \Program Files\Darwinia\mods\Insurrection\
For Mac: ~/Library/Application Support/Darwinia/full/mods/Insurrection/
For Linux: ~/.darwinia/mods/Insurrection/

If you remove the "mods/Insurrection/", that should be the location where preferences.txt is stored. Note that this is for WinXP, and maybe Vista. I don't know where Win7 keeps anything, so I can't help you. Assuming that Windows 7 does have some kind of search functionality, I would suggest using it to find "preferences.txt." You might have to tell it to look in hidden directories.

xander
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Wed Jun 17, 2009 10:41 pm

Well, actually, I poked about at the time and found the preferences.txt file in "C:\Users\Gena\Saved Games\Darwinia" (Gena being my username), but didn't post it since it was more likely it was 1.5.x/permissions related.
-- The GoldFish - member of former GIT and commander in chief of GALLAHAD. You could have done something, but it's been fixed. The end. Also, play bestgameever!
User avatar
xander
level5
level5
Posts: 16866
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Wed Jun 17, 2009 11:43 pm

The GoldFish wrote:Well, actually, I poked about at the time and found the preferences.txt file in "C:\Users\Gena\Saved Games\Darwinia" (Gena being my username), but didn't post it since it was more likely it was 1.5.x/permissions related.

That's right... the Vista/DX10 version puts files somewhere else. I had forgotten that. Somone should get xyzzyx to update his FAQ...

xander
CarthAnne
level0
Posts: 6
Joined: Mon Jun 15, 2009 2:56 pm

Postby CarthAnne » Sat Jun 20, 2009 9:24 pm

The GoldFish wrote:Would it be possible for you to give 1.5.11 a whirl and see if you suffer similar issues with that?

It sounds like it may be crashing before the game is able to create the appropriate files, and if you are indeed using 1.4.2, this could be a permissions related problem, which 1.5.11 is designed to cope with (a problem which became introduced with vista)

edit - in case it wasn't immidietly apparent, there's a very basic support page on the darwinia webpage with a link for the 1.5.11 patch, which the stickied help topic in this forum doesn't seem to mention. I tried it here and it seems to (as usual) require some ridiculous directx 9 dll that it doesn't even use before it will run, so you may need to pop by the MS webpage to get the latest end user runtime download - I'm going to have to and I'm using the windows 7 RC myself...


None of you seem to be listeninhg very well THE PC SAYS DARWINIA IS NOT COMPLETELY INSATALLED THUS I CANT INSTALL PATCH 1.5
User avatar
xander
level5
level5
Posts: 16866
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Sat Jun 20, 2009 9:36 pm

Uninstall everything, then try reinstalling. Aside from that, (1) Windows 7 is beta software, thus is likely prone to errors and (2) Darwinia is several years old and was made for XP, thus compatibility with Windows 7 is far from certain.

xander
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Sat Jun 20, 2009 9:38 pm

We are listening. The instructions given here are how to get the version you have running. The patch problem may be related to Windows 7 Beta, which of course is not yet officially supported.
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Sun Jun 21, 2009 4:46 am

Sorry, I didn't realise you were trying to install patch 1.5 and it was telling your installation was broken - you were hardly very clear to begin with.

Regardless, I'm running windows 7 64 bit and eventually managed to conjure up an original Darwinia CD. I'm afraid I had no problem installing, although windows gave me a prompt suggesting that it might not have installed properly and I might like to try reccommended settings (which I simply dismissed). Then, I immidietly ran the 1.5.11 installer downloaded from the IV webpage, which ran without issue. I think there can be issues with the 1.5.x installer deciding not to work if you don't have some redundant directx9 dll, but in my experience it's fairly clear about that.

If Darwinia simply isn't installing properly despite repeated attempts, it might be relavent for you to say exactly from what source you're installing it from, or maybe try installing it to a location other than program files unless you tried that already, since w7 etc is very protective of that folder.

Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 1 guest