crashbug, sound related

Problems with the Windows version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

Not A Fake Account
level0
Posts: 4
Joined: Sat Jan 06, 2007 2:44 am

crashbug, sound related

Postby Not A Fake Account » Sun Jun 15, 2008 11:01 pm

system: XP sp3, intel c2d e6850, 4gig ram, latest directx runtime (june 08), geforce 8800gt 512mb, asus xonar d2x soundcard

the first problem is when loading up a level, the world map fades out, the level fades in and after about 1 second freezes.

Code: Select all

=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : win32-full-1.5.11
ERROR   : 'DirectSound ERROR
..\..\code\sound\sound_library_3d_dsound.cpp line 1166

Direct sound couldn't set fx
Error Code : DSERR_CONTROLUNAVAIL
The control (vol, pan, etc.) requested by the caller is not available
Last error: The system cannot find the path specified.

 (3)'

=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundMixFreq = 22050
SoundMasterVolume = 255
SoundChannels = 32
SoundHW3D = 0
SoundSwapStereo = 0
SoundMemoryUsage = 1
SoundBufferSize = 512
SoundDSP = 1
ScreenWindowed = 1
ScreenZDepth = 24
RenderLandscapeDetail = 1
RenderWaterDetail = 1
RenderBuildingDetail = 1
RenderEntityDetail = 1
RenderCloudDetail = 1
RenderPixelShader = 1
ControlMouseButtons = 3
ControlMethod = 1
BootLoader = random
UserProfile = NewUser
RenderSpecialLighting = 0
Difficulty = 1
ScreenHeight = 1050
CurrentGameMode = 1
ScreenColourDepth = 32
ScreenRefresh = 60
ScreenWidth = 1680
RenderLandscapeMode = 1
LargeMenus = 0
AutomaticCamera = 0
ControlHelpEnabled = 0

=========================
====== STACKTRACE =======
=========================

retAddress = 0041C40A
retAddress = 10023730


if you edit preferences.txt to change SoundDSP to 0, then the game plays fine. when you quit it throws up an error

Code: Select all

=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : win32-full-1.5.11
ERROR   : 'DirectSound ERROR
..\..\code\sound\sound_library_3d_dsound.cpp line 217

DirectSound failed to shutdown primary buffer
Error Code : Unknown
n/a'

=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundMixFreq = 22050
SoundMasterVolume = 255
SoundChannels = 32
SoundHW3D = 0
SoundSwapStereo = 0
SoundMemoryUsage = 1
SoundBufferSize = 512
SoundDSP = 0
ScreenWindowed = 1
ScreenZDepth = 24
RenderLandscapeDetail = 1
RenderWaterDetail = 1
RenderBuildingDetail = 1
RenderEntityDetail = 1
RenderCloudDetail = 1
RenderPixelShader = 1
ControlMouseButtons = 3
ControlMethod = 1
BootLoader = random
UserProfile = NewUser
RenderSpecialLighting = 0
Difficulty = 1
ScreenHeight = 1050
CurrentGameMode = 1
ScreenColourDepth = 32
ScreenRefresh = 60
ScreenWidth = 1680
RenderLandscapeMode = 1
LargeMenus = 0
AutomaticCamera = 0
ControlHelpEnabled = 0

=========================
====== STACKTRACE =======
=========================

retAddress = 0041C40A

lastly if you're using another program that uses directsound output when you're launcing darwinia, in my case winamp, it gives the error "couldn't send sound data" before quitting
User avatar
xander
level5
level5
Posts: 16867
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Sun Jun 15, 2008 11:46 pm

The crash is a known bug with Realtime FX (the SoundDSP setting). In the future, you may try reading the stickies or searching the forums when you have a problem, as this issue has been brought up quite a few times in the past, and is a well known bug. The other two errors may be related, and kind of look like driver errors to me (i.e. your sound card drivers may be out of date). Not really sure on that, though -- I suggest that you try updating your drivers, and see if you still have a problem. If so, you might paste a dxdiag report here, and someone else may have an idea.

xander
Rangoon
level0
Posts: 2
Joined: Sun Jan 03, 2010 2:22 am

Postby Rangoon » Sun Jan 03, 2010 2:29 am

Hi,

I have this same error, which is different from the one in the Sticky. That one is a memory error, but this is different as shown in the OP. It seems that there is likely a fix for this, but I haven't been able to figure it out. I can either use hardware acceleration or realtime processing, but not both. I have tried using Creative Alchemy and varied the settings in that profile quite a bit. It will work (and it does enable my hardware acceleration option), but when I then add realtime processing, I get the crash.

I'm using an X-Fi card with Vista 64-bit, and without Alchemy I don't have the option to select hardware acceleration. With it I do, but then can't have realtime processing which doesn't make sense to me.

Any ideas?
Thanks!

I've played Darwinia all the way through on my Mac, but am looking forward to playing it on my Vista pc.

Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 2 guests