Points of light appearing as diamonds (win32-full-v1.21)

Problems with the Windows version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

altitude
level0
Posts: 7
Joined: Mon Jun 06, 2005 10:32 pm
Location: SF Bay Area, California, US
Contact:

Points of light appearing as diamonds (win32-full-v1.21)

Postby altitude » Mon Jun 06, 2005 10:50 pm

Hi folks.

(BTW, just to let all the introversion folks and testers know, this is a great game. Kudos to you all.)

In any case, i have version 1.21 for windows. My system is a P4-2.8, WinXP SP1, Nvidia 6600GT, running with 2 dvi monitors at 1600x1200 each, DX9.0c (i think) .

Most often, when I start running darwinia, the points of light that appear in the "selection screen" (the one where you select which level to go to) as well as the points of light on the tops of any of the buildings appear as diamonds instead of the standard points of light.

Sometimes, if i change the resolution or go from full-screen to windowed, it fixes itself, but it doesn't seem deterministic to me.

I have screenshots at http://www.funkware.com/~altitude/Darwinia/diamonds

Let me know if there's any other information i can provide.

Thanks!

...alex...
Last edited by altitude on Tue Jun 07, 2005 1:55 am, edited 1 time in total.
User avatar
trickfred
level5
level5
Posts: 1691
Joined: Sat Jul 24, 2004 5:01 am
Location: The Great White North, Eh?
Contact:

Postby trickfred » Mon Jun 06, 2005 11:05 pm

Yer link's broked. Lose the period. :)

Edit: That's trippy. Very boxy.
User avatar
xander
level5
level5
Posts: 16869
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Postby xander » Mon Jun 06, 2005 11:31 pm

I wonder if it has anything to do with this topic: http://forums.introversion.co.uk/darwin ... php?t=1202

Are you, by any chance, running Darwinia on a two headed system?

xander
User avatar
NeoThermic
Introversion Staff
Introversion Staff
Posts: 6254
Joined: Sat Mar 02, 2002 10:55 am
Location: ::1
Contact:

Postby NeoThermic » Tue Jun 07, 2005 12:50 am

xander wrote:I wonder if it has anything to do with this topic: http://forums.introversion.co.uk/darwin ... php?t=1202

Are you, by any chance, running Darwinia on a two headed system?

xander


altitude wrote:Nvidia 6600GT, running with 2 dvi monitors


Disable the second monitor and run Darwinia, see if that fixes the points of light problem.

NeoThermic
altitude
level0
Posts: 7
Joined: Mon Jun 06, 2005 10:32 pm
Location: SF Bay Area, California, US
Contact:

Postby altitude » Tue Jun 07, 2005 7:21 pm

Yes, disabling the second monitor did the trick.

I guess this ends up being a known issue. It does indeed seem to be the same problem as http://forums.introversion.co.uk/darwin ... php?t=1202.

Is there a fix being worked on for this one?

Thanks.

...alex...
sPank4
level1
level1
Posts: 23
Joined: Thu Dec 15, 2005 7:30 pm
Location: Australia

Postby sPank4 » Fri Dec 16, 2005 8:01 am

hey, old topic i know, but is there a fix being planned for this??

I didn't have the problem until i got the Rocket Crash problem (now patched). after it had crashed, next time i started it up it had the diamonds.

ill disable my second monitor for the mean time, but id love to see a patch.
StaticEngine
level1
level1
Posts: 10
Joined: Sat Feb 18, 2006 6:18 am
Location: Seattle, WA
Contact:

Postby StaticEngine » Sat Feb 18, 2006 8:56 pm

I'm having this problem too, on a multimonitor system with a nVidia 6600GT based video card. I used to have an ATI 9600XT video card, and I'm sure the bug didn't occur with that setup. The bug goes away when I switch to single monitor mode, but that's a pain because of my slightly odd setup (1 LCD & 1CRT, CRT is "primary" monitor for gaming, but all icons and start bar are on the LCD because it's bigger and sharper, but it's smears black, making it less than ideal for gaming).

Anyway, I'm wondering, this has some indcations that it may be an nVidia driver issue, unless the billboard/particle rendering code for Darwinia is doing something specific and weird that would behave differently between the two chipsets (ATI vs. nVidia).

Should I alert nVidia of this bug, and try to get them to fix texturing in their drivers for multimon systems, or does Introversion need to take a day away from deving Defcon to fix their code and release another patch?

Thanks.
phuzz
level0
Posts: 2
Joined: Wed Feb 22, 2006 2:55 pm
Location: Bristol, UK

Postby phuzz » Wed Feb 22, 2006 3:04 pm

I'm getting the same problem with two monitors on a Geforce 6800XT and the Steam version of Darwinia, so it does look like an nVidia issue. Different graphics drivers don't seem to change things.
However, I have found another work-around:
Once you're in-game and in a map. Go to Screen Options and change the Z-Buffer Depth and hit apply.
For me this gets rid of the dimond-y things.
It doesn't seem to make any difference whether Darwinia starts up with 16-bit or 24-bit Z-Buffer, it's just the act of changing it that fixes the issue. Generally, I just start a map, switch to 16, hit apply, then imediately change back to 24.
Hopefully that's a more hassle free option for people than disabling the second monitor (I thought it was a suprisingly big bug to still be unfixed, I guess not everyone knows the joys of dual screens yet :))
User avatar
NeoThermic
Introversion Staff
Introversion Staff
Posts: 6254
Joined: Sat Mar 02, 2002 10:55 am
Location: ::1
Contact:

Postby NeoThermic » Wed Feb 22, 2006 3:15 pm

phuzz wrote:I'm getting the same problem with two monitors on a Geforce 6800XT and the Steam version of Darwinia, so it does look like an nVidia issue. Different graphics drivers don't seem to change things.
However, I have found another work-around:
Once you're in-game and in a map. Go to Screen Options and change the Z-Buffer Depth and hit apply.
For me this gets rid of the dimond-y things.
It doesn't seem to make any difference whether Darwinia starts up with 16-bit or 24-bit Z-Buffer, it's just the act of changing it that fixes the issue. Generally, I just start a map, switch to 16, hit apply, then imediately change back to 24.
Hopefully that's a more hassle free option for people than disabling the second monitor


That is an intresting fix. Can anyone else who has this issue please try this work around and report back to if it works or not? If so, I'll go ahead and include this in my common bugs topic.



phuzz wrote:I thought it was a suprisingly big bug to still be unfixed, I guess not everyone knows the joys of dual screens yet :)


Well, I run dual monitors, but on an ATi setup and don't get this problem. Although it was discoverd a while ago, the only related factor is the use of nVidia cards (there's a few bugs that apply to ATi or nVidia cards only).

NeoThermic
StaticEngine
level1
level1
Posts: 10
Joined: Sat Feb 18, 2006 6:18 am
Location: Seattle, WA
Contact:

Postby StaticEngine » Thu Feb 23, 2006 5:13 am

I contacted nVidia tech support, and they stated that it wouldn't be fixed until the developers (Introversion) contacted them and sent them some code for nVidia to debug.

I'm pretty sure nVidia provides this service for free, since games that run bad on their hardware makes them look bad. Introversion should really look into this. There's a good number of people who run multimon these days, and about half the people run on nVidia...
StaticEngine
level1
level1
Posts: 10
Joined: Sat Feb 18, 2006 6:18 am
Location: Seattle, WA
Contact:

Postby StaticEngine » Thu Feb 23, 2006 5:16 am

Also, the switching Z-Buffer depth as a fix works for me as well. Good find!
brandorf
level0
Posts: 1
Joined: Mon Jul 24, 2006 3:39 pm

Postby brandorf » Mon Jul 24, 2006 3:46 pm

In the nVidia drivers, you can set individual overides for each program. Setting Darwinia.exe to "Compatibility Performance Mode" (Versus "Multiple Display Performance Mode") seems to have fixed the light issue.

Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 2 guests