Crash After Demoting Officer, Then Creating New One

Problems with the Windows version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

User avatar
film11
level3
level3
Posts: 411
Joined: Sat Jun 19, 2004 4:51 pm

Crash After Demoting Officer, Then Creating New One

Postby film11 » Sat Aug 28, 2004 11:50 pm

I was going to lead my group of Darwinians to an incubator I had just captured. So I created an officer and right clicked near him to group all of my Darwinians near him. I accidently demoted him, no problem I thought, I'll just make another. I opened the task manager, drew the officer gesture and the moment I let go of the mouse button it crashed with a blackbox. Then after the blackbox message I get another message (memory could not be read) (in the screenie below blackbox.):

Code: Select all

=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : win32-demo-beta1
ERROR   : 'Darwinia has been forced to shutdown.
Please post your 'blackbox' file to the Darwinia forums, with a description of the error you encountered'

=========================
===== SYSTEM REPORT =====
=========================

SysInfoGenVersion: 1
CPU:               Intel(R) Pentium(R) 4 CPU 3.20GHz
Num Processors: 2
Country: United Kingdom
Language: English
Num sound devices: 1
Primary sound device: SB Audigy 2 Audio [B800]
Graphics Card: Celestica Gold Edition RADEON 9600XT 128MB
Operating System: Windows XP
Computer Name: JACK



=========================
====== USER DATA ========
=========================

USERNAME : film11
EMAIL    : jackdudman2k1@hotmail.com

=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
SinglePlayer = 1
IAmAServer = 1
Editor = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundDriver = -1
SoundMixFreq = 44100
SoundMasterVolume = 255
SoundChannels = 16
SoundHW3D = 1
SoundSwapStereo = 1
ScreenWidth = 1024
ScreenHeight = 768
Windowed = 0
RenderLandscapeLighting = 1
RenderLandscapeOverlay = 1
RenderLandscapeDetail = 1
RenderWater = 1
RenderWaterDetail = 1
RenderClouds = 1
RenderNegative = 0
RenderPixelShader = 1
RenderSmoothLines = 1
RenderHighDetailVirii = 1
RecordDemo = 0
DemoFrameRate = 25
StartMap = mine
TestHarness = 0
ShowIntro = 0

=========================
====== STACKTRACE =======
=========================

retAddress = 00410749
retAddress = 0045D317
retAddress = 004146E1
retAddress = 0046AC36
retAddress = 77E814C7
retAddress = 00000000


Heres the screenie with second error:
Image
User avatar
LLamaBoy
level5
level5
Posts: 1627
Joined: Sun Aug 18, 2002 12:18 pm
Location: Nicosia, Cyprus
Contact:

Postby LLamaBoy » Sun Aug 29, 2004 12:08 am

This is another incarnation of the infamous Officer Bug. It's been mentioned before that it still crashes if you demote the officer without deselecting him post-creation, though I'm not sure which of the many threads it's in.
User avatar
film11
level3
level3
Posts: 411
Joined: Sat Jun 19, 2004 4:51 pm

Postby film11 » Sun Aug 29, 2004 11:00 am

The officer appears to be the most of troublesome of users it seems :/
User avatar
Soulkeeper
level3
level3
Posts: 457
Joined: Sun Jun 27, 2004 3:04 pm
Location: Dorset, UK
Contact:

Postby Soulkeeper » Sun Aug 29, 2004 11:03 am

Agreed. Seems this is going to be one of the first things to be fixed. :?
- I see your destiny, I control your fate. I am the Guardian Soulkeeper. -
goweb
level3
level3
Posts: 377
Joined: Fri Aug 09, 2002 6:25 pm
Location: Guildford, Surrey, England
Contact:

Postby goweb » Sun Aug 29, 2004 12:26 pm

I demoted an officer and then it crashed as soon as I tried to load the Task Manager.

=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : win32-demo-beta1
ERROR : 'Darwinia has been forced to shutdown.
Please post your 'blackbox' file to the Darwinia forums, with a description of the error you encountered'

=========================
===== SYSTEM REPORT =====
=========================

SysInfoGenVersion: 1
CPU: AMD Athlon(tm) XP 1800+
Num Processors: 1
Country: United Kingdom
Language: English
Num sound devices: 3
Primary sound device: Creative Sound Blaster PCI
Graphics Card: GIGABYTE RADEON 9600 PRO
Operating System: Windows XP
Computer Name: GEMSPACE



=========================
====== USER DATA ========
=========================

USERNAME : goweb
EMAIL : goweb@o2.co.uk

=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
SinglePlayer = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = dsound
SoundDriver = -1
SoundMixFreq = 44100
SoundMasterVolume = 255
SoundChannels = 16
SoundHW3D = 0
SoundSwapStereo = 1
ScreenWidth = 1024
ScreenHeight = 768
Windowed = 0
RenderLandscapeLighting = 0
RenderLandscapeOverlay = 1
RenderLandscapeDetail = 1
RenderWater = 1
RenderWaterDetail = 1
RenderClouds = 1
RenderNegative = 0
RenderPixelShader = 1
RenderSmoothLines = 1
RenderHighDetailVirii = 0
RecordDemo = 0
DemoFrameRate = 25
StartMap = mine
TestHarness = 0
ShowIntro = 0
=========================
====== STACKTRACE =======
=========================

retAddress = 00410749
retAddress = 0045D317
retAddress = 004146E1
retAddress = 0046AC36
retAddress = 7C816D4F
retAddress = 00000000

Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 1 guest