Vibrating Camera View

Problems with the Windows version of Darwinia

Moderators: jelco, bert_the_turtle, Chris, andy, John

Andcarne
level4
level4
Posts: 675
Joined: Mon May 26, 2003 1:44 am

Vibrating Camera View

Postby Andcarne » Sat Aug 28, 2004 6:05 am

This occurs when the camera is partway up a slope, near a sharp corner in the slope. When the camera turns away from the corner, it suddenly jerks back, as if the back end of the camera is coming into contact with the edge, and being bounced back. It's hard to describe it any better then this, but I can record and post a small video if needed.

Reproducability: This is reproducible in many areas of the terrain, if the positioning of the camera is right. It occurs every time, no matter what graphical settings are used, or at what point in the level I am at.
skwirl42
level1
level1
Posts: 22
Joined: Fri Oct 22, 2004 9:54 pm
Location: Montreal, Canada
Contact:

Wild camera changes

Postby skwirl42 » Thu Oct 28, 2004 12:40 am

I'm getting some wild camera changes (really all over the place), almost always. Close to the ground, close to cliffs, near nothing, etc. It only happens when I use the mouse for moving around. Using the keyboard controls, I have no trouble whatsoever.

Is this a new bug?

In any case, the view changes have made me nauseous and gave me a splitting headache. Not blaming you guys, or anything. :) That's just how wild the camera movement is.

I haven't been able to try anything else out simply because I can't get the view to relax enough. I also haven't managed to figure out how to change preferences, but I guess that's more a problem on my end than anything else.

skwirl42
skwirl42
level1
level1
Posts: 22
Joined: Fri Oct 22, 2004 9:54 pm
Location: Montreal, Canada
Contact:

more details

Postby skwirl42 » Thu Oct 28, 2004 12:53 am

It seems I barely have to move the mouse to cause the camera to whip around. The whipping around gets progressively faster, but settles down if I then point the camera up with the mouse. It really does settle down, somewhat like a ball near the end of its bounces.

Sometimes this will happen even without the mouse being used, when the view is closer to landforms.

edit: here's a screen capture

edit 2: Here's my sysinfo:

SysInfoGenVersion: 2
CpuVendor: PowerPC 7450
CpuModel: ppc7450
Num Processors: 1
Language: en_CA
Num sound devices: 1
Primary sound device: Built-in Audio
Graphics Card: ATY,Rage128Pro
Operating System: Darwin 7.5.0

The processor is 1 GHz and I've got 896 MB of RAM.
skwirl42
level1
level1
Posts: 22
Joined: Fri Oct 22, 2004 9:54 pm
Location: Montreal, Canada
Contact:

further nailing down

Postby skwirl42 » Thu Oct 28, 2004 2:36 am

I've nailed this down to having landforms in the camera's view. The camera tends to whip back and forth (sometimes with up and down motions) until it calms down facing outward from the landforms.

However, when I turned to the right after that, it didn't happen. When I turned to the left it did. This is at the starting location.
User avatar
Soulkeeper
level3
level3
Posts: 457
Joined: Sun Jun 27, 2004 3:04 pm
Location: Dorset, UK
Contact:

Postby Soulkeeper » Thu Oct 28, 2004 3:02 am

This bug has already been documented, both here and class B. Bit had to class as people could call it a graphical glitch, but at the same time, its quite serious (I think someone's tried classing it as an A before now). Anyway, the cause is an extremely low fps which, can be fixed by dropping your settings real low. e.g. run in 640 * 480 or 800 * 600 only. Turn all details and water details off (do this by setting RenderWaterDetail and RenderWater etc to zero). Also, set RenderLandscapeDetail = 4 just to help boost things a wee bit. There might be a couple of other things you can do, but these seem to be most effective. Oh, try things like diver updates and HDD defrags if my first tips don't work.

I think this is largely due to the particular gcards you guys are using (I had the same problem on my laptop). The above are temporary solutions, the best way is to get a better gcard, or just hope IV is willing to support the one's you are using.
- I see your destiny, I control your fate. I am the Guardian Soulkeeper. -
skwirl42
level1
level1
Posts: 22
Joined: Fri Oct 22, 2004 9:54 pm
Location: Montreal, Canada
Contact:

graphics card

Postby skwirl42 » Thu Oct 28, 2004 3:10 am

Yeah, my graphics card is a 16 MB Rage Pro. The one thing on my system I haven't upgraded, simply because of the ridiculous cost of Mac versions of video cards.

I gave the lowering a try, and no good. Still does that. Guess I'll need to get a new video card... ugh... I have been meaning to get a new one, but money's tight and there are other priorities.
User avatar
Soulkeeper
level3
level3
Posts: 457
Joined: Sun Jun 27, 2004 3:04 pm
Location: Dorset, UK
Contact:

Postby Soulkeeper » Thu Oct 28, 2004 3:16 am

Oh, last ditch resort. Keep you camera close to the ground, and looking down. As long as your card isn't trying to render too much, there shouldn't be a problem.
- I see your destiny, I control your fate. I am the Guardian Soulkeeper. -
skwirl42
level1
level1
Posts: 22
Joined: Fri Oct 22, 2004 9:54 pm
Location: Montreal, Canada
Contact:

hmmm

Postby skwirl42 » Thu Oct 28, 2004 3:28 am

My question is, though, why would low frame rate affect the camera?

But scene complexity does seem to be a big deciding factor. Whenever I get a lot in view, even accidentally, it starts gyrating wildly. I'll check in the class B section, see what's been said there, for starters.

I wasn't actually able to keep the view stable for long enough to do anything. I wanted to zoom into the Darwinians, but I got a lot in camera, and it immediately went insane.
Karajin
level0
Posts: 2
Joined: Tue Oct 19, 2004 5:36 am

Postby Karajin » Thu Oct 28, 2004 5:32 am

When ever I play my cammera starts to bob left &right or up &Down...Then it speads up so all I see is real quick below me and one real quick sky shot...its hurting my head...Also it just dose it on its own, I don't even get a chance to move...
User avatar
Dominator
level2
level2
Posts: 153
Joined: Fri Jul 02, 2004 9:58 pm
Location: Darwinia Land
Contact:

Postby Dominator » Thu Oct 28, 2004 10:47 am

i had this problem and the solution for me was to press F2 a couple of times, and this seemed to sort the problem out for me, althought i must say that in the third release of the game it happens a lot less
I never could get the hang of Thursdays
User avatar
Soulkeeper
level3
level3
Posts: 457
Joined: Sun Jun 27, 2004 3:04 pm
Location: Dorset, UK
Contact:

Postby Soulkeeper » Thu Oct 28, 2004 11:23 am

It does it because the camera is trying to follow the mouse. At low fps the camera over-compensates each time it tries to track the mouse, cuasing the vibration effect.

Dom is right, F2 prevents camera from following the mouse. Just hit F2 a couple of times when you need it, because it stops you from being able to look around the map with mouse.

One last thing, when you start, hit F5 aswell, it will display an fps count in the top left corner of the screen. What does it say? Mine holds steady at 60 with full detail and the whole map in view (w00t).
- I see your destiny, I control your fate. I am the Guardian Soulkeeper. -

Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 1 guest