Solution to Windows ALT-TAB problem

Anything and everything

Moderators: bert_the_turtle, jelco, Chris

neurocrash
level0
Posts: 7
Joined: Mon Nov 20, 2006 10:56 pm

Solution to Windows ALT-TAB problem

Postby neurocrash » Tue Nov 21, 2006 12:52 am

If you are one of the lucky ones who has had problems with this, here is what I have learned:

a. The ALT-TAB to switch between programs only seems to work when in Gestures mode - it would be nice it it worked in both (patch or update please?)

b. If you are in Gestures mode and Windows still wants to change to other Windows apps, I think I've found the solution to this problem.

Some programs can make a registry change to somehow "enhance" your task switching experience. Change it back to normal like this:

1. Start the Registry Editor (regedit.exe)
2. Move to HKEY_CURRENT_USER\Control Panel\Desktop
3. Double click on Coolswitch
4. Set to 0 and click OK
5. Close the registry editor

In my case, it was set to 1, which resulted in ALT-TAB triggering Windows task management instead of Darwinia.

Cheers!
User avatar
xander
level5
level5
Posts: 16868
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Re: Solution to Windows ALT-TAB problem

Postby xander » Tue Nov 21, 2006 1:47 am

neurocrash wrote:a. The ALT-TAB to switch between programs only seems to work when in Gestures mode - it would be nice it it worked in both (patch or update please?)

It is only supposed to work in the gesture mode. In the gesture mode, [ALT] brings up the task manager, and, with the task manager up, [TAB] can be used to switch between programs. In the icon mode, [TAB] brings up the task manager, and the mouse must be used to select programs.

xander
neurocrash
level0
Posts: 7
Joined: Mon Nov 20, 2006 10:56 pm

Postby neurocrash » Tue Nov 21, 2006 1:57 am

I suppose that since the manual does not reflect the version of the game in my box, this distinction was not clear. In any case, I would not have been able to use it in Gestures mode due to the above Windows task switching problem, so I wanted to pass on this fix since I did not locate a solution in these forums.

Thanks for helping with the clarification.
chalz.r
level0
Posts: 7
Joined: Wed Dec 06, 2006 4:42 am
Location: USA

Postby chalz.r » Wed Feb 06, 2008 8:55 pm

So, like.. help? I know this is an ancient thread, but searching for 'alt-tab' hasn't brought me many new options..

I installed the 1.5.11 patch on my XP system today, and alt-tab switches between Windows programs, not Darwinia programs. I am in gesture mode (I find it so much faster and slicker than icon mode) and tried that CoolSwitch option change and no go. Am I doomed? Are my only options now to downgrade or hunt for the CTRL key so I can do ctrl-alt-tab?

<insert whining and suffering>

Or has some new information come to light that I'm not finding?
User avatar
KingAl
level5
level5
Posts: 4138
Joined: Sun Sep 10, 2006 7:42 am

Postby KingAl » Wed Feb 06, 2008 10:54 pm

Yep, the system's changed in the latest patch. I believe it's Ctrl + Tab - though you can manually select the slot you want with the mouse if you bring up the control panel with Ctrl.
Gentlemen, you can't fight in here: this is the War Room!
Ultimate Uplink Guide
Latest Patch

Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests