Autopatcher Locking Me Out of the Game

Get community help for technical problems

Moderators: bert_the_turtle, jelco

User avatar
Feud
level5
level5
Posts: 5149
Joined: Sun Oct 08, 2006 8:40 pm
Location: Blackacre, VA

Autopatcher Locking Me Out of the Game

Postby Feud » Sat Sep 20, 2008 7:28 am

So it's worked just fine for me all day, but now whenever I try to start the game it freezes when the auto patcher looks for updates. Restarting the comp worked once, but not any more.

I've tried digging through the Main.dat for an override, but to no avail. Is there anyway to turn off the auto patch system?

Edit: I have tried reinstalling Multiwinia, but it is giving me the same problem. I am now totally unable to start the game.

This is quite frustrating.
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Sat Sep 20, 2008 7:34 am

Create a shortcut to multiwinia.exe

?????

Also I had it freeze on me a few minutes ago - I think there might be something wrong with something.

Code: Select all

Autopatch version 003 2008-07-13 vista
Config{ dl = "C:\Documents and Settings\admin\Local Settings\Application Data\Introversion\Multiwinia\update",
        manifest = "",
        sizeOnly = No,
        respawn = No,
        launch = Yes,
        mode = "upgrade",
        doNothing = No,
        runCopier = Yes,
        revert = No }
APP_DIR: C:\Program Files\Multiwinia
authkey file in user profile? Yes
authkey file app dir? No
version file exists? Yes
Appdir writable? Yes
Running Vista? No
RUNNING DOWNLOAD... DownloadItem{
   valid  = Yes,
   url    = "update.introversion.co.uk/autopatch/manifest.php?version=retail.iv.1.0.5&key=THISW-OULDB-EMYKE-YSOIH-IDITS&game=Multiwinia&mode=upgrade",
   write  = No,
   fpath  = "",
   resume = Yes,
}
DOWNLOAD ERROR 7: couldn't connect to host


It does freeze for me but comes back to life after about 20 seconds.
User avatar
Feud
level5
level5
Posts: 5149
Joined: Sun Oct 08, 2006 8:40 pm
Location: Blackacre, VA

Postby Feud » Sat Sep 20, 2008 7:46 am

Short cutting directly to the multiwinia exe worked, I just hope that this can either be fixed or that future updates can be manually downloaded.

I wonder if changing the launch to "No" or changing the mode might do something.
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Sat Sep 20, 2008 8:07 am

Since that's a debug output text file (local settings/application data/introversion/multiwinia/autopatch_debug.txt) I'm not sure it'd have many effects. However maybe these can be controlled via command line - you'd have to ask Ice or whomever made the autopatcher in the first place. I'd love the abilty to turn off the autolaunching o_o
RabidZombie
level5
level5
Posts: 2414
Joined: Fri Nov 18, 2005 10:09 pm

Postby RabidZombie » Sat Sep 20, 2008 10:37 am

I thought skipping the autoupdater just involved running multiwinia.exe, instead of autopatch.exe.
User avatar
Chris
Introversion Staff
Introversion Staff
Posts: 1172
Joined: Sat Nov 25, 2000 7:28 pm
Location: Cambridge, UK
Contact:

Postby Chris » Sat Sep 20, 2008 10:50 am

The autopatcher doesn't lock up completely - it times out after 15 seconds. If you just wait for it, even though it appears to be dead, it will eventually give up trying and run the game normally.

Also, you can just run Multiwinia.exe directly if the Autopatcher is genuinely not working for you.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sat Sep 20, 2008 3:54 pm

Feud:

Does it freeze for more then 15-20 secs?

Post autopatch_debug.txt? (Use the 'Open Multiwinia Profile' windows start menu shortcut to locate it)

Do you run any firewalls? Do adding permissions for the autopatcher solve it?
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch
User avatar
Feud
level5
level5
Posts: 5149
Joined: Sun Oct 08, 2006 8:40 pm
Location: Blackacre, VA

Postby Feud » Sat Sep 20, 2008 4:44 pm

Chris wrote:The autopatcher doesn't lock up completely - it times out after 15 seconds. If you just wait for it, even though it appears to be dead, it will eventually give up trying and run the game normally.

If I just left it alone after about 5-10 seconds the Window shows "-Not Responding", and 5-10 seconds after that the window goes away and the standard "This Program is not Responding" box comes up.

Chris wrote:Also, you can just run Multiwinia.exe directly if the Autopatcher is genuinely not working for you.

That's what I ended up doing.

I tried it this morning and it seems to be working, so it seems to be a hit or miss problem. Linking directly to the Multiwinia.exe makes it work great, so I'll just have to pay attention for when patches are released.

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest