(SOLVED) Mouse freaking out in Defcon for Linux.

Technical support for all issues relating to Defcon Linux

Moderator: Defcon moderators

meldroc
level0
Posts: 2
Joined: Tue Feb 05, 2013 4:02 am

(SOLVED) Mouse freaking out in Defcon for Linux.

Postby meldroc » Tue Feb 05, 2013 4:06 am

Right now I'm running it in Kubuntu 12.10, just purchased the paid version on Steam.

When I run DEFCON full-screen, there is an issue where I can move my mouse for a fraction of a second, then it snaps back to the screen center. This is very annoying, and makes the game unplayable.

So far, the only workaround I've found is to switch the game to windowed mode (I edited the preferences text config file to do this), but I'd really rather play the game full-screen if I can get the mouse to work.

Anybody have a solution to this problem?\

Edit: Fixed it! See my post below...
Last edited by meldroc on Wed Feb 06, 2013 7:13 pm, edited 1 time in total.
User avatar
trickser
level5
level5
Posts: 1823
Joined: Thu Mar 06, 2008 2:15 pm
Location: The Senate ; GMT+1
Contact:

Postby trickser » Tue Feb 05, 2013 3:16 pm

I am just guessing, but maybe its an SDL issue. I have no experience with steam linux defcon, but usually defcon ships with his own SDL. You can try to delete it and install a system package.
meldroc
level0
Posts: 2
Joined: Tue Feb 05, 2013 4:02 am

SOLVED IT!

Postby meldroc » Wed Feb 06, 2013 1:08 am

I googled SDL, dug up some environment variables.

I fixed the problem by setting this environment variable:

export SDL_MOUSE_RELATIVE=0

So I created a tiny starter shell-script to get Defcon rolling:

Code: Select all

#!/bin/bash

# See if this fixes the mouse glitch
export SDL_MOUSE_RELATIVE=0

cd /usr/local/games/defcon
./defcon.bin.x86_64


The game's working fine now.

Return to “Linux Troubleshooting”

Who is online

Users browsing this forum: No registered users and 2 guests