Page 1 of 1

Mouse is too fast/sensitive in Defcon on Ubuntu 11.04/11.10

Posted: Wed Nov 23, 2011 8:28 pm
by tntc
The mouse sensitivity in Defcon is extremely high, making it very difficult to click on buttons, etc. in game. Moving my finger 1/4 of the way across my touchpad moves the cursor across the entire screen. This is roughly 8x as sensitive as my touchpad outside the game. Is there any way to adjust the sensitivity?

Posted: Thu Nov 24, 2011 4:35 am
by frenchfrog
I suspect this related to SDL.

I've done quick search, most posts refer to setting the environment variable "SDL_VIDEO_X11_MOUSEACCEL".

SDL_VIDEO_X11_MOUSEACCEL
For X11, sets the mouse acceleration. The value should be a string on the form:

"n/d/t"

where n and d are the acceleration numerator/denumerators (so mouse movement is accelerated by n/d), and t is the threshold above which acceleration applies (counted as number of pixels the mouse moves at once).

From http://sdl.beuc.net/sdl.wiki/SDL_envvars

The necessary environment variable is SDL_VIDEO_X11_MOUSEACCEL.
I found that setting SDL_VIDEO_X11_MOUSEACCEL didn't work for me without setting SDL_MOUSE_RELATIVE=0 too.

So, for example:

$ SDL_MOUSE_RELATIVE=0 SDL_VIDEO_X11_MOUSEACCEL=6/1/0 openttd

There are other reports which suggest that

$ SDL_VIDEO_X11_DGAMOUSE=0

might work.

From http://wiki.openttd.org/FAQ_troubleshooting

Open a terminal and type

gedit ~/.profile

Add these lines

export SDL_VIDEO_X11_MOUSEACCEL="1/1/1"
export SDL_VIDEO_X11_DGAMOUSE=0

to the end of the file. Save and exit. Log out. Log back in.
The environment variables will be set for all programs you launch.

From http://ubuntuforums.org/archive/index.p ... 32135.html

Posted: Thu Nov 24, 2011 1:47 pm
by carebear
Moving my finger 1/4 of the way across my touchpad


.... playing with touchpad will make you become a good victim ... buy a mouse .. :X