Dodgy Textures

Technical support for all issues relating to Defcon Linux

Moderator: Defcon moderators

User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Dodgy Textures

Postby shinygerbil » Wed Oct 17, 2007 10:37 pm

Brand new install of Defcon, (almost) brand new install of Ubuntu. With a lot of my old settings imported in. No problems with any other game that I have as yet tried (including Darwinia)...

This is what I get:

Image

Image

Image

The picture of the mouse changes, depending on what icon is being used (move/resize icon, etc.)

What is hard to notice, but also present, is the fact that some of the text boxes have odd borders. If you look at the MOTD box you can kinda see it (at the bottom and on the right).

The game is still playable but it also randomly flashes what looks like a calendar in place of the mouse icon. I'm trying without success to catch it. It's very weird.

Is it my install, or is the latest version from the site borked?

Note: this happens whether I put in my authkey and old preferences.txt or not.
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Wed Oct 17, 2007 11:25 pm

OK, so it does happen in Uplink (fresh install, latest version).

This is the same thing that keeps flashing up in Defcon...

Image
User avatar
xander
level5
level5
Posts: 16868
Joined: Thu Oct 21, 2004 11:41 pm
Location: Highland, CA, USA
Contact:

Postby xander » Wed Oct 17, 2007 11:39 pm

j00r li|\|ux iz b0rk3d!

xander
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Wed Oct 17, 2007 11:48 pm

omg no wai D:
Here is my signature. Make of it what you will.
Image
ChileanSuperpower
level2
level2
Posts: 118
Joined: Sun Sep 23, 2007 10:26 pm
Location: Santiago de Chile

Postby ChileanSuperpower » Thu Oct 18, 2007 12:47 am

LOL!
estel
level4
level4
Posts: 689
Joined: Mon Jan 02, 2006 11:20 pm
Location: Bristol
Contact:

Postby estel » Thu Oct 18, 2007 2:42 pm

Yup, borked :P

Have you tried running them in a failsafe mode for your WM?
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Fri Oct 19, 2007 2:33 am

estel wrote:Yup, borked :P

Have you tried running them in a failsafe mode for your WM?


It gets stranger! That works for Uplink, but not for Defcon...
Here is my signature. Make of it what you will.

Image
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Tue Nov 20, 2007 11:48 am

Umm...Bump? I've tried lots of stuff and none of it works!
Here is my signature. Make of it what you will.

Image
estel
level4
level4
Posts: 689
Joined: Mon Jan 02, 2006 11:20 pm
Location: Bristol
Contact:

Postby estel » Wed Nov 21, 2007 4:42 pm

WINDOZE.
User avatar
Pox
level5
level5
Posts: 1786
Joined: Sat Mar 03, 2007 11:23 am
Location: Melbourne
Contact:

Postby Pox » Thu Nov 22, 2007 4:41 am

estel wrote:WINDOZE.


:o teh devils!
estel
level4
level4
Posts: 689
Joined: Mon Jan 02, 2006 11:20 pm
Location: Bristol
Contact:

Postby estel » Mon Nov 26, 2007 5:58 am

In seriousness, I think that it's most likely the be the fault of the graphics drivers...
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Wed Nov 28, 2007 3:17 pm

Meh, I'm probably gonna reinstall tonight (I feel like dualbooting Windows - mostly so I have a chance of getting into the Multiwinia beta :wink: ) so hopefully it'll sort itself out...
Here is my signature. Make of it what you will.

Image
User avatar
shinygerbil
level5
level5
Posts: 4667
Joined: Wed Dec 22, 2004 10:14 pm
Location: Out, finding my own food. Also, doing the shinyBonsai Manoeuvre(tm)
Contact:

Postby shinygerbil » Sat Dec 01, 2007 3:41 am

Code: Select all

steve@steve-laptop:/opt/defcon/defcon-v1.42/lib$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI Radeon 20061018 AGP 4x x86/MMX/SSE2 NO-TCL
OpenGL version string: 1.3 Mesa 7.0.1
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_logic_op, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_histogram,
    GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_stencil_wrap, GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
    GL_MESA_ycbcr_texture, GL_MESA_window_pos, GL_NV_blend_square,
    GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_OES_read_format, GL_SGI_color_matrix,
    GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x54 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
User avatar
NeoThermic
Introversion Staff
Introversion Staff
Posts: 6253
Joined: Sat Mar 02, 2002 10:55 am
Location: ::1
Contact:

Postby NeoThermic » Sat Dec 01, 2007 10:52 pm

Ok, so using a app I coded for testing my theory, this has been tentatively solved. The card that shinygerbil is using is a mobile version of the Radeon 7000 chipset. This chipset doesn't support NPOT textures (non-power of two). Some of the textures defcon loads (coastlines.bmp for example) have a NPOT side (in the case of coastlines.bmp, it's 512 x 285). He indicated to me, however, this worked fine under older versions of ubuntu and windows, so one can assume that the OpenGL implementation in those cases faked support and passed something usable to the graphics card.

NeoThermic
toxxx
level0
Posts: 7
Joined: Tue Jan 08, 2008 6:24 pm

so whats the solution

Postby toxxx » Wed Jan 28, 2009 12:17 am

Okay, so neothermic know what the problem is with NPOT textures...


how do we get it fixed, I'd consider offering a bounty, because I'd rather nuke myself and eat radioactive
sludge all day, than put windows onto my laptop..


if anyone else is having this issue, lets get together and offer a bounty!!

:-)

Return to “Linux Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest