Steam Authentication Failed

Technical Support for all Defcon related issues

Moderator: Defcon moderators

Mikea
level0
Posts: 2
Joined: Sun Mar 21, 2010 2:33 am

Steam Authentication Failed

Postby Mikea » Sun Mar 21, 2010 2:47 am

I was planning on getting together with a few friends to play Defcon this weekend, but I haven't been able to get my recently purchased copy to authenticate. Looking over the forums and various other websites I'm noticing that this is a common problem. But so far, none of the recommended fixes have helped.

I've tried deleting my authkey file to force the game to get a new one. So far this has always failed. I've tried doing this after each of the fixes below, but it either fails while Getting Encryption Details or Requesting Authentication.

I've tried directly connecting my computer to my cable modem to bypass the router.
I've tried disabling Windows Firewall (Vista x64).
I've tried signing out of Steam and then back in.
I've tried deleting the game, uninstalling from Steam, and then redownloading.
I've tried launching Steam with Administrative privileges and setting the Defcon executable to run as Administrator.
I've tried updating all drivers (video, sound, motherboard) to the most recent versions.

Since I've taken the router out of the equation, I'm not sure this is a network port blocking issue. But any suggestions would be nice.

Here's a sample from debug.txt after the game fails authentication at Requesting Authentication:

Code: Select all

Defcon 1.43 steam built Jul  2 2007
Parsing archive main.dat...DONE
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 27ms
Parsing International data (2753 islands) : 10ms
Parsing City data (2745 cities) : 14ms
Parsing archive sounds.dat...DONE
Failed to load AuthKey : 'authkey'
Authentication key set : 'authkey not found'
WinSock started
Connection established to MetaServer, listening on Port 5009
Steam Authentication Initiated
Steam Authentication : Starting Steam
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Starting Steam API
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = <removed>
Steam Authentication : Getting Encryption Details
Received Authentication : authkey not found : (keyID -1) : Key invalid
Key failed basic check : authkey not found (result=Key invalid)
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
Requesting data from MetaServer : sb
Received data from MetaServer : sb
Steam Authentication : Getting Steam2 Auth
Steam Authentication : Getting Steam3 Auth
Steam Authentication : Requesting Authentication
Steam Authentication FAILED
pdoff
level0
Posts: 2
Joined: Sun Mar 21, 2010 3:00 pm

Postby pdoff » Sun Mar 21, 2010 3:12 pm

I have the same issue, having just bought the game on Steam today. I have also run through all the solutions given on the forums with no luck.

As far as I am concerned, I have been sold a defective product and will be trying to get my money back. I guess this is what I get for legitimately purchasing a game I suppose. And please, don't insult my intelligence by trying to blame pirates for this. Game companies have a choice and they choose to dick around paying customers.
Sabrak
level0
Posts: 2
Joined: Sun Mar 21, 2010 3:10 pm

Postby Sabrak » Sun Mar 21, 2010 3:13 pm

I have exactly the same problem, tried the same solutions, and have (almost) the same cntent in my debug file.

I don't understand how this issue hasn't been fixed since I found people complaining about it in posts old of 3 years.


Code: Select all

Defcon 1.43 steam built Jul  2 2007
Parsing archive main.dat...DONE
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 36ms
Parsing International data (2753 islands) : 15ms
Parsing City data (2745 cities) : 20ms
Parsing archive sounds.dat...DONE
Failed to load AuthKey : 'authkey'
Authentication key set : 'authkey not found'
WinSock started
Connection established to MetaServer, listening on Port 5009
Steam Authentication Initiated
Steam Authentication : Starting Steam
Steam Authentication : Starting Steam API
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = XXXXXXXXXXXXXXXX
Steam Authentication : Getting Encryption Details
Received Authentication : authkey not found : (keyID -1) : Key invalid
Key failed basic check : authkey not found (result=Key invalid)
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
Requesting data from MetaServer : sb
Received data from MetaServer : sb
Steam Authentication : Getting Steam2 Auth
Steam Authentication : Getting Steam3 Auth
Steam Authentication : Requesting Authentication
Steam Authentication FAILED
pdoff
level0
Posts: 2
Joined: Sun Mar 21, 2010 3:00 pm

Postby pdoff » Sun Mar 21, 2010 3:31 pm

Sabrak wrote:I have exactly the same problem, tried the same solutions, and have (almost) the same cntent in my debug file.

I don't understand how this issue hasn't been fixed since I found people complaining about it in posts old of 3 years.


Well, they've had our money haven't they?

Also, if it is a firewall/router issue, then they are demanding we cripple our own computers securtiy just to reassure them nobody has pirated their precious game.
Mikea
level0
Posts: 2
Joined: Sun Mar 21, 2010 2:33 am

Postby Mikea » Mon Mar 22, 2010 12:03 am

I'm not sure what changed since yesterday, but I just fired up the game and it worked fine. And this is with my firewall restored, computer plugged into our router, and running everything under standard privileges.

My guess is that the authentication server just goes down every once and a while. Not to say that firewalls and routers are not the cause of other people's authentication issues. Just that it might be worth waiting a day or two to see if the problem fixes itself on the other end. Sucks to tell people who might be having this issue in the future that they just can't play their game right now, but that's modern DRM for you.
Sabrak
level0
Posts: 2
Joined: Sun Mar 21, 2010 3:10 pm

Postby Sabrak » Mon Mar 22, 2010 12:23 am

It seems like you are right, I've been able to authenticate my game right after I read your message.
User avatar
tllotpfkamvpe
level5
level5
Posts: 1768
Joined: Fri Aug 31, 2007 12:04 am
Contact:

Postby tllotpfkamvpe » Tue Mar 30, 2010 7:27 am

Authentication error always comes up on my steam version, however the game works just like the full version. If you can join online games, there is no authentication error.
Maniacal
level0
Posts: 2
Joined: Wed May 12, 2010 7:51 pm

Postby Maniacal » Wed May 12, 2010 7:57 pm

I have the same error and tried everything to no avail :(

So I e-mail Introversion and got this reply:
We are sorry that you have encountered trouble with key authentication.
We are about to release a patch that corrects this problem and introduces some features.


Hopefully the patch will fix it :)
Kahai
level0
Posts: 2
Joined: Fri May 14, 2010 7:26 am

Postby Kahai » Fri May 14, 2010 7:32 am

I am sorry for adding to an already extensive list... But I am having the same problem with authentication keys, I bought this game a day ago on the 13th May through steam and I have tried all of the solutions posted here to no avail.

I understand that the authentication servers go down from time to time and that trying again later is successful. I don't suppose Introversion has a 'server status' page I can check to make sure it isn't a problem on my end.

As a final note, I can browse the in game online server list, I am just stuck in demo mode.
ThornXBL
level0
Posts: 9
Joined: Sat May 15, 2010 12:25 am

Postby ThornXBL » Sat May 15, 2010 12:28 am

Kahai wrote:I am sorry for adding to an already extensive list... But I am having the same problem with authentication keys, I bought this game a day ago on the 13th May through steam and I have tried all of the solutions posted here to no avail.

I understand that the authentication servers go down from time to time and that trying again later is successful. I don't suppose Introversion has a 'server status' page I can check to make sure it isn't a problem on my end.

As a final note, I can browse the in game online server list, I am just stuck in demo mode.


Myself and a friend of mine also purchased the game yesterday and have the same issue as you.

None of Steam Support's "fixes" work, and nothing I've seen on here works. When my game tries to verify that my copy is a legit Steam copy, it fails and gives a demo key every time.

Reinstalls, verifying game cache, changing registry permissions, deleting AuthKey file, none of it works. It's either a Steam or Introversion authentication server issue. If it doesn't get resolved soon, I'm going to want my money back.

EDIT: FYI: it fails after the "Getting Encryption Details" dialog box
Lord Yuan
level0
Posts: 1
Joined: Sat May 15, 2010 12:33 am

Postby Lord Yuan » Sat May 15, 2010 12:40 am

I got DEFCON from steam months ago and after re-installing I am having the same problem. I see the same blurbs and such that everybody else sees too. Apparently the newest patch didn't work either, I really like the game, and it would be a shame not to be able to play it again.
ThornXBL
level0
Posts: 9
Joined: Sat May 15, 2010 12:25 am

Postby ThornXBL » Sat May 15, 2010 12:41 am

This is what I get in the Debug log after a fresh uninstall/reinstall/run:

Code: Select all

Defcon 1.43 steam built Jul  2 2007
Parsing archive main.dat...DONE
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 51ms
Parsing International data (2753 islands) : 23ms
Parsing City data (2745 cities) : 42ms
Parsing archive sounds.dat...DONE
Failed to load AuthKey : 'authkey'
Authentication key set : 'authkey not found'
WinSock started
Connection established to MetaServer, listening on Port 5009
Steam Authentication Initiated
Steam Authentication : Starting Steam
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Starting Steam API
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = <removed>
Steam Authentication : Getting Encryption Details
Received Authentication : authkey not found : (keyID -1) : Key invalid
Key failed basic check : authkey not found (result=Key invalid)
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
Requesting data from MetaServer : sb
Received data from MetaServer : sb
Steam Authentication : Getting Steam2 Auth
Steam Authentication : Getting Steam3 Auth
Steam Authentication : Requesting Authentication
Steam Authentication FAILED
CLIENT : Disconnected
Disconnected from MetaServer


This is what I get in the debug on successive attempts:

Code: Select all

Defcon 1.43 steam built Jul  2 2007
Parsing archive main.dat...DONE
WinSock started
Client listening on port 5011
Parsing Coastline data (1776 islands) : 67ms
Parsing International data (2753 islands) : 22ms
Parsing City data (2745 cities) : 49ms
Parsing archive sounds.dat...DONE
Failed to load AuthKey : 'authkey'
Authentication key set : 'authkey not found'
WinSock started
Connection established to MetaServer, listening on Port 5009
Steam Authentication Initiated
Steam Authentication : Starting Steam
Steam Authentication : Starting Steam API
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : LatestVersion
Received data from MetaServer : MOTD
Steam Authentication : Logging On To Steam
Steam Authentication : Getting Steam Id
Steam Authentication : SteamID = <removed>
Steam Authentication : Getting Encryption Details
Received Authentication : authkey not found : (keyID -1) : Key invalid
Key failed basic check : authkey not found (result=Key invalid)
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
Requesting data from MetaServer : sb
Received data from MetaServer : sb
Steam Authentication FAILED
CLIENT : Disconnected
Disconnected from MetaServer
Last edited by ThornXBL on Sun Feb 27, 2011 5:20 am, edited 2 times in total.
Durand-Panda
level0
Posts: 2
Joined: Sat May 15, 2010 2:45 am

Postby Durand-Panda » Sat May 15, 2010 2:52 am

I'd like to say that I am literally in the EXACT position as the poster above - except that there were three of us that bought it at the same time and it's refused to work for all of us, telling us that authentication failed. Have tried everything - manual deletion, deletion through Steam and reinstall, verify game cache, delete authkey file, but nothing seems to work.

The issue seems to be that our games only generate an authkey (to put in the /Steam/steamapps/common/decon folder) AFTER we've been told authentication has failed and we've only got Demo access (after which the authkey we're given begins with DEMO).

This is on Windows Vista, and I am running Steam with Admin privileges etc.

So yeah, that's basically the issue all of us are having. It won't create an authkey file for us until after it's told us that it can't validate and we'll have to play the demo.
ThornXBL
level0
Posts: 9
Joined: Sat May 15, 2010 12:25 am

Postby ThornXBL » Sat May 15, 2010 2:54 am

The last Steam Support response just told me to talk to Introversion. They can't help me.
Durand-Panda
level0
Posts: 2
Joined: Sat May 15, 2010 2:45 am

Postby Durand-Panda » Sat May 15, 2010 3:00 am

Same. All they said to do was run Steam as an administrator and verify the Game Cache, then washed their hands of it and said talk to Introversion.

Return to “Windows Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest