Uplink 1.54 Patch/Demo (Windows/Linux)

Discussion about the latest patch

Moderators: bert_the_turtle, jelco, Rkiver, frenchfrog, JamesL

User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Uplink 1.54 Patch/Demo (Windows/Linux)

Postby frenchfrog » Fri Nov 17, 2006 8:43 pm

As usual, download the windows patch, linux patch (note that it requires all the .dat files to be in lib/) or linux patch with installer.
View the full changelog here.
The windows demo, linux demo.


On linux, note that you will perhaps needs to copy all the .dat files from your old Uplink installation into the /lib sub directory of the new Uplink installation.

Also, on linux, if you hit a crash please report the relevant part of the ~/.uplink/debug.log file, please also report the distro you are using. All testing was done on Ubuntu 6.06 .

Please note that on the linux version, fonts should now work fine. (since 1.52)




VERSION 1.54

- Fixed : Negative amount of money being deposited in bank accounts.
- Fixed : A problem with selecting the Defcon world map or not.
- Fixed : An exit crash involving Gateways.
- Fixed : Remaining crashes due to IRC.

- Added : 'Retire agent' option to the login screen.
Last edited by frenchfrog on Mon Mar 19, 2007 5:09 pm, edited 4 times in total.
jatqceer
level0
Posts: 7
Joined: Sat Sep 30, 2006 7:36 pm

Postby jatqceer » Mon Nov 20, 2006 8:11 am

Thanks. Works well under FreeBSD.
Surfpup
level2
level2
Posts: 133
Joined: Sat Feb 22, 2003 4:11 am
Location: america
Contact:

Postby Surfpup » Thu Nov 23, 2006 5:52 am

I found a minor bug where the free space on a server was split into two separate parts...
i.e.
Free Space - 7 Gigaquads
filehere -
filehere -
Free Space - 4 Gigaquads

This happened after I deleted one of the files on the server and it turned into a "free space" slot.

Shouldn't the free space all add up at the bottom?
An idea is bulletproof.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Fri Nov 24, 2006 6:20 am

No, because it's only a condensed display of a memory bank (it's the same thing as your gateway memory).

The inner working of a file server haven't changed with this _new_ display.

Bonus: it should now be easier to understand why Revelation sometime doesn't fit on a server.
Surfpup
level2
level2
Posts: 133
Joined: Sat Feb 22, 2003 4:11 am
Location: america
Contact:

Postby Surfpup » Fri Nov 24, 2006 10:26 pm

Ok, that makes sense now. I'm lovin' the new patches, keep it up!
An idea is bulletproof.
Trac3R
level1
level1
Posts: 15
Joined: Fri Dec 02, 2005 10:46 pm
Location: Earth, unfortunately
Contact:

How do I use patches and am I allowed to do it?

Postby Trac3R » Sun Nov 26, 2006 11:41 pm

Hello guys,

I've just two questions:

1. Can I use your patches with the localized german version from S-A-D/purple hills? Because your patches and the ones here seem to be different. (V.1.32 was for Linux only and fixed umlaut-issues. No new patches since that one.) And the german version is... let's say pretty bad - so bad that SAD closed the forums because the mass of complain. Patches would be very recommend.

By the way, I tried to find out if there were other localizations. During this search I found links to porn sites on your website. I know, hackers - warez - porn... But I guess it's not meant that way, isn't it?

2.Do I have to follow a special order of patches? I mean first 1.4, then 1.5 to the latest one? Your changelog or anything I read here doesn't really answer to this question.

Sorry for bothering you with this. I know you're not in charge of our localization. Well, I hope I had not bought the translated version, or there were no translated one present. Most people here speak (an off course read) English better than me.

---
If you like to reply to this, please note that I use Linux.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Re: How do I use patches and am I allowed to do it?

Postby frenchfrog » Mon Nov 27, 2006 1:35 am

Trac3R wrote:1. Can I use your patches with the localized german version from S-A-D/purple hills? Because your patches and the ones here seem to be different. (V.1.32 was for Linux only and fixed umlaut-issues. No new patches since that one.) And the german version is... let's say pretty bad - so bad that SAD closed the forums because the mass of complain. Patches would be very recommend.


I don't think it will work but you lose nothing to try.

Trac3R wrote:By the way, I tried to find out if there were other localizations. During this search I found links to porn sites on your website. I know, hackers - warez - porn... But I guess it's not meant that way, isn't it?


I guess some domains have expired and were bought by ...

Trac3R wrote:2.Do I have to follow a special order of patches? I mean first 1.4, then 1.5 to the latest one? Your changelog or anything I read here doesn't really answer to this question.


I really don't get why people ask this question, last time I saw obligatory incremental patching was at least 3 years ago ...
Trac3R
level1
level1
Posts: 15
Joined: Fri Dec 02, 2005 10:46 pm
Location: Earth, unfortunately
Contact:

Postby Trac3R » Tue Nov 28, 2006 12:39 am

frenchfrog wrote:(patch the german localization)
I don't think it will work but you lose nothing to try.



Yes, you're so damned right about that. But I also lose nothing to ask. :wink:
I give it a try.


I really don't get why people ask this question, last time I saw obligatory incremental patching was at least 3 years ago ...



Well, might be that "people" still be used to do some patches incremental. Manually made kernel patches for example, or if they use older games because game-developers don't care so much about their OS. I which there were more like you folks. Take Bioware's Neverwinter Nights (1) and Massive's Ground Control. I still play this stuff, and not only because of the "plenty" opportunities. They all got incremental patches, well they did to the latest patch level. Sorry for this stupid question... Nice to see the answer written light-blue on blue now.

Thanks a lot.
HaloNothing
level2
level2
Posts: 80
Joined: Thu Nov 30, 2006 3:55 am
Contact:

Postby HaloNothing » Tue Dec 05, 2006 10:59 pm

All in all great update to the game!

Stockmarket increments still a little tedious, makes bulk buying a long, clicky process...

Liked the idea of log_nuke from Simply_Uplink, I'm kind of sorry it never got included into the patches (but then, when do you really need to wipe an entire log anyway!)

I do love the more compact addition of saved audio files!

All around some suble, but great changes have taken place from 1.31

Great job! I hope to join with developers soon
Magix_995
level0
Posts: 1
Joined: Thu Jul 14, 2005 12:25 pm

Postby Magix_995 » Sun Dec 17, 2006 4:35 pm

Hi
In next beta, please add a fonction at mouse wheel to move up and down quest and materials
Excuse my english
karlsn
level0
Posts: 4
Joined: Sun Dec 17, 2006 6:07 pm
Contact:

Postby karlsn » Mon Dec 18, 2006 12:34 pm

I've never patched the game before. Can just jump to this patch and install it? or do I need to patch with the others first? (I want the game fully updatet)
karlsn was here...
User avatar
Montyphy
level5
level5
Posts: 6745
Joined: Tue Apr 19, 2005 2:28 pm
Location: London, England

Postby Montyphy » Mon Dec 18, 2006 2:20 pm

karlsn wrote:I've never patched the game before. Can just jump to this patch and install it? or do I need to patch with the others first? (I want the game fully updatet)


You only need to apply the lastest patch.
Uplink help: Check out the Guide or FAQ.
Latest Uplink patch is v1.55.
User avatar
KingAl
level5
level5
Posts: 4138
Joined: Sun Sep 10, 2006 7:42 am

Postby KingAl » Mon Dec 18, 2006 2:23 pm

Heh. If the version numbers keep rising at this rate, we'll eventually get an Uplink 2 no matter what Chris says.
deus1234
level0
Posts: 1
Joined: Wed Dec 20, 2006 6:15 am

Postby deus1234 » Wed Dec 20, 2006 6:19 am

Applied the patch and now it won't start
I'm using Ubuntu 6.10

uplink
=============================
= =
= U P L I N K =
= =
= Version 1.54 =
= - R E L E A S E - =
= =
=============================

Version 1.54 (RELEASE)
Compiled on Nov 16 2006 at 20:46:23
(code-C)(code-M)(code-T)
Aborted (core dumped)

This is the only error message i can find, please help me
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Re: Uplink 1.54 Patch/Demo (Windows/Linux)

Postby frenchfrog » Wed Dec 20, 2006 3:57 pm

frenchfrog wrote:On Linux, if you hit a crash please report the relevant part of the ~/.uplink/debug.log file
Last edited by frenchfrog on Wed Feb 21, 2007 3:44 pm, edited 1 time in total.
The Ultimate Uplink Guide (for any question on Uplink)
Latest Uplink Patch

Return to “Latest Patch”

Who is online

Users browsing this forum: No registered users and 1 guest