Uplink 1.53 Patch (Windows/Linux), Demo Windows

Discussion about the latest patch

Moderators: bert_the_turtle, jelco, Rkiver, frenchfrog, JamesL

User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Uplink 1.53 Patch (Windows/Linux), Demo Windows

Postby frenchfrog » Wed Oct 25, 2006 8:24 pm

As usual, download the windows patch, linux patch (note that it requires all the .dat files to be in lib/) or linux patch with installer.
View the full changelog here.
The windows demo.


On Linux, if you hit a crash please report the relevant part of the ~/uplink/debug.log file, please also report the distro you are using. All testing was done on Ubuntu 6.06 .

Please note that on the linux version, fonts should now work fine. (since 1.52)




VERSION 1.53

- Fixed : Problems with buying gateway securities.
- Fixed : Linux Installer to include the new font libraries.
Pendrokar
level0
Posts: 3
Joined: Wed Oct 25, 2006 8:50 pm
Location: Latvia, Riga

Postby Pendrokar » Wed Oct 25, 2006 9:36 pm

But yesterday or was it the day before yesterday. :roll:
I downloaded v1.52 :)

I came across some bugs (while preparing for Uplink Speedrun):

1.Password Hacker still worked when I made it hack the InterNIC password, and then(while password hacker worked) I wrote the password in the box (The code was writen earlier).
Pic- http://img105.imageshack.us/img105/8912/passwordstillrunningbugzh9.png

2.While looking at an bank accounts statements I saw a bug of negative money being deposited.
Pic- http://img431.imageshack.us/img431/8768/50depositbugug5.png
offsides
level1
level1
Posts: 11
Joined: Sun Oct 15, 2006 6:36 pm

Postby offsides » Thu Oct 26, 2006 12:42 am

Looks good - thanks!
idle
level0
Posts: 6
Joined: Fri Sep 15, 2006 7:49 pm

Postby idle » Thu Oct 26, 2006 6:27 pm

is the linux tar file broken?

*edit
ok my post can be deleted :D
now it works i've tryed it with wget and now i works...
(atm i use firefox 2.0rc2
Last edited by idle on Thu Oct 26, 2006 7:10 pm, edited 1 time in total.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Thu Oct 26, 2006 6:52 pm

hmmm, seems to work fine here if downloaded to a location and then opened. (broken software on your side?)

EDIT: What OS/Distribution and browser/version are you using?
idle
level0
Posts: 6
Joined: Fri Sep 15, 2006 7:49 pm

Postby idle » Thu Oct 26, 2006 9:50 pm

i found a bug:
On missions like: Highly skilled Agend required for removal job.
if i complete a mission (i read the news and see that the target is in arest...) and send a reply back i become directly 2 messages... one: that they can't believe.... (missiom failed) and the message that the mission is successfully....

i hope you can understand what i mean :D
my english isn't the best ;P

*edit
i think that is not with all of these missions...

*edit again :D
when i disconnect from irc then the game quits with a segfault.

i've tryed to connect to the uplink irc... no channel was automatical joined?... /join #chan dosn't work...
i want disconnect and then comes the segfault.
Last edited by idle on Sat Oct 28, 2006 2:40 pm, edited 1 time in total.
Gentoo
Amd 64 3700+
jokeyrhyme
level1
level1
Posts: 30
Joined: Fri Sep 22, 2006 7:23 am
Location: NSW, Australia
Contact:

Postby jokeyrhyme » Fri Oct 27, 2006 2:43 pm

Okay, I just got booted for having an illegal copy of the game again. This is starting to get ridiculous.

I've been playing non-stop for a few hours. Starting from a fresh install using the 1.31.sh from the CD I received in the mail, upgrading with 1.52.sh and then 1.53.sh.

Below are some files you might like to check out:
JokeyRhyme.usr
LittleFox.usr
debug.log

JokeyRhyme is the profile that just got locked out for piracy. Hours of play lost for no good reason.
LittleFox is a profile I created when I first re-installed, primarily so I could set the "defaultworldmap" option before creating my main profile. It's been locked out because I didn't cover any trails with it.

I'm hoping there's enough info here to stop this from happening after the next patch, or for someone to tell me what aspect of my system is triggering the fault.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Fri Oct 27, 2006 10:42 pm

Caught agent files are pretty much useless since they only contain the _score_ .

As for the warez thing, Uplink do some file check, and if some files fails the test, you get booted for warez version.

This test append on random interval (it also depends on what you do in the game), this interval in probably between 5-10 mins if you do some missions, fastforward to get the results, etc ...

The possibilities are as follow:
1) the check is wrong in the Linux version since after 1.31 . (but the code haven't really changed since 1.31), related to building with gcc 4?
2) your hardware/kernel sometimes returns invalid bits of data.

The best way to test this would probably be to play vanilla 1.31 and see if it also fails in 1.31.

Worse case, I could do a custom build just for you to give a more explicit message on the warez thing.
jokeyrhyme
level1
level1
Posts: 30
Joined: Fri Sep 22, 2006 7:23 am
Location: NSW, Australia
Contact:

Postby jokeyrhyme » Fri Oct 27, 2006 11:18 pm

Is there anything I can make available to you that would help you diagnose what this problem is? As no-one else seems to be having this problem, it would appear that my system is doing something stupid, which means I already feel like I've unfairly monopolized your time.

This doesn't seem like something that would be recorded in the user files anyway, so while I could supply you with user profiles before they are booted, I'm not sure why I originally thought they would be any use.

It's clearly my system's fault: these files are straight from your archives, so there's no way they could fail your tests otherwise.

All three times this has happened to me, I was fast forwarding time so that a client could hear about a system I destroyed. I've been doing multiple jobs, fast forwarding about 10 minutes and then clearing logs.

I'm running this on Gentoo Linux 2006.1 with a 2.6.18 kernel and glibc 2.4, on a Sony VAIO VGN-S48GP laptop: single-core Pentium-M Centrino with 1GB RAM and nVidia 6200TC. Perhaps the newly added real-time features in this kernel are broken on my system?

I need to take a few days break from Uplink (I just can't deal with losing hours of play again right now), but when I return I'll play with good old 1.31 and see.
Redemption042
level1
level1
Posts: 30
Joined: Sat Apr 09, 2005 11:10 pm
Location: Goleta, CA USA

Postby Redemption042 » Sat Oct 28, 2006 6:56 am

I'm probably being really stupid here, but I just upgraded from Xubuntu 6.06 to Xubuntu 6.10 and now uplink won't start. It gives this error message

./lib/uplink.bin.x86: ./lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)

and here is my gcc

gcc --version
gcc (GCC) 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

*******
EDIT
*******

I'm sorry, I was an idiot. I found the solution in the linux FAQ. sorry.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Sat Oct 28, 2006 3:09 pm

jokeyrhyme wrote:Is there anything I can make available to you that would help you diagnose what this problem is? As no-one else seems to be having this problem, it would appear that my system is doing something stupid, which means I already feel like I've unfairly monopolized your time.

No problem, really, I'm here to solve problems :)

jokeyrhyme wrote:This doesn't seem like something that would be recorded in the user files anyway, so while I could supply you with user profiles before they are booted, I'm not sure why I originally thought they would be any use.


You couldn't have known, since the warez thing is pretty much a secret ;)

jokeyrhyme wrote:It's clearly my system's fault: these files are straight from your archives, so there's no way they could fail your tests otherwise.


Did you try redownloading the full linux version from the website? (normally it shouldn't change anything since the installer as a integrity test)

jokeyrhyme wrote:I'm running this on Gentoo Linux 2006.1 with a 2.6.18 kernel and glibc 2.4, on a Sony VAIO VGN-S48GP laptop: single-core Pentium-M Centrino with 1GB RAM and nVidia 6200TC. Perhaps the newly added real-time features in this kernel are broken on my system?


Perhaps, or you got bad memory, or failling hardisk, but something is fishy, something else would have crashed in those cases, perhaps something is really wrong with Uplink.

Could you send me a PM (private message) with your email, I'll send you a custom build in the coming days.
User avatar
chimera
level2
level2
Posts: 114
Joined: Fri Aug 13, 2004 7:20 pm
Location: Belgium, West-Vlaanderen

Postby chimera » Mon Oct 30, 2006 12:10 pm

I can't download the latest patches, I get this error both in firefox and internet explorer (7)

Forbidden
You don't have permission to access /test/UplinkPatch-1.53.exe on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.0.55 (Ubuntu) Server at www.uplink.co.uk Port 80

Anything wrong with the servers? or is it my PC
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Mon Oct 30, 2006 7:48 pm

Yeah, the forum server was changed, this should be fixed now.

(this also explains why most poeple were force to re log on the forum)
User avatar
chimera
level2
level2
Posts: 114
Joined: Fri Aug 13, 2004 7:20 pm
Location: Belgium, West-Vlaanderen

Postby chimera » Tue Oct 31, 2006 9:47 am

I can just install this over my 1.42 right?
jokeyrhyme
level1
level1
Posts: 30
Joined: Fri Sep 22, 2006 7:23 am
Location: NSW, Australia
Contact:

Postby jokeyrhyme » Tue Oct 31, 2006 12:47 pm

That's right. All of these patches fully include all the changes from the previous ones. There aren't any incremental patches around here.

Return to “Latest Patch”

Who is online

Users browsing this forum: No registered users and 3 guests