Uplink 1.49 Patch (Windows/Linux)

Discussion about the latest patch

Moderators: bert_the_turtle, jelco, Rkiver, frenchfrog, JamesL

User avatar
Xan
level1
level1
Posts: 27
Joined: Sun Oct 01, 2006 7:54 am
Location: Former soviet union

Postby Xan » Mon Oct 02, 2006 11:33 am

chrisgbk wrote:
mkylman wrote:
Xan wrote:Say french are u thinking about making a some kind of a porting program so the user wont lose thier saves?

Ditto.


Why would a porting program be needed? When you upgrade to 1.49, your save files are either compatible with or are converted to the new format automatically, or at least mine were, and they work perfectly. The only possible reason would be if you planned to downgrade, but in that case all you need to do is create a backup of your files before updating.


10x ) now i get it )
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Mon Oct 02, 2006 7:59 pm

Linux version 1.49 TRYB that should fix the libtiff problem and also hopefully fix the "Unable to open a console terminal" initialization problem is out, see first post.
User avatar
sysrq
level2
level2
Posts: 123
Joined: Wed Mar 20, 2002 4:52 am

Postby sysrq » Mon Oct 02, 2006 8:18 pm

frenchfrog wrote:Linux version 1.49 TRYB that should fix the libtiff problem and also hopefully fix the "Unable to open a console terminal" initialization problem is out, see first post.

Nope, still Message : Could not initialize SDL: Unable to open a console terminal, strace confirms the uplink is still trying to open /dev/tty and /dev/tty0
DEATH TO DUCKS!!!
User avatar
Kinping
level1
level1
Posts: 65
Joined: Fri Sep 15, 2006 6:54 pm
Location: Aachen, Germany
Contact:

Postby Kinping » Mon Oct 02, 2006 8:41 pm

frenchfrog wrote:Linux version 1.49 TRYB that should fix the libtiff problem and also hopefully fix the "Unable to open a console terminal" initialization problem is out, see first post.


Well - I do still have it also:

Code: Select all

Uplink has been forced to Abort
===============================
 Message   : Could not initialize SDL: Unable to open a console terminal.
 Location  : app/opengl.cpp, line 93
Image
le_jawa
level1
level1
Posts: 13
Joined: Fri Aug 27, 2004 3:21 am
Contact:

New crash error?

Postby le_jawa » Mon Oct 02, 2006 8:58 pm

Here's what I'm seeing in my debug log; I haven't seen it posted previously:

Code: Select all

===============================================
NEW GAME     14:11, 2/10/2006
===============================================
Version : 1.49TRYA
RELEASE
Linux Build
Version 1.49TRYA (RELEASE)
Compiled on Sep 30 2006 at 18:22:13
(code-C)(code-M)(code-T)
Loading uplink options from /home/jason/.uplink/options...success

Successfully loaded data archive data.dat
Successfully loaded data archive graphics.dat
Successfully loaded data archive loading.dat
Successfully loaded data archive sounds.dat
Successfully loaded data archive music.dat
Successfully loaded data archive fonts.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat

Uplink has been forced to Abort
===============================
 Message   : Could not initialize SDL: No I/O port permissions.
 Location  : app/opengl.cpp, line 93
============== B E G I N  C O R E  D U M P =================
retAddress = 0x804da4f
retAddress = 0x80523eb
retAddress = 0x810f231
retAddress = 0x810f2ec
retAddress = 0xb7b9dea2
retAddress = 0x804d661
============== E N D  C O R E  D U M P =====================


Oops, I forgot the distro. Ubuntu 6.06 IA32
Last edited by le_jawa on Wed Oct 04, 2006 5:51 am, edited 1 time in total.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Mon Oct 02, 2006 9:10 pm

Please post your distro when you post a crash report, some distros have _particularities_

Again google is a friend I guess ...
zeb
level1
level1
Posts: 10
Joined: Sat Sep 30, 2006 8:18 am

Postby zeb » Mon Oct 02, 2006 9:33 pm

Hi,
I am using Mandriva Cooker/2007, same problem with TRYB:

Code: Select all

Uplink has been forced to Abort
===============================
 Message   : Could not initialize SDL: Unable to open a console terminal.
 Location  : app/opengl.cpp, line 93
============== B E G I N  C O R E  D U M P =================
retAddress = 0x804da4f
retAddress = 0x80523eb
retAddress = 0x810f231
retAddress = 0x810f2ec
retAddress = 0xb7b1075c
retAddress = 0x804d661
============== E N D  C O R E  D U M P =====================


Thanks.
jokeyrhyme
level1
level1
Posts: 30
Joined: Fri Sep 22, 2006 7:23 am
Location: NSW, Australia
Contact:

Postby jokeyrhyme » Mon Oct 02, 2006 10:59 pm

le_jawa: I noticed that you're Uplink is looking for a 32-bit screen, and can only find a 16-bit one. I'm not sure if this is the problem, but does your xorg.conf (or the XFree86 equivalent) have a "depth 32" entry?

If not, then you could either add one, or maybe you could change the depth that Uplink is looking for in the "options" file.

EDIT: This should be to Kinping. And it looks like that might not be a problem anymore. I need to pay attention to which page I'm on. :)
User avatar
Kinping
level1
level1
Posts: 65
Joined: Fri Sep 15, 2006 6:54 pm
Location: Aachen, Germany
Contact:

Postby Kinping » Tue Oct 03, 2006 12:14 am

jokeyrhyme wrote:le_jawa: I noticed that you're Uplink is looking for a 32-bit screen, and can only find a 16-bit one. I'm not sure if this is the problem, but does your xorg.conf (or the XFree86 equivalent) have a "depth 32" entry?

If not, then you could either add one, or maybe you could change the depth that Uplink is looking for in the "options" file.


Actually I tried around a little, but still got the same error. It is not the 32bit/24bit depth entry, because Darwinia runs perfectly at depth 32. Therefore the error must be a different one.

Also if I set options manually by command parameter it still does not work.
Image
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Tue Oct 03, 2006 12:50 am

Linux version 1.49 TRYC, I think I got everything right, except the screwy font ... see first post.
User avatar
sysrq
level2
level2
Posts: 123
Joined: Wed Mar 20, 2002 4:52 am

Postby sysrq » Tue Oct 03, 2006 3:58 am

frenchfrog wrote:Linux version 1.49 TRYC, I think I got everything right, except the screwy font ... see first post.

Well nice to see you fixed uplink wanting a full VT to run :). You might want to make a note on the patch that it requires all the .dat files to be in lib/ *maybe this was required with 1.3x and I just wasn't paying attention, I did a clean install to test this). It would also be nice if uplink would output a error message that says something along those lines if it can't find them. Currently it just says "====== END OF DEBUGGING INFORMATION ====
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/music/bluevalley.uni" etc so someone who doesn't know what's going on wouldn't think they didn't have that file period not knowing the .dat files are just containers with the content within them. Just one more thing, it would be nice if you made the default uplink script end with

Code: Select all

$here/lib/uplink.bin.x86 "$@"
so that any arguments you pass to it will be passed on to the binary
DEATH TO DUCKS!!!
zeb
level1
level1
Posts: 10
Joined: Sat Sep 30, 2006 8:18 am

Postby zeb » Tue Oct 03, 2006 7:05 am

Are there prmissions problems?

When starting uplink as user:

Code: Select all

===============================================
NEW GAME     7:0, 3/10/2006
===============================================
Version : 1.49TRYC
RELEASE
Linux Build
Version 1.49TRYC (RELEASE)
Compiled on Oct  3 2006 at 01:02:26
(code-C)(code-M)(code-T)
Loading uplink options from /home/eric/.uplink/options...success

Successfully loaded data archive sounds.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/fonts/dungeon.ttf
Unable to open font : fonts/dungeon.ttf
True type font support is DISABLED
Compiled with SDL_mixer version: 1.2.7
Running with SDL_mixer version: 1.2.7
New patch Detected!
Old version = 131
New version = 149

REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/music/bluevalley.uni
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/uplinklogo.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/newgame.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/newgame_h.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/newgame_c.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/options.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/options_h.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/options_c.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/exitgame.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/exitgame_h.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/mainmenu/exitgame_c.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/userid.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/proceed.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/proceed_h.tif
GUCCI Error - failed to load TIF (null)
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/graphics/proceed_c.tif
GUCCI Error - failed to load TIF (null)


When starting as root:

Code: Select all

===============================================
NEW GAME     6:59, 3/10/2006
===============================================
Version : 1.49TRYC
RELEASE
Linux Build
Version 1.49TRYC (RELEASE)
Compiled on Oct  3 2006 at 01:02:26
(code-C)(code-M)(code-T)
Loading uplink options from /root/.uplink/options...failed

=====DEBUGGING INFORMATION ENABLED=====
Loading application data
Successfully loaded data archive sounds.dat
Successfully loaded data archive patch.dat
Successfully loaded data archive patch2.dat
Finished loading application data
Init_Game called...creating game object
Finished with Init_Game
Initialising SDL...done
 SDL is now opening a 2560x1024 window in 32 depth ...done
 SDL is now changing the window caption and diverse settings ...done
 Initialising OpenGL...
Finished initialising OpenGL.
Now registering callback functions...done
 Init_Fonts called...setting up system fonts
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/fonts/dungeon.ttf
Unable to open font : fonts/dungeon.ttf
True type font support is DISABLED
Finished with Init_Fonts
 Init_Sound called...setting up sound system
Compiled with SDL_mixer version: 1.2.7
Running with SDL_mixer version: 1.2.7
Finished with Init_Sound
Init_Music called...loading modules
Finished with Init_Music
Creating main menu.
====== END OF DEBUGGING INFORMATION ====
REDSHIRT : Failed to load file : /usr/local/games/uplink/lib/music/bluevalley.uni
[quote]

Regards  :) [/quote]
zeb
level1
level1
Posts: 10
Joined: Sat Sep 30, 2006 8:18 am

Postby zeb » Tue Oct 03, 2006 7:13 am

By the way, is it necessary to install patch 1.31 before this one ?
Thanks.
User avatar
frenchfrog
level5
level5
Posts: 2572
Joined: Sun Sep 22, 2002 7:11 pm
Location: Quebec

Postby frenchfrog » Tue Oct 03, 2006 2:11 pm

zeb wrote:By the way, is it necessary to install patch 1.31 before this one ?


No, it shouldn't be needed.

As for your problem, your answer is in the post right above yours.
zeb
level1
level1
Posts: 10
Joined: Sat Sep 30, 2006 8:18 am

Postby zeb » Tue Oct 03, 2006 6:23 pm

frenchfrog wrote:As for your problem, your answer is in the post right above yours.


That's right, it works now! (except the fonts).

Return to “Latest Patch”

Who is online

Users browsing this forum: No registered users and 1 guest