Linux FAQ

For problems with the game

Moderators: bert_the_turtle, jelco, Chris, Icepick, Rkiver, Punisher Bass

John
Introversion Staff
Introversion Staff
Posts: 470
Joined: Sun Dec 10, 2000 6:22 pm
Location: London, UK

Linux FAQ

Postby John » Wed Feb 15, 2006 6:05 pm

  • Q. I'm getting ./uplink: symbol lookup error: ./uplink: undefined symbol: __glutRoot errors.
    A. If you're running the demo, try downloading the 1.31 version from here
    A. If you're trying to run the full game, try applying the patch, which you can download here (for the Loki Installer based patch) or here (for the tar.gz based patch).
  • Q. Uplink can't find /usr/lib/libstdc++.so.5
    A. At the moment the Linux distributions are in a period of transition between libstdc++ 6 and 5. They are incompatible with each other, so making a link between them won't work. The answer is to install the libstdc++ 5 as well (you can quite easily have both installed simultaneously).

    On Debian: apt-get install libstdc++5
    On Fedora: yum install compat-libstdc++-33.i386
    Other yum-based systems: yum install a package recommended by yum provides libstdc++.so.5
    On SourceMage: cast gcc33
  • Q. I'm getting: Could not initialize SDL Video: Couldn't find matching GLX visual.
    A. The default resolution Uplink tries to use is 640x480. If this is not available, the above problem might occur. Check to see in your X configuration file if you have the modes available. Also, try the following command-line parameters:

    To disable fullscreen mode: -graphics_fullscreen
    To enable fullscreen mode: +graphics_fullscreen
    To set the desired resolution: '!graphics_screenwidth' 1024 '!graphics_screenheight' 768
  • Q.I'm getting `GCC_4.2.0' not found message when I try to run Uplink.
    A. Try deleting or renaming the libgcc_s.so.1 file that is bundled with Uplink, which you will probably find in ~/uplink/lib or /usr/games/uplink/lib.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests