2 frames per second, whatever settings I use

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

markhadman
level0
Posts: 4
Joined: Thu Dec 01, 2011 2:15 am

2 frames per second, whatever settings I use

Postby markhadman » Thu Dec 01, 2011 2:27 am

Hi,

I just bought the game, version darwinia_1.43_amd64

I'm running it on Linux 3.1.3-1-ARCH with HD2400 PRO (RADEON driver) on an AMD Athlon(tm) 64 Processor 4000+

With all graphics set to 'low', pixel effects off and any of 0,1 or 2 in RenderLandscapeMode I still only get 2 frames per second on the map screen at the start of the game.

It's impossible to set graphics settings in-game - when I click 'apply' nothing happens, I have to set them by editing preferences.txt. I think the game is just ignoring the settings anyway.... ANd when I try to switch to windowed mode, the game crashes with 'segmentation fault'.
Vorpal
level0
Posts: 3
Joined: Wed Nov 30, 2011 6:52 pm

Postby Vorpal » Thu Dec 01, 2011 6:12 pm

I assume you mean that you are using the open source drivers? I have no issue when using catalyst on my Radeon HD 6850 card. So it might be worth trying catalyst for you as well. On Arch Linux catalyst can be found in AUR (catalyst and catalyst-utils).
markhadman
level0
Posts: 4
Joined: Thu Dec 01, 2011 2:15 am

Postby markhadman » Sun Dec 04, 2011 4:08 am

Catalyst driver works, thanks for the suggestion

(Wish I hadn't bothered though... Turns out I played this game about !!ten!! years ago, it wasn't any good back then, either...)

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest