mouse goes wild

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

mouse goes wild

Postby pimp-my-ppc » Thu Sep 11, 2008 10:50 pm

When I start the main game, my mouse will not sit still. It works fine for the main menu and stops when the options are brought up. What could be wrong?

http://www.youtube.com/watch?v=HU44RtWpHWc
User avatar
xander
level5
level5
Posts: 16859
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Thu Sep 11, 2008 11:50 pm

What version of Darwinia are you running? What OS? On what hardware? What kind of framerates are you getting? Does this occur in any other game or program? Are you running any mods? Have you played with the preference file or any of the data files?

More info, please.

xander
pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

Postby pimp-my-ppc » Fri Sep 12, 2008 12:41 am

I'm using the latest Darwinia on Ubuntu 8.04 64 bit. My specs are listed here: http://system76.com/product_info.php?cP ... ucts_id=51
I'm getting really good framerates, like more than 100 i think. This only occurs in darwinia. I've tried Defcon and Uplink and both are fine. I'm not running any mods. It did this with no changes to prefs and no matter what I tried to change in prefs. (i only changed landscape render mode and camera control mouse..both are back to original values though) I haven't messed with any data files.
User avatar
xander
level5
level5
Posts: 16859
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Fri Sep 12, 2008 6:15 am

pimp-my-ppc wrote:... on Ubuntu 8.04 64 bit....

I am not a Linux person by any stretch, but I wonder if the fact that it is running on a 64 bit proc might be a problem? I assume that there are some kind of compatibility libs or something... they are all up to date? And your video drivers are up to date?

I am sorry that I am not all that helpful -- hopefully bert or brice will be along shortly...

xander
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 7:32 am

There have been a lot of probs with recent ubuntu distros... search this forum, or just skim the past dozen thread titles or so.

It seems that many ubuntu probs are caused by library incompatabilities. Specifically, the system libs that are *included* with the darwinia executable are so old that they fail to link properly or something like that. The fix for several people has been to simply *delete* the .so files that are installed in the darwinia/lib directory.

I haven't had to do this (I still run a 5 year old 32b 2.6 kernel :) ) but supposedly your system should already have the updated libs in it's lib path. If not, then simply launch darwinia (the script, not the executable directly) from a command line and watch for the linker errors... they will tell you which packages to install to fill in the missing libs.

No guarantees on this, but it's come up several times, so worth a shot IMHO.

**But *dont* go deleting the system libs from /usr or /lib (the root level linux dirs) because that will likely cause you LOTS of headaches down the road. The issue is the *old* libs *included* / *installed* with darwinia.

EDIT: also search for dual core issues... if you have dual or multi core, you *have* to assign the game to run on just *ONE* core!!! because the game is not written to me multicore safe. there's a command line command for this that someone posted in one thread not too long ago... If you do have dual core, try this FIRST before deleting the libs above, becasue darwinia will *not* run properl;y on more than one core: known fact!
pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

Postby pimp-my-ppc » Fri Sep 12, 2008 2:21 pm

Making it go on one core helped some, it made it jerk less, but it didn't solve it. Changing the libraries didn't do a thing. Could it be the offset value it displays at startup being wrong? It also works better windowed than fullscreen(fullscreen has no change from before).
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 2:28 pm

"offset value"? if it seems relevant, post the text here, including the messages before and after, if you can. I can't recall what this might be...

But if windowing helps, maybe you have some new mouse driver that ubuntu is pushing into the mainstream? maybe try disabling any special mouse settings your distro gives you... like acceleration?

is the mouse cursor jiggling even when you don't touch the mouse? or is it "over-reacting"? Try to describe what's \actually happening in more detail...'cause we can't read minds or see your screen ;)

EDIT: you DO have "hardware cursor acceleration" turned on, don't you?????? 'cause X can also run the mouse cursor from software... but it is dog slow and... jerks a lot if the processor is under heavy loads... like when running darwinia :)

Check your X.org setup. You may have to do some ubuntu forum searches about this to find the X server's startup log file (it's in /var/logs on my box) and parse/find the appropriate lines there. Your driver *should* be preset to use the video card's *hardware* cursor thingy (they all have one)... but if it's doing the mouse cursor in software, that very well could cause a noticeable performance problem [-- kinda like disabling all video hardware acceleration and using the old old ancient framebuffer driver in the kernel ;) ...you can then watch windows get assembled from individual paint ops, piece by slow piece (kinda interesting if you're ever curious how the windowing system actually wroks under the hood)]

But without a better description of what's *actually* happening on screen, I can't help you any further, I don't think.
Last edited by briceman2 on Fri Sep 12, 2008 2:39 pm, edited 1 time in total.
pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

Postby pimp-my-ppc » Fri Sep 12, 2008 2:38 pm

adjusting mouse sensitivity and acceleration doesn't change anything. Yes, it does it without touching the mouse but it is made worse when you use the mouse.If i don't touch anything after clicking "garden", i am left looking at a certain part of the sky(same part every time) with the screen sometimes "jiggling". The offset value thing is "XINERAMA:offset guess:0,0" The mouse seems to every so many seconds think it is in a different location, but i'm surprised it's only in the main game and not the main screen.
I hope the problem with the mouse is fixable.
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 2:40 pm

...read my EDIT above... cross posted :)

EDIT: the XINERAMA thing has nothing to do with the mouse -- it's the multi-monitor handler for X.org and is guessing that you have only one monitor hooked up. Ignore it if darwinia renders at all (which you say it does).

EDIT2: just noticed your youtube... you compressed the time in that didn't you? ..so it's pretty useless for me to see what's really happening -- if you want to redo the youtube vid, make sure you're getting 20-30fps realtime or the timing of the mouse movements won't look right and...
pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

Postby pimp-my-ppc » Fri Sep 12, 2008 2:57 pm

i didn't see anything about hardware cursor in the .var.log for X11. I added this to my Xorg.conf file and no change is seen.

Option "HWCursor" "on"

After I added this, that line is displayed in the logs now, but that's it.

EDIT:on the youtube video, it seems my screen capture software compresses the time once i go fullscreen. I think it's because the fullscreen resolution is so much smaller than my normal screen. I will try it again if you want in window mode.
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 3:23 pm

pimp-my-ppc wrote:EDIT:on the youtube video, it seems my screen capture software compresses the time once i go fullscreen. I think it's because the fullscreen resolution is so much smaller than my normal screen. I will try it again if you want in window mode.


well it's not that I "want" it, but the vid up now is uesless for diagnosing your issue :) so up to you.

defcon & uplink probably don't max out the procesor load like darwinia, so it could still be a software cursor somewhere in the lib stack... somewhere :)

do you have this cursor issue in any other game that *does* max out the proc load 100% of the time?

EDIT: try this: run a proc load test like superpi or onre of the x86 burn-in progs... make it so your system is at 100% load constantly... then play around with non-darwinia progs and see if your mouse behaves smooth or jumpy... this will tell you if the issue is before or after the libs darwinia uses (libSDL mainly).

do you have a second mouse you can plug in to test?

is your mouse USB? is your usb subsystem chugging for any reason? esp. under full proc load?

I'm guessing th eprob is not darwinia, but something in your mouse software... somewhere :) but more info would help, of course...

maybe your SDL libs have some funky mouse settings on your ubuntu install?? darwinia was compiled agains 1.29 IIRC, but runs ok against 1.28 on my system. If a newer libSDL has different mouse handling, that could be wheree th issue is... dunno

bottom line seems that you need to follow your mouse from the connector all the way up to th eX.org desktop and SDL libs to see if there's anything weeird in the setups anywhere... you might try searching / asking ubuntu gurus about jerky mouse issues under full proc load -- in general, not wrt darwinia in particular...
pimp-my-ppc
level1
level1
Posts: 14
Joined: Tue Nov 15, 2005 3:35 am
Location: here and now

Postby pimp-my-ppc » Fri Sep 12, 2008 3:41 pm

I will have the new youtube video up shortly.
superpi does not hinder my other games, I even did other opengl games. I tried Uplink too and there is no change.

I use both the built in laptop mouse and an external usb mouse with no change.
I've never stumbled on this issue before in other games. Even ones that drain my computer more than Darwinia.
I will also continue to look around the Internets for SDL mouse problems, though my searches are null so far.
Without the SDL lib in the lib dir, the one on my system is sdl 1.2.12..and then i get no sound. So I like the sdl that comes with Darwinia.

EDIT:
http://www.youtube.com/watch?v=Ap6pXdXZzrg

EDIT2: could this be related?
http://listas.apesol.org/pipermail/sdl- ... 33019.html
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 5:59 pm



uhhmm... that's fsck'd!! I've seen that motion before in some mod problem before, but can't place it right now... I think TGF called it a long long time ago, but not sure... TGF??? PM her if you like (The GoldFish)



dunno. but to (sorta, maybe) rule out your SDL libs just search the web for SDL linux games and load one up.

I think it's a darwinia thing now -- probably/possibly the new SDL is not 100% back compat. ...so you might try reverting to an earlier SDL on your system? 1.28 or 1.29 definitely work ok.

EDIT: I mean 1.2.8 or whatever the console messages say darwinia is compiled against... ALSO: this may be a subtle 32b vs 64b libSDL bug and/or darwinia ugly code hack. I'm on 32b so I have no way of helping you there, and I can't guarantee 1.2.8/9 64b will work at all... ;) :) :)

Ignore the libsdl in the darwinia/lib dir -- that 's some glue code or something ugly they did (the "ugly" probably being the prob wrt the new libs). Check your package mgr for what's really installed system wide, and see if it can be backed to an earlier version without breaking too mauch stuuff... should be easy unless you got a LOT of games going.

P.S. this'll be my last post for the day... I'll check back some time this weekend. but I think the prob has been narrowed down to darwinia+libsdl compat issue, OR whatever TGF figured out long ago (but that was a mod issue, not main game IIRC)

have you tried completely erasing your profile and starting fresh? to eliminate any bogus save game info... but I don't think it will help, really.

good luck!
User avatar
briceman2
level2
level2
Posts: 123
Joined: Wed Dec 12, 2007 4:30 am

Postby briceman2 » Fri Sep 12, 2008 6:18 pm

P.S. if you get stuck, and since you seem linux literate and willing to dig, PM "John"... he's the guy that did the linux port, and he's a great guy and responds to PM's fairly quickly (in my experience). He might be able to help you out iof all else fails, but don't bug him until then 'cause they're all in a man crazy push to get Multiminia out the door this month ;)
User avatar
The GoldFish
level5
level5
Posts: 3961
Joined: Fri Mar 01, 2002 9:01 pm
Location: Bowl / South UK
Contact:

Postby The GoldFish » Sat Sep 13, 2008 6:08 am

Seems pretty batshit insane. My suggestion would be try to find a way of forcing vysnc to limit the FPS somewhat.

I'm afraid I'm not sure what else to do, other than be crazy and try using wine, just to see what happens.
-- The GoldFish - member of former GIT and commander in chief of GALLAHAD. You could have done something, but it's been fixed. The end. Also, play bestgameever!

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest